Egbert Drenth

Vertx DA62 - Power and startup??

Recommended Posts

Hi,

I bought the DA62 a while ago but never flown with it until now.
I selected cold and dark startup mode but there is no way I get power on, let alone can start the engines. I suspect my battery is empty.
(Eventhough I have in FSUIPC batteries set to unlimited, but I guess DA62 has proprietary batteries)

In the manual it is advised to enable external power (which I did on the ceiling) then:

  • Pressed Elec Master ON
  • Enabled Fuel levers (on the floor)

G1000 remains black, no power at all. Flipping engines switches to Master as well and starting engines didn't help either.
Any help is welcome.

BTW: does have Vertx a forum. Looked for one on their website but couldn't find.

Egbert

 

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

I would suggest downloading again. I had similar issues with older versions but the latest updates resolved them. 

Share this post


Link to post
16 minutes ago, pedwards said:

I would suggest downloading again

I checked and it appears I already have installed the latest version (V1.053) but I'll redownload/reinstall again.

Share this post


Link to post

Your battery might be drained.….you have to connect the ground power to recharge it.

  • Upvote 1

Share this post


Link to post

I reinstalled and now everything seems to be fine.
Thanks for your help

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now