Cumulonimbus

Again: Speech Recognition

Recommended Posts

Hi there,

 

with the help of various threads in this forum I managed to get the speech training in P2A to work. It was not that trivial on my german Win10-pc...

Ok, still I have the problem to get the Grammar Help to work. I practice the phrases (pressing the PTT button) but P2A seems not to hear me... No sound on replay.

My mic is obviously working: It worked fine with the speech recognition training (in P2A). And I followed the hints in this forums... but nothing.

I'm quite frustrated... And my trial period is getting shorter and shorter.

Perhaps someone has another clue, what I could try to do.

BTW, here is the text of the message window, which pops up when pressing the Practice button. Perhaps that helps:

Active Default Input Device: Mikrofon (Realtek High Definition Audio)

Reco Engine Name: MS-1033-80-DESK

Reco Engine Description: Microsoft Speech Recognizer 8.0 for Windows (English - US)

Language: Englisch (USA)

Grammar: StaticGrammar

Grammar Loaded: True

 

Any help is appreciated.

Timo

 

 

 

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

While the microphone is working with Windows (Speech Training is a Windows program called by P2A), if you don't hear anything with the Replay button, the Mic is not being heard by Pilot2ATC.

When you say you are Pressing the PTT button, I assume it is the one on the screen.  The one on your joystick or other device does not work with Grammar Helper.

Try running P2A as administrator to eliminate resource access issues.

The text message window seems correct, assuming you are speaking into the Mikrofon(Realtek High Definition Device) microphone.  Be sure there are not other input devices with that name or other drivers for the device you are using.  If you have multiple sound input drivers installed, disable all but the one for Mikrofon.

Also, check the volume settings for the default audio input device and perform the "Listen" function in the Windows Recording Device dialog to be sure the signal is strong and clear.  On the Advanced tab, be sure the Exclusive Mode is not checked.

Many PCs come with Sound Add On programs from the manufacturer that are run at startup.  Some of these programs may "Capture" the microphone and prevent Pilot2ATC from hearing it.  Also, some addons may have such features.  Check to be sure there are not other sound programs running.  Also be sure that you have the latest Audio Drivers for your Microphone installed.
 

Make sure you are using a valid call sign by changing it to the default Mfg: Beech; Tail Number: N431VB and pressing the Save Button.  You can send me a screenshot of this page and I will let you know if there is a problem with the call sign.

Let us know what happens.

Dave

Share this post


Link to post
Share on other sites
12 hours ago, Dave-Pilot2ATC said:

When you say you are Pressing the PTT button, I assume it is the one on the screen.  The one on your joystick or other device does not work with Grammar Helper.

Just clarification on this: there are two PTT buttons on screen, one obviously associated with the Grammar Helper, and the other, lower down and next to the "Connect" button, which corresponds to the PTT button.

I've got myself frustrated several times by forgetting this and using the wrong one!

Pete

 

Share this post


Link to post
Share on other sites

Dave,

the hint with the sound addon did the trick! There's really an addon named Nahimic, which is loaded at start up. I terminated it and... it works! (in fact, I don't have any clue, for what purpose I need this app...)

Thanks a lot!

Timo

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now