Sign in to follow this  

Issues with FA call, Flow and Speech Recognition

Recommended Posts


Big fan of FS2Crew here. I own the PMDG 737 and 747, Aerosoft Airbus, Maddog versions and just a few days ago I bought the Dash 8 version. Despite of knowing the intricacies of FS2Crew and its configuration, I am struggling with some weird issues:

1. The most annoying one is that the Flight Attendant don't stop calling me from some point during cockpit preparation until the end of the flight. Every couple of minutes I here "Hello", but I have never called her / pressed the CALL button. I order anything just to get rid of her, it is delivered and moments after I hear "hello" again during for the entire duration of the flight. My guess is that it starts during cockpit preparation after I move the Audio Move Selector to PA to hear the first cabin announcement (about +4 min). After hearing the announcement and making my Welcome announcement, the FA starts her unstoppable cockpit service 🤣😣. Weirdly, I also noticed that after rotating to PA, the PA panel sometimes automatically open and sometimes I have to click PA to show it (w/ some lag).  I have tried finding any shortcuts I may be using that could somehow interfere in the "Call" button, but there is none.

2. FO is not able to read the QNH and Fuel Onboard, instead always reads "0000".

3. After Engine Start Checlist is complete, FO always says 'Looks like we are picking up some ice', it does not mater what is the weather (last time was on a summer day 17oC and the same message was given) and the fact that there is no active ice detection alert. 

4. I noticed the FO is not calling the Vspeeds (last response is the power check) and therefore it does not react to my "Gear Up" call on initial climb. Status keeps locked at <takeoff proc> and the FO keeps repeating "one thousand to go". I have to manually advance to climb phase and then speak "flaps zero, IAS ..." to which he accepts and executes, but keeps repeating "one thousand to go" non-stop after that.

5. Also, I have been struggling with the "On" word pronunciation. No matter how I try, it won't recognise it, but instead it reads "Armed". I am not a native speaker and I know my limitations, but I live in UK for about 3 years and I believe I know how to speak "On" properly. A similar problem used to happen in my 737, which I solved 100% by adding armed / arm / on words in speech dictionary in Windows. Strangely, it works for the 737, but not for the Dash 8. Is this even possible? Edit: Found out that it recognises ''hone" as the pronunciation for 'one'. Never seen this in the manuals or on online videos. Any clues? 

Running P3D 4.5 / Majestic v1.020a / FS2Crew V3.3. / Win 10 64-bit. 

Appreciate any insights. Many thanks!


Edit: Trying reinstalling and remembered to have seen this error when installing C++:


Edited by ArScAn

Share this post

Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

For 1 to 4, sounds like you're using LINDA?

Right?  LINDA and FS2Crew for the Dash 8 don't mix well.  There's a Linda CFG option in FS2Crew to help a bit.

And look at the small print for that error: You already have it installed.  So you can safely disregard it.


And here's how to train your voice for specific words:



Share this post

Link to post
Share on other sites

Hi Byork,

Thanks for the prompt reply. Indeed, I am using Spad.Next for my Saitek panels. I turned on Linda in CFG and it seems to have solved the issues 1 to 4.

Regarding 5, this is really upsetting. As I have been using FS2Crew for a couple of years already, I have trained my computer several times (5x or more) and indeed I noticed a step improvement on doing that. When I first start using FS2Crew, I struggled with On / Arm / Armed in the 737 as well, but after adding the words to the speech dictionary with my own pronunciation, the problem was 100% solved.

Strangely enough, the same pronunciation is not recognized by the Q400 version. At some point, I found out that saying 'Hone' would be recognized as 'one' in the Q400 version, but saying 'hone' is not realistic, so yesterday I added the term 'hone' to the speech recognition and recorded it using a normal pronunciation for 'one'. For my surprise, after that FS2Crew was not responding to both 'one' or 'hone' pronunciations, but instead read it always as 'arm'. Any clues? It is normal that different versions have different pronunciations for the same word? The 737 version continues to work flawlessly. 

Another phrase I cannot make FS2Crew to understand is the fuel readout in tons. It understands thousand kilograms or pounds quite well, but tons is never understood. Adding tons to the speech dictionary did not help.

Thank you! 

Edited by ArScAn

Share this post

Link to post
Share on other sites is the same as Linda.  Set the LINDA option in FS2Crew to Yes to help reduce the interference, but you'll loose some FS2Crew calls the process.

Best bet is to simply not use Spad Next/Linda.

The speech system used in each FS2Crew is the same.  Your results should be identical between versions.

Try this:

"Delete" your Voice Profile in the Windows Speech Control Panel menu.

Create a new one and re-train your voice again.


Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this