Recommended Posts

Posted (edited)

Hi Matt,

I think I did a boo boo with my pta 2.66. Instead of making any backup with my shaders I eagerly applied ini shaders file provided with 2.65 into 2.66 and instead getting an error.
I tried to check and uncheck Urban lighting but still getting the same error messages:

In the end I was able to load initial config file.

Applying preset F:\Program Files\pta_2.66forP3D4.5\MattDavies_Dec18 (2).ini...
ERROR applying preset: source file F:\Program Files\pta_2.66forP3D4.5\SHADERS_BACKUP\Cloud.fx not found
ERROR applying preset: source file F:\Program Files\pta_2.66forP3D4.5\SHADERS_BACKUP\General.fx not found
ERROR applying preset: source file F:\Program Files\pta_2.66forP3D4.5\SHADERS_BACKUP\GPUTerrain.fx not found
ERROR applying preset: source file F:\Program Files\pta_2.66forP3D4.5\SHADERS_BACKUP\FuncLibrary.fxh not found
ERROR applying preset: source file F:\Program Files\pta_2.66forP3D4.5\SHADERS_BACKUP\PostProcess\HDR.hlsl not found
ERROR applying preset: source file F:\Program Files\pta_2.66forP3D4.5\SHADERS_BACKUP\PostProcess\FXAAResolve.hlsl not found
   Applying [Tweak main config (prepar3D.cfg)] to Main config file
Preset has been applied with errors. See log above
Shaders cache cleared

ERROR: backup of shader file F:\Program Files\pta_2.66forP3D4.5\SHADERS_BACKUP\Cloud.fx not exists
ERROR: backup of shader file F:\Program Files\pta_2.66forP3D4.5\SHADERS_BACKUP\General.fx not exists
ERROR: backup of shader file F:\Program Files\pta_2.66forP3D4.5\SHADERS_BACKUP\GPUTerrain.fx not exists
ERROR: backup of shader file F:\Program Files\pta_2.66forP3D4.5\SHADERS_BACKUP\FuncLibrary.fxh not exists
Shader backup F:\Program Files\Lockheed Martin\Prepar3D v4\ShadersHLSL\GPUTerrain.fxh has been restored to F:\Program Files\pta_2.66forP3D4.5\SHADERS_BACKUP\GPUTerrain.fxh
ERROR: backup of shader file F:\Program Files\pta_2.66forP3D4.5\SHADERS_BACKUP\PostProcess\HDR.hlsl not exists
ERROR: backup of shader file F:\Program Files\pta_2.66forP3D4.5\SHADERS_BACKUP\PostProcess\FXAAResolve.hlsl not exists
Shaders cache cleared
Backup of config file F:\Program Files\pta_2.66forP3D4.5\CONFIG_BACKUP\Prepar3D.cfg has been reatored to C:\Users\Bilal Asif Khan\AppData\Roaming\Lockheed Martin\Prepar3D v4\Prepar3D.cfg
 

Edited by biloo

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Easy one to fix ...

... just reinstall the P3Dv4.5 *CLIENT*. It will re-create the shaders folder in P3D root.

I always make a backup of the folder immediately after an upgrade. Quite a few files, but they're all tiny - so it doesn't take long at all.

Adam.

Share this post


Link to post
Share on other sites

Thanks Adam,

I just did that. Quick question regarding the new pta 2.66. PTA 2.66 I downloaded doesn't have Matt's ini file. Can I use the one provided in v2.65 zip file ?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now