Quijote

Planes with G1000 won't follow GTN750 flight plan SOLVED:

Recommended Posts

Hello, I have spent half-a-day testing and have to report that I cannot get any plane with a builtin G1000 to follow the flight plan I enter into a "floating" GTN750. I am in VR as well. However, planes with the older GPS models 530 will follow the flight plan just fine. The G1000 error isn't noted until there is a change of direction. The plane starts the turn but in the middle stops turning and just goes straight. If I click on NAV on the G1000, it will return to the new magenta line and finish the turn. I must select NAV after every change of course. At first I thought that this was an error only with new planes with modified G1000s like the Epic or King Air 350, but when I started testing on the C172 I found that all G1000s react the same - and all the 530s work.

WHAT'S NEW: I have just begun to notice that, when the 750 is following a flight plan, the G1000 or 530 also show a magenta line and the name of the next waypoint.... but only a line to the next waypoint, not the rest of the flight plan. They didn't used to do that. When we get to a turn, the G1000/530 puts up a new magenta line and the next waypoint. But halfway through the turn the plane exits NAV mode and starts going straight. I have to tell PlaneCommand "LNAV" or push the NAV button on the G1000. Then we go back to the magenta line.

So it appears that the 750 is controlling the plane fine when LNAV is initiated and when the flight plan has a change of course, the 750 gives the new waypoint and magenta line to the G1000 but forgets to say "follow the magenta line".

I use the 750 in ALL my planes and I never noticed this before because I used to just set a direct destination on the 750 and then use graphical editing to add new waypoints. The plane always followed the course including the turns, but putting the waypoints into a flight plan isn't working. Is there something that I am missing in the settings???????

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Hi,

first for all the G1000 IS also a GPS and this will inevitably conflict with another GPS. What you'd want is our upcoming G600/500 instead which is more or less only the 'display' part of the G1000 without the navigation computations (nor the engines).

Having said this, the GTN/GNS V2 will always update the next waypoint and overwrite any stock GPS/FMS flight plan. This is meant for any EFIS displaying the next waypoint next on their screens, like the one found in the SAAB 340.

For more waypoints, just enable the advanced option: "Update Simulator GPS Waypoints" (see our latest user's manual revision).

Please note autopilot coupling is independent from the waypoints and is controlled at the autopilot level directly. However, if your disable "Connect GPS to Autopilot", the default autopilot will fly the waypoints which are set from the GTN/GNS V2 at least, but these will be all flyover types (the X-Plane SDK has very little to offer to change the flight plan).

Share this post


Link to post
Share on other sites

Thank you, Jean-Luc,

PROBLEM SOLVED! I went into the Gauge Options and changed the GPS Source from Auto to GPS1. That means that the 750 is replacing the GPS1 which was the G1000. Now the plane follows the flight plan and makes all the turns. The magenta line no longer appears on the G1000 which is just fine with me. In one of the recent upgrades, that status must have changed and now it is solved again. Another happy client......

Share this post


Link to post
Share on other sites

Hi Quijote,

However this leaves me with another puzzle: by default GTN_750_1 is using GPS1 (if source is set to Auto).

Were you using the GTN_750_1?

Share this post


Link to post
Share on other sites

I'm sorry, I don't know what is A GTN 750_1. I have had a 750 for a while now so it is probably an older version. I selected GPS1 as the active GPS and that is working. 

Share this post


Link to post
Share on other sites

GTN_750_1 is the 'code' to say: a GTN, model 750, unit #1 (as opposed to a unit #2). This is the encoded section name for this device in the RealityXP.GTN.ini file too, and the encoded name you'd find illustrated several places in the User's Manual. This is also the same name (without the '_') which displays atop the Configuration Panel.

So, were you using a GTN 750 Unit #1 or Unit #2 in this aircraft?

Share this post


Link to post
Share on other sites

I looked in the ini file and it says that I was using the 750_1.

BTW, I took your advice and activated "Update Simulator GPS Waypoints" and now the G1000 displays all the legs of the flight plan. I have gotten it to work on the Diamond DA62 and the Epic E1000 so far and it is perfect.

  • Like 1

Share this post


Link to post
Share on other sites
On 4/17/2019 at 2:11 PM, Quijote said:

I went into the Gauge Options and changed the GPS Source from Auto to GPS1.

2 hours ago, Quijote said:

I looked in the ini file and it says that I was using the 750_1. 

And this is why I'm puzzled: when using 'Auto' the GTN is looking for its unit#. If it is #1, it overrides GPS1 and if it is #2 it overrides GPS2. In fact, manually selecting GPS1 for GTN#1 is exactly the same as selecting Auto for GTN#1 (supposedly).

I know there has been a few other customers reporting a similar issue with the NAV source setting, where they needed to manually set NAV1 instead of Auto for GTN #1.

I still don't know why this is happening but I'm starting to see some similarities and this gives me a hint to explore.

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now