Jump to content

tupues

Artifacts on p3d v4.5

Recommended Posts

Posted (edited)

Hello all,

 

Yesterday I decided to finally install 4.5 (I'd been on 4.2 all this time too lazy to update). So I did the update, just installing the content and the client thus trying to avoid having to install addons over again.

I am not confronted with strange artifacts that seem to be caused by vegetation.

So far I tried:

 

  • switching dynamic vegetation on and off
  • reinstalling contents making sure to have a clean autogen and texture folder
  • installed the latest Nvidia driver
  • playing with various options in settings including v-synch and triple buffering (although I think this could be one of the culprits… not sure I tried everything there)

Of course turning the autogen vegetation off solves the problem, but thats not the idea. I reckon I either have a faulty autogen somewhere or its a graphics card issue. One way or the other I am missing something.

Sorry for the quality of the video. The first part shows me panning around and the second switching views…

 

I do have ORBX sceneries installed, but they are (mostly) up to date...

I am grateful for any help, Tom

Edited by tupues

Share this post


Link to post

Someone else had this issue when 4.5 first came out. They fixed it with a fresh P3D install, but you can maybe try uninstalling/reinstalling Orbx Global, Trees, and Libraries.

Share this post


Link to post
31 minutes ago, Rasterfahnder said:

Try to delet this folder:

"C:\Users\your user name\AppData\Local\Lockheed Martin\Prepar3D v4\Shaders"

gl

 

Tried that, no luck sadly.

 

15 minutes ago, itsjase said:

Someone else had this issue when 4.5 first came out. They fixed it with a fresh P3D install, but you can maybe try uninstalling/reinstalling Orbx Global, Trees, and Libraries.

A fresh install altogether I am guessing will solve it. However I'd rather avoid that work for now…

Share this post


Link to post
Posted (edited)

Reinstalling ORBX libraries can be done in no time.

X:\Lockheed Martin\Prepar3D v4\ORBX\User Documents\Versions\

Delet the FTX_AA_ORBXLIBS.TXT file
Then start FTX Cental, it will show the libs as uninstalled. That way you don't have to reinstall everything. Works with any file in this folder.

I feel you mate, there are not many things on an sunday so anoying as to see your sim brake. Hang in there v4.5 is worth the work. Had to reinstall it my self but boy it was worth the effort.

Edited by Rasterfahnder

Share this post


Link to post

Thanks Bic,

that thread looks very promising. I will try the mentioned and get back!

Share this post


Link to post

That was it.

Followed this

Quote

Postby venzi » Wed Apr 24, 2019 1:46 pm

OK, finally figured out what was causing it on my setup. I had a plugin called URP (which is something like PTA - shader tool) in my Documents\Prepar3D v4 Add-ons. I did the following:
 
  1. Uninstalled URP from the Windows Control Panel
  2. Deleted <Prepar3D v4>\ShadersHLSL
  3. Deleted C:\Users\<username>\AppData\Local\Lockheed Martin\Prepar3D v4\Shaders
  4. Ran the 4.5 Install_Client.msi and selected "Repair". This installed the factory ShadersHLSL
It's all working now, including: the new beta ActiveSky, REX SkyForce 3D, OrbX Trees, even PTA!
Edit: PTA is latest 2.66 which has some (possibly unrelated) fix to support 4.5

and it now works perfectly!

 

Thanks to all involved. I am glad I waited a little before I uninstalled everything!

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...