Sign in to follow this  
Pete Dowson

"coreprio" gives me BSODs with P3D4!

Recommended Posts

Posted (edited)

I read in a thread here about the system addon "coreprio", which dynamically adjusts cores for running program threads in order to even out the loadings.

As one of those users who sees Core 0 maxed out most of the time I thought I'd try it.

It appeared to work well.  Task manager showed a good spread of cores being used, with core 0 only occasionally spiking to 100% loading.

Today, however, when putting more load onto P3D4 (my normal 'stress' test scenarios at EGLL and EHAM, with up to 200 AI), I started getting Blue Screens of Death stating "CLOCK_WATCHDOG_TIMEOUT".  These might happen during loading the scenario, or after it had been running a little while, or even twice during P3D loading.

I looked at all the changes I'd made recently.  I even uninstalled a couple of Windows updates which occurred over the last couple of days. I only thought of CORPRIO last, and, bingo, disabling that seems to have done it.

Now I should point out that my system is heavily overclocked (and well cooled though -- 9900k CPU never more than 35C despite being clocked at 5.5GHz with cache at 5.0GHz), so such problems may well not occur in more 'normal' systems. But I thought I'd post this as a warning.

It's a pity. I was hoping to get a completely stutter free experiece (I don't get many, but certain there are some little stutters over London and approaching EGLL). But little stutters are better than BSODs!

Pete

 

 

 

Edited by Pete Dowson

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

CLOCK_WATCHDOG_TIMEOUT on an overclocked CPU usually means your overclock is unstable.

Share this post


Link to post
Posted (edited)
2 minutes ago, Sethos1988 said:

CLOCK_WATCHDOG_TIMEOUT on an overclocked CPU usually means your overclock is unstable.

Yep I agree here...

Edited by awf

Share this post


Link to post
2 hours ago, Sethos1988 said:

CLOCK_WATCHDOG_TIMEOUT on an overclocked CPU usually means your overclock is unstable.

I know why it is BSODing!  But I've had this overclock running perfectly for weeks now, ever since Rob Ainscough built it for me in February, and it has done many hours and often with heavy loading, with no BSODs till now (except before I realised I needed to turn on the external cooler at least 10 minutes before daring to turn on the PC! 😉 ).

With COREPRIO there must be a lot of extra load being put on something somewhere (NOT registered by Task Manager in which everything looks hunky dory).

Anyway, I think I've solved it. I examined the settings in CORPRIO and saw that I had

Prepar3D.exe;*

set for the processes to be optimised. I hadn't noticed the * when I put the P3D entry in. 

So I guess it was trying to play with the core affinities for every process in the system (and there are a lot of them; 12 Apps and 57 "background processes").

With that changed to just "Prepar3D.exe" it seems good again. I'll give it a good workout to be sure.

Thanks anyway! 😉 

Pete

 

 

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this