Jump to content

Recommended Posts

I'm running P3D V4.5 with the last hotfix. I am NOT running the public beta MD82. I have 1.4b414 installed and no expansion at the moment.

I am consistently getting a CTD and it's always within seconds of the FO checking the gear on the preflight. Since it's showing in Event Viewer as an ntdll.dll problem, I'm cautiously saying it's something associated with FS2Crew somehow. Given it happens at the exact same time every time, I'm guessing it must be related. 

Here's what  Event Viewer has to say in case it's of any help:

Faulting application name: Prepar3D.exe, version: 4.5.12.30293, time stamp: 0x5cd47aad
Faulting module name: ntdll.dll, version: 10.0.17763.475, time stamp: 0x3230aa04
Exception code: 0xc0000374
Fault offset: 0x00000000000fb049
Faulting process id: 0x2b60
Faulting application start time: 0x01d5184ccb2eacce
Faulting application path: D:\Lockheed Martin\Prepar3D v4\Prepar3D.exe
Faulting module path: C:\Windows\SYSTEM32\ntdll.dll
Report Id: 67faf7c0-f895-4f04-8e54-3f31168b0a4c
Faulting package full name: 
Faulting package-relative application ID: 

 

Any thoughts? I have yet to run a flight with the MD in P3D because this CTD has always happened. I have also tried things to boost performance like clearing my shaders and deleting my P3D.cfg since ntdll.dll CTDs are usually results from system overloads.

Share this post


Link to post
Share on other sites

Like I said, I thought it might've been a long shot since it happened at the same time every time. But I just tried to load a different aircraft that's been working and that one crashes instantly now with a runtime error. Its definitely a bigger issue with something somewhere. Sorry for the false alarm. 

Share this post


Link to post
Share on other sites

I seem to recall reading that most NTDLL issues are associated with over-clocking or bad video drivers.

At any rate, check that link I sent you.

Cheers,

 

Share this post


Link to post
Share on other sites
Posted (edited)

First, the more I troubleshoot this the more I'm convinced I have a bigger problem with my installation. I've been having addons randomly fail to load with the sim (like FSUIPC of all things) in addition to the other issues I mentioned earlier. I also stumbled across people having the same issue I'm having with my Airbus (runtime error leading to CTD or blank screens) but on PMDG aircraft. It's linked to REX. I guess their latest patch was bugged? I tried without external addons and everything seems to behave but I didn't run a full flight. It's late and I work first thing so I will try a flight without any REX addons and report back tomorrow. 

After further tests I'm noticing a pattern as far as this specific issue. On one test, I managed to get past the FOs gear test only to have a CTD on climb out when the flap lever went to be moved. I think the CTDs are linked to levers being moved in the case of the MD80. I wonder if in my setup all that action behind the scenes in combination with REX was what overloaded my system.

On a side note, I did look up ntdll.dll issues before posting here and even looked at things in your link. My system is fairly new (about a month now) and I don't believe anything is over-clocked. Or at least nothing should be. One post here in AVSIM had a CTD guide and suggested looking at dll's. Looking further I did notice something odd in my dll.xml file. There are a lot of addons installed that are NOT listed. This includes FS2Crew. Is this normal for P3D? I only finally made the switch with this new system. I looked in the dll.xml in both my AppData and ProgramData folder and have no FS2Crew entries at all. 

 

Edited by rgamurot

Share this post


Link to post
Share on other sites

The only FS2Crew program that uses the DLL.xml is RAAS and the upcoming UGCX.

P3D v4 has twice the memory limit of FSX, so it'll be hard to overload.

But try turning your sliders down and see if that makes a difference.

 

Share this post


Link to post
Share on other sites

Running without REX has seemed to solved the problem. Not sure how it affected the MD80 but  I managed to complete an entire flight. Only problem is flickering in the sim at altitude but I doubt this is the appropriate place to troubleshoot that. 

I did turn down sliders in cruise but I never had low FPS this entire time. It also didn't affect the flickering FWIW.

Share this post


Link to post
Share on other sites

Glad you seem to have isolated it.

Cheers,

 

Share this post


Link to post
Share on other sites

Hey Bryan. I just wanted to give an update.

I followed the preflight flow more closely and I narrowed down the exact cause. It was specifically the REX Radar. After the gear check, the FO does the radar check. That's what was triggering the CTDs. Not sure why that one time I managed to get into the air and the flap lever caused the CTD. But as far as the repeatable CTDs on the ground it was linked to the radar test. 

Share this post


Link to post
Share on other sites

You should alert REX and the Maddog developer about this.

Good find!
 

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...