Jump to content

Recommended Posts

Hello,

I'm getting the error below when I try to play a Cereproc voice in P2A. In the past I could play them but I could not mix them with Ivona voices. I updated my Cereproc voices to version 5.01 and in the Speech Recognition Text to Speech dialog I can play Cereproc and Ivona just fine.

Cereproc_Error.png

Rob

 

Share this post


Link to post
Share on other sites

This is a CereProc installation issue.  Other users who've had this issue found that they had more than one version of CereProc voices installed.  Once all voices were upgraded, they started working.

Share this post


Link to post
Share on other sites

Hello Dave,

Thanks for your response, but they are working in windows speech recognition. I can switch between ivona and cereproc voices without a problem. In the past that wasn't possible either. I'll check the installation.

Best,
Rob

 

Share this post


Link to post
Share on other sites

Be sure you reboot your PC after installing or updating voices.  You might also want to reset the voices for each controller on the Voices tab of Config, just to be sure the voices are set from the updated list.  Make sure there are not multiple voices with the same name.

The voices are managed by Windows and P2A just asks Windows to provide a list of installed voices.  It then asks windows to load a voice when it's needed, from the provided list.

It does not delve into the details of actually making the voice work....like looking for dll entry points.  That is done by Windows.

Share this post


Link to post
Share on other sites

I only have 5.0.1 voices installed but the old tts engine 4.0.4 is still there. I can try to remove that one as well as all the entries in the registry.

Rob

 

Share this post


Link to post
Share on other sites
Posted (edited)

That sounds like a good plan.  If that doesn't do it, you could try reinstalling the 5.01 version after you've removed the 4.04 version.  And reboot after the new install.

Edited by Dave-Pilot2ATC

Share this post


Link to post
Share on other sites

Hello Dave,

Issue solved. I uninstalled all my Cereproc voices (5.0.1) then I cleaned the registry from all the entries that contained 'Cereproc'. Rebooted installed one Cereproc voice for testing. Went to the Windows Speech Recognition Text to Speech option dialog and tried the Cereproc voice: ERROR again. So I started checking all the options in the Speech Recognition screens. In the Speech Recognition option screen the language was on English US but there was also the option English UK, so I tried changing that and voila now it works in the voice selection screen! I can switch between Ivona and Cereproc voices again. Don't ask me why because my region setting is on English US. Then I tried it in P2A and there it also works. Maybe a Windows update changed the setting? I don't know, but such thing cost too much time. 

Best,
Rob

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...