Jump to content

Sign in to follow this  
MrSpeaker

Payload manager p3dv4

Recommended Posts

Not sure why there is not a sticky or help on their website but I cant seem to find any info on how to fix the payload manager, it will not function. I cant load anything. Im using the latest update of the lear and p3dv4.5. Also is there any info to calculate V speeds for take off


 

as.jpg

Seinfeld Quote of the Month:

"Course, it would have to be someone who hasn't heard the story before. Someone who is unencumbered by any emotional attachment. Someone whose heart is so dark, it cannot be swayed by pity, compassion, or human emotion of any kind"

Share this post


Link to post
Share on other sites
45 minutes ago, MrSpeaker said:

Not sure why there is not a sticky or help on their website but I cant seem to find any info on how to fix the payload manager, it will not function. I cant load anything. Im using the latest update of the lear and p3dv4.5. Also is there any info to calculate V speeds for take off

What do you see with the Payload Manager -- are any fuel values displayed? Did this problem start after you updated to ver 4.2g of the Lear? If so, did you uninstall the previous version first?

One thing you can try is loading the default F-35 first, which seems to help initialize some of the sim variables, and then switch to the Lear -- this has helped some folks. You do not want to use any saved flights saved before you updated the Lear.

If that doesn't help, you can try uninstalling and reinstalling the Lear, If you do this, make sure you use the uninstall option under Programs and Features in the Win10  Control Panel.

Al

 

 

Edited by ark

Share this post


Link to post
Share on other sites

the payload manger pops up, however when you try to click to add passenger or fuel  nothing happens, I dont have any saved flights and this was the first time installing the lear on my new pc, v4.2g, I will try loading the the f35 as you suggest.


 

as.jpg

Seinfeld Quote of the Month:

"Course, it would have to be someone who hasn't heard the story before. Someone who is unencumbered by any emotional attachment. Someone whose heart is so dark, it cannot be swayed by pity, compassion, or human emotion of any kind"

Share this post


Link to post
Share on other sites
36 minutes ago, MrSpeaker said:

the payload manger pops up, however when you try to click to add passenger or fuel  nothing happens, I dont have any saved flights and this was the first time installing the lear on my new pc, v4.2g, I will try loading the the f35 as you suggest.

Hmmm.... my understanding is you can only install the Lear onto one PC at a time (per each account) and the new installer checks for this somehow.  So if this was an UPDATE to v4.2g and there is no record on the new PC showing a previous install, that could be the issue. If the problem persists I would try uninstalling all copies of the Lear that you have via the Win10 Programs and Features and then reinstall. If that doesn't help, you will likely need to contact FSW via

https://www.flysimware.com/FLYSTORE_2015/en/contact-us

and explain the situation and provide your name, email and account details.

Al

 

Edited by ark

Share this post


Link to post
Share on other sites

There website is very vague, wwhat is this xmltool thing, is this something i need to install? 


 

as.jpg

Seinfeld Quote of the Month:

"Course, it would have to be someone who hasn't heard the story before. Someone who is unencumbered by any emotional attachment. Someone whose heart is so dark, it cannot be swayed by pity, compassion, or human emotion of any kind"

Share this post


Link to post
Share on other sites
24 minutes ago, MrSpeaker said:

There website is very vague, wwhat is this xmltool thing, is this something i need to install? 

Short answer, YES!   😉

Assuming you have a typical P3Dv4.5 install, if you go to

C:\Users\YourName\AppData\Roaming\Lockheed Martin\Prepar3D v4

you should have a file called DLL.XML, and in that file you should have a code section that looks like this:

<Launch.Addon>

     <Name>XMLTools64</Name>

    <Disabled>False</Disabled>

    <ManualLoad>False</ManualLoad>

    <Path>XMLTools64.dll</Path>

    <DllStartName>module_init</DllStartName>

    <DllStopName>module_deinit</DllStopName>

  </Launch.Addon>

Although you are not using FSX-Steam, suggest you take a look at

https://www.avsim.com/forums/topic/558321-steam-payload-manager-help/

which will give you some perspective on what to look for regarding the XMLtools entry in the P3D DLL.XML file.

In my P3Dv4 root folder I have a file called XMLTools64.dll which is loaded by the above entry in the DLL.XML file.

Al

 

Share this post


Link to post
Share on other sites

I do not have that entry in my dll.xml file, is the lear installer supposed to add it??? going to try to edit it manually 

 

Edited by MrSpeaker

 

as.jpg

Seinfeld Quote of the Month:

"Course, it would have to be someone who hasn't heard the story before. Someone who is unencumbered by any emotional attachment. Someone whose heart is so dark, it cannot be swayed by pity, compassion, or human emotion of any kind"

Share this post


Link to post
Share on other sites

tried to add it to my dll.xml but no joy.

 

<?xml version="1.0" encoding="Windows-1252"?>
<SimBase.Document version="1,0" Type="Launch">
  <Descr>Launch</Descr>
  <Filename>dll.xml</Filename>
  <Disabled>False</Disabled>
  <Launch.ManualLoad>False</Launch.ManualLoad>
  <Launch.Addon>
    <Name>FSUIPC 5</Name>
    <Disabled>False</Disabled>
    <ManualLoad>False</ManualLoad>
    <Path>Modules\FSUIPC5.dll</Path>
  </Launch.Addon>
  <Launch.Addon>
    <Name>SPAD.neXt LVAR Bridge</Name>
    <Disabled>False</Disabled>
    <ManualLoad>False</ManualLoad>
    <Path>modules\spdbridge64.dll</Path>
  </Launch.Addon>
  <Launch.Addon>
    <Name>as_connect</Name>
    <Disabled>False</Disabled>
    <Path>as_srv\as_connect_64.dll</Path>
  </Launch.Addon>
</SimBase.Document>
<Launch.Addon>
    <Name>XMLTools</Name>
    <Disabled>False</Disabled>
    <ManualLoad>False</ManualLoad>
    <Path>XMLTools.dll</Path>
    <DllStartName>module_init</DllStartName>
    <DllStopName>module_deinit</DllStopName>
  </Launch.Addon>
</SimBase.Document>


 

as.jpg

Seinfeld Quote of the Month:

"Course, it would have to be someone who hasn't heard the story before. Someone who is unencumbered by any emotional attachment. Someone whose heart is so dark, it cannot be swayed by pity, compassion, or human emotion of any kind"

Share this post


Link to post
Share on other sites
18 minutes ago, MrSpeaker said:

tried to add it to my dll.xml but no joy.

 

<?xml version="1.0" encoding="Windows-1252"?>
<SimBase.Document version="1,0" Type="Launch">
  <Descr>Launch</Descr>
  <Filename>dll.xml</Filename>
  <Disabled>False</Disabled>
  <Launch.ManualLoad>False</Launch.ManualLoad>
  <Launch.Addon>
    <Name>FSUIPC 5</Name>
    <Disabled>False</Disabled>
    <ManualLoad>False</ManualLoad>
    <Path>Modules\FSUIPC5.dll</Path>
  </Launch.Addon>
  <Launch.Addon>
    <Name>SPAD.neXt LVAR Bridge</Name>
    <Disabled>False</Disabled>
    <ManualLoad>False</ManualLoad>
    <Path>modules\spdbridge64.dll</Path>
  </Launch.Addon>
  <Launch.Addon>
    <Name>as_connect</Name>
    <Disabled>False</Disabled>
    <Path>as_srv\as_connect_64.dll</Path>
  </Launch.Addon>
</SimBase.Document>
<Launch.Addon>
    <Name>XMLTools</Name>
    <Disabled>False</Disabled>
    <ManualLoad>False</ManualLoad>
    <Path>XMLTools.dll</Path>
    <DllStartName>module_init</DllStartName>
    <DllStopName>module_deinit</DllStopName>
  </Launch.Addon>
</SimBase.Document>

Remove the </SimBase.Document> above. There should only be one of these at the very end of the DLL.XML file. 

Also, if you look at what I posted above for the DLL.XML file, note the entries are XMLTools64.dll -- you apparently entered the 32 bit FSX version instead of the 64 bit P3D version.

Finally, did you happen to check to see if you have the XMLTools64.dll file in your P3D root folder as I mentioned above?

And yes, the installer should of taken care of all this.

Al

Edited by ark

Share this post


Link to post
Share on other sites
4 hours ago, MrSpeaker said:

There website is very vague, wwhat is this xmltool thing, is this something i need to install? 

No this installer installs this for you. So i am not sure how your the only customer who says they ran the installer but the entry is not in the dll.xml file. This just makes no sense.

Anyways AL has posted your mistake now that your manually adding the entry. You had to have done something different.

Edited by Flysimware

Share this post


Link to post
Share on other sites

Here is what you need.

Step 1 update this...

<?xml version="1.0" encoding="Windows-1252"?>
<SimBase.Document version="1,0" Type="Launch">
  <Descr>Launch</Descr>
  <Filename>dll.xml</Filename>
  <Disabled>False</Disabled>
  <Launch.ManualLoad>False</Launch.ManualLoad>
  <Launch.Addon>
    <Name>FSUIPC 5</Name>
    <Disabled>False</Disabled>
    <ManualLoad>False</ManualLoad>
    <Path>Modules\FSUIPC5.dll</Path>
  </Launch.Addon>
  <Launch.Addon>
    <Name>SPAD.neXt LVAR Bridge</Name>
    <Disabled>False</Disabled>
    <ManualLoad>False</ManualLoad>
    <Path>modules\spdbridge64.dll</Path>
  </Launch.Addon>
  <Launch.Addon>
    <Name>as_connect</Name>
    <Disabled>False</Disabled>
    <Path>as_srv\as_connect_64.dll</Path>
  </Launch.Addon>
<Launch.Addon>
     <Name>XMLTools64</Name>
    <Disabled>False</Disabled>
    <ManualLoad>False</ManualLoad>
    <Path>XMLTools64.dll</Path>
    <DllStartName>module_init</DllStartName>
    <DllStopName>module_deinit</DllStopName>
  </Launch.Addon>
</SimBase.Document>

Step 2 confirm this file exists.

Confirm if you have the XMLTools64.dll file in your P3D root folder as I mentioned above?

Edited by Flysimware

Share this post


Link to post
Share on other sites

Thanks guys, I will try it later today and report back. Maybe the issue is I have p3d on a different hard drive. Also I downloaded the xmltools thing from a website and when installing it said it could not find my XML file either. So something is messed up somewhere. Btw there was no xmltools.dll in my p3d folder. 

Edited by MrSpeaker

 

as.jpg

Seinfeld Quote of the Month:

"Course, it would have to be someone who hasn't heard the story before. Someone who is unencumbered by any emotional attachment. Someone whose heart is so dark, it cannot be swayed by pity, compassion, or human emotion of any kind"

Share this post


Link to post
Share on other sites

Okay guys first of all thanks so much for taking the time to help me get this all sorted óut. It works. I have no idea why the installer did not put it anything in my XML file. And I have no idea why even the stand alone xmltools thing I installed could not find my XML file either. But I'm in business now, just got to sober up a bit and take her for a spin lol. 


 

as.jpg

Seinfeld Quote of the Month:

"Course, it would have to be someone who hasn't heard the story before. Someone who is unencumbered by any emotional attachment. Someone whose heart is so dark, it cannot be swayed by pity, compassion, or human emotion of any kind"

Share this post


Link to post
Share on other sites
5 hours ago, MrSpeaker said:

Maybe the issue is I have p3d on a different hard drive.

Sounds like that might of been part of the problem, especially since you didn't have XMLtools64.dll in your P3D folder, which is strange.

Glad all is working now.

Al

Edited by ark

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Donation Goals

    AVSIM's 2020 Fundraising Goal

    Donate to our annual general fundraising goal. This donation keeps our doors open and providing you service 24 x 7 x 365. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. We reset this goal every new year for the following year's goal.


    45%
    $11,410.00 of $25,000.00 Donate Now
×
×
  • Create New...