Jump to content

Gnacino

Issue with Saitek Radio Panel, Digits not liting

Recommended Posts

Hi, The issue I'm having is that the digits don.t always lite up on the panel.  The dials and the buttons work on the sim, but the digits don't always lite up, they're sporadic.  They always run up when I start the pc, so I'm sure there is not a short in the panel.  I have version 3.0.12c on LINDA,  I'm running FSUIPC 5.14, I have Saitek panels selected on the settings in LINDA and they are enabled in joysticks.  I'm running Prepar3D 4.5.13.32097 on WIN 10 Pro 64bt.

Sometimes they're on and at times they are off.  Not sure what is causing this.  Any ideas from the smartest man across the pond?

Gnacino

Share this post


Link to post
Share on other sites

This is a problem caused by Win10 power management. See this thread


Andrew Gransden

Scotland, UK

LINDA Support/Developer - VATSIM and BAVirtual - Airbus Flyer

i7 1TB SSD GTX980 - FSX/P3D - Aerosoft Airbus A318/A319/A320/A321 - FS2Crew

Share this post


Link to post
Share on other sites

Windows 8.1 and Windows 10 brought forward power saving tech for USB devices and that sometimes shuts down power to devices whose drivers fail to circumvent the Windows power saving.

Please do a search in the Avsim hardware joysticks and controllers forum for Saitek and Windows Advanced Power Management, or a web search for "SaitekUSBFix.zip" or "USBEnhancedPowerManagementDisabler.zip".

In Control Panel, Device Manager, Human Interface Devices, locate your Saitek devices, check the properties, and deselect "let Windows manage power for the device".  You may need to unplug then replug devices to recognize them in the list.

 


Frank Patton

Gigabyte GA-Z97X-Gaming 7 MOB; i7 4790 4.4Ghz; 16gb DDR3 2300; MSI GTX970 4gb Gaming 100ME, Coolermaster Pro 5 case, Corsair H100i

Former USAF meteorologist and ground weather school instructor; AOPA Member #07379126

There is no limit to what a man can do or where he can go if he doesn’t mind who gets the credit! - Benjamin Jowett

 

Share this post


Link to post
Share on other sites
10 minutes ago, ScotFlieger said:

This is a problem caused by Win10 power management. See this thread

Scott,
That other topic you linked is great but now closed to additional responses.  Rather than editing the Windows Registry, the following two patches, among others I believe are available, will accomplish the necessary registry edits on the fly.

 "SaitekUSBFix.zip" or "USBEnhancedPowerManagementDisabler.zip"


Frank Patton

Gigabyte GA-Z97X-Gaming 7 MOB; i7 4790 4.4Ghz; 16gb DDR3 2300; MSI GTX970 4gb Gaming 100ME, Coolermaster Pro 5 case, Corsair H100i

Former USAF meteorologist and ground weather school instructor; AOPA Member #07379126

There is no limit to what a man can do or where he can go if he doesn’t mind who gets the credit! - Benjamin Jowett

 

Share this post


Link to post
Share on other sites

Frank

Thank you for the lead. I have added the app as method 3 in the pinned thread.


Andrew Gransden

Scotland, UK

LINDA Support/Developer - VATSIM and BAVirtual - Airbus Flyer

i7 1TB SSD GTX980 - FSX/P3D - Aerosoft Airbus A318/A319/A320/A321 - FS2Crew

Share this post


Link to post
Share on other sites

Thanks guys.  I fixed the problem using Michael Scotts Youtube Video, Saitek Multi Panel Blank Screen Fix for Windows 10 and 8.1

He went thru step by step very clearly and easy to understand by going to regedit.

Thank you for the info.

Gnacino

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...