Jump to content

Sign in to follow this  
Lorby_SI

LorbyLiveTraffic 1.71 released

Recommended Posts

Hello @ll,

this new version of LorbyLiveTraffic is mostly about bugfixes. Additional logic has been added to deal with the currently less than ideal data quality of the RealTraffic client - LLTX will either ignore or try to correct datasets that are obviously wrong or outdated. For example, there are datasets that put an aircraft at 30.000ft at 5kn ground speed (while the real AC hasn't even departed yet); others are displaying the departure and arrival airports of the last flight that the aircraft did, not the current one; on most airports there is no reliable ground traffic data, etc.

IMHO, at this moment, the only really usable LLTX modes are "Sim AI" and "Hybrid", until the data source troubles have been resolved on the providers' end.

The app is available as freeware on the downloads page of the Lorby-SI website

Best regards and a happy new year

Edited by Lorby_SI
  • Like 2

Oliver Binder

LORBY-SI

Share this post


Link to post
Share on other sites

Sounds awesome, never used this before, looking through the manual, I will probably just use the Sim AI function. Just curious will this help control the AI in a better fashion? meaning will separate them better on approach and maybe stop them from taking off and landing into each other?


 

as.jpg

Seinfeld Quote of the Month:

"Course, it would have to be someone who hasn't heard the story before. Someone who is unencumbered by any emotional attachment. Someone whose heart is so dark, it cannot be swayed by pity, compassion, or human emotion of any kind"

Share this post


Link to post
Share on other sites
40 minutes ago, MrSpeaker said:

Sounds awesome, never used this before, looking through the manual, I will probably just use the Sim AI function. Just curious will this help control the AI in a better fashion? meaning will separate them better on approach and maybe stop them from taking off and landing into each other?

Hi,

not really, no. The only thing that it does in this context is a little more separation on approach, but nothing too fancy. Aircraft that are flying behind another one are slowed down a little bit, so they can't catch up. There will still be go-arounds, there is just too much going wrong that could be corrected that way. While both Sim AI and Hybrid mode are based on the real world locations (so aircraft are "naturally" separated better than usual), the simulator logic has final say. The trick is not to have better separation or SID/STAR - that is relatively easy to achive. The real challenge is to make that work with ATC, and that unfortunately is impossible with the SimConnect API.

Best regards

Edited by Lorby_SI

Oliver Binder

LORBY-SI

Share this post


Link to post
Share on other sites
Posted (edited)

Hi Oliver,

When convenient can you please check that 1.72.b02 is working with Real Traffic?  I use AI mode, and with the latest release, no traffic is injected.

I keep the previous installer and reverting makes no difference either. Maybe a Real Traffic issue (although the interface shows a lot of traffic, at WSSS).

Currently I get nothing injected but it was fine yesterday, all I did was upgrade 1.71.b02 to 1.72.b02.

I have tried live mode as well but that is not working either.

Something funky is happening. I am also cognisant that you have said LLTX is hard work, so just a quick look, please don’t spend hours.

It may work again in the morning! I was going to do a flight from WSSS to WADD but did not depart as I started to diagnose why no AI had generated. But can’t figure it out.

Edit, googling has suggested I delete the RT ini file and that may clear the issue. I will try tomorrow (midnight where I live 😎)

Thanks,

Mark

Edited by mwa05

Share this post


Link to post
Share on other sites
Posted (edited)
3 hours ago, mwa05 said:

Hi Oliver,

When convenient can you please check that 1.72.b02 is working with Real Traffic?  I use AI mode, and with the latest release, no traffic is injected.

I keep the previous installer and reverting makes no difference either. Maybe a Real Traffic issue (although the interface shows a lot of traffic, at WSSS).

Currently I get nothing injected but it was fine yesterday, all I did was upgrade 1.71.b02 to 1.72.b02.

I have tried live mode as well but that is not working either.

Something funky is happening. I am also cognisant that you have said LLTX is hard work, so just a quick look, please don’t spend hours.

It may work again in the morning! I was going to do a flight from WSSS to WADD but did not depart as I started to diagnose why no AI had generated. But can’t figure it out.

Edit, googling has suggested I delete the RT ini file and that may clear the issue. I will try tomorrow (midnight where I live 😎)

Thanks,

Mark

Hello Mark,

unfortunately it looks like another datasource of RealTraffic just quit. Most datasets don't have the From/To information anymore, some are even missing the aircraft type. So SimAI and Hybrid mode are dead currently.

RT live mode is working for me though - but you probably have to actiavte "Fill in traffic".

Edit: Sim AI mode is working too, but I had to wait for about 2 minutes before the first aircraft showed up. Most departure/arrival airports will be wrong though, because LLTX is guessing those that are not provided by RT.

Best regards

Edited by Lorby_SI

Oliver Binder

LORBY-SI

Share this post


Link to post
Share on other sites
8 hours ago, Lorby_SI said:

Hello Mark,

unfortunately it looks like another datasource of RealTraffic just quit. Most datasets don't have the From/To information anymore, some are even missing the aircraft type. So SimAI and Hybrid mode are dead currently.

RT live mode is working for me though - but you probably have to actiavte "Fill in traffic".

Edit: Sim AI mode is working too, but I had to wait for about 2 minutes before the first aircraft showed up. Most departure/arrival airports will be wrong though, because LLTX is guessing those that are not provided by RT.

Best regards

Good morning Oliver,

Whether my RT ini file got corrupted or the developer of Real Traffic sorted the data source or a combination of both 🧐 today it is all working.

To use your phraseology AI mode was certainly dead last night but has sprang back to life again today... I guess such is the nature of the beast.

Have a great weekend.

Mark

Edited by mwa05

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Donation Goals

    AVSIM's 2020 Fundraising Goal

    Donate to our annual general fundraising goal. This donation keeps our doors open and providing you service 24 x 7 x 365. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. We reset this goal every new year for the following year's goal.


    2%
    $540.00 of $25,000.00 Donate Now
×
×
  • Create New...