Jump to content

Sign in to follow this  
DrumsArt

P3Dv5 and MCE?

Recommended Posts

Hi,

What about MCE for P3Dv5? Sorry, I've been doing some research, I couldn't find anything on that...So.

Thank you and Regards,

Richard.


Richard Portier

MAXIMUS VI FORMULA|Intel® Core i7-4770K Oc@4.50GHz x8|NVIDIA GeForce GTX 1080ti|M16GB DDR3|Windows10 Pro 64|P3Dv5|AFS2|TrackIr5|Saitek ProFlight Yoke + Quadrant + Rudder Pedal|Thrustmaster Warthog A10|

Share this post


Link to post
Share on other sites
1 hour ago, DrumsArt said:

Hi,

What about MCE for P3Dv5? Sorry, I've been doing some research, I couldn't find anything on that...So.

Thank you and Regards,

Richard.

Haven't installed it yet.

An update will be required, at least for GSX integration and installers to add files where appropriate.

Meanwhile, you could try this...

Copy fsInsider64.dll and fsInsider.ini files from \Prepar3D v4\ to \Pepar3D v5\

Copy <MCE dlls> from \Prepar3D v4\ to \Pepar3D v5\

Go to C:\Users\your_user_name\AppData\oaming\Lockheed Martin\Prepar3D v5\

Open "dll.xml" and add these lines (before the very last line in file) so that P3D can load "fsInsider64.dll". Normally wizard does that automatically.

<Launch.Addon>
        <Name>Multi Crew Experience</Name>
        <Disabled>False</Disabled>
        <ManualLoad>True</ManualLoad>
        <Path>fsInsider64.dll</Path>
</Launch.Addon>

You should get a prompt to authorize fsInsider64.dll to load. Allow it to.

Either file loads fine and everything works as expected (except GSX integration) and you can change "<ManualLoad>True</ManualLoad>" to "<ManualLoad>False</ManualLoad>" to do without the prompt, or will have to wait for the updated fsInsider64.dll that will be fully tested under V5.

Waiting for feedback.

Thanks.

Edited by FS++
  • Upvote 1

Share this post


Link to post
Share on other sites

Thank you very much Gerald 👍

Richard.


Richard Portier

MAXIMUS VI FORMULA|Intel® Core i7-4770K Oc@4.50GHz x8|NVIDIA GeForce GTX 1080ti|M16GB DDR3|Windows10 Pro 64|P3Dv5|AFS2|TrackIr5|Saitek ProFlight Yoke + Quadrant + Rudder Pedal|Thrustmaster Warthog A10|

Share this post


Link to post
Share on other sites
23 hours ago, DrumsArt said:

Thank you very much Gerald 👍

Richard.

You're welcome.

I'm waiting fo LM to state hardware requirements, as I may need a better GPU.

Any feedback on this?

 

Share this post


Link to post
Share on other sites
1 hour ago, FS++ said:

You're welcome.

I'm waiting fo LM to state hardware requirements, as I may need a better GPU.

Any feedback on this?

 

It is clear that P3Dv5 is more demanding on the GPU than its predecessor. Then it all depends on your settings, resolution and so... With my config, with very high setting, ORBX Cityscape Honolulu (for testing) + FSDT PHNL+A2A Bonanza, my 1080ti was at 70% memory usage. I'm afraid that 2 or 4Gb is a bit tight unless to drastically lower the settings.

Richard.


Richard Portier

MAXIMUS VI FORMULA|Intel® Core i7-4770K Oc@4.50GHz x8|NVIDIA GeForce GTX 1080ti|M16GB DDR3|Windows10 Pro 64|P3Dv5|AFS2|TrackIr5|Saitek ProFlight Yoke + Quadrant + Rudder Pedal|Thrustmaster Warthog A10|

Share this post


Link to post
Share on other sites
3 hours ago, DrumsArt said:

It is clear that P3Dv5 is more demanding on the GPU than its predecessor. Then it all depends on your settings, resolution and so... With my config, with very high setting, ORBX Cityscape Honolulu (for testing) + FSDT PHNL+A2A Bonanza, my 1080ti was at 70% memory usage. I'm afraid that 2 or 4Gb is a bit tight unless to drastically lower the settings.

Richard.

Thanks. Will go for 8 GB.

I assume you're up and running with MCE + P3D V5.

If that's the case, can you just check quickly whether fsInsider64.dll still has access to ATC options. Sometimes it breaks between flight sim versions.

Switch MCE to Native ATC mode, then ask co-pilot "confirm ATC options".

You should hear the content of atc window (options section)  read out to you aloud.

 

Share this post


Link to post
Share on other sites
On 4/18/2020 at 8:29 PM, FS++ said:

Thanks. Will go for 8 GB.

I assume you're up and running with MCE + P3D V5.

If that's the case, can you just check quickly whether fsInsider64.dll still has access to ATC options. Sometimes it breaks between flight sim versions.

Switch MCE to Native ATC mode, then ask co-pilot "confirm ATC options".

You should hear the content of atc window (options section)  read out to you aloud.

 

Ok, "confirm ATC options" is perfectly read by the CP.

I might add that the GSX menu with Brian talking came up when I restarted MCE after turning it off.
However, the command text no longer appears at the top of the screen, instead the P3D text is displayed even if I use the option to "reset text display in fs".

FSUIPC v6.0.3.0

MCE v2.8.38

Richard.

Edited by DrumsArt

Richard Portier

MAXIMUS VI FORMULA|Intel® Core i7-4770K Oc@4.50GHz x8|NVIDIA GeForce GTX 1080ti|M16GB DDR3|Windows10 Pro 64|P3Dv5|AFS2|TrackIr5|Saitek ProFlight Yoke + Quadrant + Rudder Pedal|Thrustmaster Warthog A10|

Share this post


Link to post
Share on other sites
5 hours ago, DrumsArt said:

Ok, "confirm ATC options" is perfectly read by the CP.

I might add that the GSX menu with Brian talking came up when I restarted MCE after turning it off.
However, the command text no longer appears at the top of the screen, instead the P3D text is displayed even if I use the option to "reset text display in fs".

FSUIPC v6.0.3.0

MCE v2.8.38

Richard.

Thanks for the report.

MCE will be adapted as soon as possible.

 

Share this post


Link to post
Share on other sites
On 4/22/2020 at 4:16 PM, DrumsArt said:

Ok, "confirm ATC options" is perfectly read by the CP.

I might add that the GSX menu with Brian talking came up when I restarted MCE after turning it off.
However, the command text no longer appears at the top of the screen, instead the P3D text is displayed even if I use the option to "reset text display in fs".

FSUIPC v6.0.3.0

MCE v2.8.38

Richard.

This replacement dll will restore command text, restore support for RC4 as well as integrate with GSX.

Edited by FS++
  • Like 2
  • Upvote 1

Share this post


Link to post
Share on other sites
2 hours ago, FS++ said:

This replacement dll will restore command text, restore support for RC4 as well as integrate with GSX.

Thanks a lot Gerald 👍

Richard.


Richard Portier

MAXIMUS VI FORMULA|Intel® Core i7-4770K Oc@4.50GHz x8|NVIDIA GeForce GTX 1080ti|M16GB DDR3|Windows10 Pro 64|P3Dv5|AFS2|TrackIr5|Saitek ProFlight Yoke + Quadrant + Rudder Pedal|Thrustmaster Warthog A10|

Share this post


Link to post
Share on other sites
2 hours ago, FS++ said:

This replacement dll will restore command text, restore support for RC4 as well as integrate with GSX.

Hi Gerald, because of my guess, that kind words not told enough, compared to complaints, i just want to let you know, that i´ve made some legs today in P3D V5 with MCE and it works perfectly like a swiss clockwork. I´ve used PF3 also and it´s the normal Duty for my CoPi to take care of all the comunication and i wasn´t able to notice any difference compared to P3D v4.5. And all this without the replacement dll. This one i will use next time.

By the way for me it seem that V5 is Pretty Pretty good in backward compability. I´ve installed all the OrbX stuff for V5 and also some other Airports from Aerosoft which are already have a V5 installer. On top i just connected V5 to my other V4.5 Airports via xmls and i can´t notice any issues. On top of that my SIM runs smooth as silk. it seems that the new DX12 take more advanteage out of the RTX GPU and the CPU cores.   


Bernd

P3D V5.2 -  PC spec: Intel i9-9900 overclocked 5 GHz HT off, 32 GB RAM, GPU Nvidia RTX2080, 2xM2 SSD, Skalarki HomeCockpit and Jeehell FMGS on a dedicated Server, PF3 for ATC, MCE, GSX, EFB, AS+ASCA and OrbXpf3-supporter.gif

Share this post


Link to post
Share on other sites

@FS++

Hello Gerald,

There is a problem with the last version (2.8.4.3), it does not recognize aircraft, the v2.8.3.8 does not generate this problem.
I don't know if it has something to do with the fact that when I run MCE, the splash screen still shows v2.8.3.8 instead of 2.8.4.3.
Richard.


Richard Portier

MAXIMUS VI FORMULA|Intel® Core i7-4770K Oc@4.50GHz x8|NVIDIA GeForce GTX 1080ti|M16GB DDR3|Windows10 Pro 64|P3Dv5|AFS2|TrackIr5|Saitek ProFlight Yoke + Quadrant + Rudder Pedal|Thrustmaster Warthog A10|

Share this post


Link to post
Share on other sites
6 hours ago, DrumsArt said:

@FS++

Hello Gerald,

There is a problem with the last version (2.8.4.3), it does not recognize aircraft, the v2.8.3.8 does not generate this problem.
I don't know if it has something to do with the fact that when I run MCE, the splash screen still shows v2.8.3.8 instead of 2.8.4.3.
Richard.

Splash screen shows the actual "mce.exe" file version in \Multi Crew Experience\ installation folder.

If you've been using the patch, suggest you un-install and re-install latest package.

 

Share this post


Link to post
Share on other sites
11 hours ago, BerndB said:

Hi Gerald, because of my guess, that kind words not told enough, compared to complaints, i just want to let you know, that i´ve made some legs today in P3D V5 with MCE and it works perfectly like a swiss clockwork. I´ve used PF3 also and it´s the normal Duty for my CoPi to take care of all the comunication and i wasn´t able to notice any difference compared to P3D v4.5. And all this without the replacement dll. This one i will use next time.

By the way for me it seem that V5 is Pretty Pretty good in backward compability. I´ve installed all the OrbX stuff for V5 and also some other Airports from Aerosoft which are already have a V5 installer. On top i just connected V5 to my other V4.5 Airports via xmls and i can´t notice any issues. On top of that my SIM runs smooth as silk. it seems that the new DX12 take more advanteage out of the RTX GPU and the CPU cores.   

Thanks for feedback.

Indeed. P3D V5 would certainly appeal to those with high-end GPUs (and lots of memory in it). That's where it makes a huge difference.

A Hotfix is due soon. Let's hope won't have to update fsInsider64.dll again 🙂

Share this post


Link to post
Share on other sites

Gerald,

Where do I get the 2.8.4.3 installer?  The download version is 2.8.4.2.

Thanks!

 

 

Edited by DWadsworth

Dave Wadsworth
i9 10900K 5.1Ghz 32G DDR4000 nVidia 3090 
Win 10 21H1 Pro P3DV5.2  ASP/ASCA Pilot2ATC FS2Crew/TIR5/CP

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Donation Goals

    AVSIM's 2020 Fundraising Goal

    Donate to our annual general fundraising goal. This donation keeps our doors open and providing you service 24 x 7 x 365. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. We reset this goal every new year for the following year's goal.


    50%
    $12,670.00 of $25,000.00 Donate Now
×
×
  • Create New...