Jump to content

Sign in to follow this  
SkyhawkN52

FS9 Not working after full reinstall after tweaking Addons

Recommended Posts

I'm not happy when I lose my Flight Sim! For the past few months, I've tried a lot of things to get FS9 working. I've repaired missing .dlls (and yes they were missing off the disk), installed in a non-primary folder, and going through each disk to make sure everything is there. Also, I can't find FS9.cfg anywhere, and I can't figure out where to put it. It's not in Appdata, the game folder, or anywhere as far as I'm concerened. I've also tried terminating rundll32.exe after starting because of how much CPU% it sucks out. I've used addons in the past, so I'm thinking it may have distorted the fs9.cfg a little bit. Please send help, or I might just bash my computer till it works  ;)

Share this post


Link to post
Share on other sites

Its been several years since I have reinstalled FS9 into either Win7 or Win10 but I remember being prompted for some missing .dlls which I found either on the web or in previous running backup copies of FS9.

For starters your FS9.cfg should be here:

C:\Documents and Settings\User\Application Data\Microsoft\FS9

And in F9 Properties, I found this checked run this program in compatibility mode for WindowsXP(Service Pack2).

Other than that please give any error messages that you get when you try and launch the program. I would test the program first before adding back any third party aircraft, scenery or other addons.

Share this post


Link to post
Share on other sites

Also, those missing .dll files went into the main folder and not into the module folder best I remember.

Share this post


Link to post
Share on other sites
Posted (edited)

Sorry I should have specified I'm in W7. I don't get any error messages so far

Edited by SkyhawkN52
More info

Share this post


Link to post
Share on other sites

Did FS launch correctly before you added back any of your addons?

Also, a common issue with Windows 7 was the KB3086225 update.  Did you check for it in your update listings?  It will have to be removed for FS to start. 

Share this post


Link to post
Share on other sites

Provide more details. I am running fs9 in windows 7 with no issues last few months, after  many many years with xp . The ONLY issue i have  and it started last few months in xp and now with win7 i can hear atc but when i speak it is not understandable and a high pitch voice.

nebojsa

Share this post


Link to post
Share on other sites
Posted (edited)

Every thing seemed to work fine until I changed a cfg a little bit on an addon. It started to crash and it was starting to become unplayable. I've already deleted KB3086225, but it might have reinstalled? I've got all the .dlls back, so the options are narrowing down. I've gone through the compatability settings, but it doesn't launch for either of them. I also did a full system scan (sf /scannow) on CMD and nothing corrupt was found. It might be the update, but I am confident it's probably fs9.cfg, but after a full system scan in my CPU hard drive, still couldn't find it! Also Jat, the ACT phased out too before it started having problems. Hope this is more detailed!

(PS it ran on Win XP 2 before the crashes.)

Edited by SkyhawkN52
Forgot More Details

Share this post


Link to post
Share on other sites

I don't think you have a .dll problem if Windows doesn't give you a message box on start with the name of the one that's missing.  If you are trying to insert an old fs.cfg file with settings for hardware you no longer have, it will certainly screw things up.  You need to put a default copy of it (if, as you say you can't find one) in the location I gave in an earlier post if FS can't boot and rebuild it on its own.

If you have commercial addons did you reinstall these also so  Windows has the registry and any proprietary .dlls are also installed?

If Windows still does automatic updates on Win7 then it will reinstall KB3086225 unless you select to manually choose your updates.

Share this post


Link to post
Share on other sites

It's more than likely the update, I'm going to work on it today. More than likely what it is if I can't run it, but would it matter if I used a No CD hack? 

Share this post


Link to post
Share on other sites

The update didn't reinstall, so I'm kind of at a dead end :0 anything would be good at this point. 

Share this post


Link to post
Share on other sites

Just Breaking! I analyzed the wait chain in Resource Monitor and found out that, by looking at the process trees, that fs9.exe waits on rundll32.exe! Now all I need is some help on how to work this problem out, and I think that fs9.exe will be able to boot!

Share this post


Link to post
Share on other sites

Well, I ever had an issue with rundll32.exe and FS9 not starting, but a search on FS9 and rundll32.exe produced a couple of old threads pointing to gameux.dll as the problem:


"In case anyone should search for this problem in the future, here is the answer. Run regedit.Delete any entires under HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\GameUXJust leave Games and MachineSettings in there"

"Got a work-around:
Took ownership of the files 'gameux.dll' in both the System32 and the SysWOW64 directories and renamed them.
Fs9 starts first time with no loading of rundll32.exe or gameux.dll."

If you haven't already found this, might check into it by googling the above.

Share this post


Link to post
Share on other sites

I tried deleting and/or modifiying the gameux.dll files, but it said I needed "TrustedInstaller" in order to do anything about it. Do you know how to work around, Steve?

Share this post


Link to post
Share on other sites

I figured out how to mod the files, and I changed all of the extensions so the system wouldn't recognize it (and yes, I did it for both 64 and 32 bit) and still nothing was showing up. I also tried to change the registry keys, but I don't want to hurt my PC so I left those alone. i am wondering though what would happen if you just straight up deleted every single registry under Gameux since it's pretty much pointless to the system.

Share this post


Link to post
Share on other sites

Okay, I give up... I've done everything there is to fix this... I'm just gonna buy fax, which is a whole different deal, so thanks for trying to help Steve0616... I just love it so much, but if there is just one thing left, I'm willing to try. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Donation Goals

    AVSIM's 2020 Fundraising Goal

    Donate to our annual general fundraising goal. This donation keeps our doors open and providing you service 24 x 7 x 365. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. We reset this goal every new year for the following year's goal.


    28%
    $7,080.00 of $25,000.00 Donate Now
×
×
  • Create New...