Jump to content

Sign in to follow this  
Pdewey

No response for refund

Recommended Posts

I installed p3d v5 and it never worked .  So I asked for a refund or get the v4 instead.  No response after they just said refunds available for first 14 days just send a email.. so sent several emails and just what no response.  Also no support

Share this post


Link to post

Just asking, what do you mean it never worked? You can't get it installed? It crashes on startup?

Share this post


Link to post

It does work actually, presuming you have the minimum hardware specifications.

If you are seeking help in getting started, post some more information about what steps you have taken and problems encountered.

 


Ian S

38.jpg

Share this post


Link to post

For a refund you need to contact LM. Check of you mailed to the correct adres and if a replays is in your spam folder.

Regarding V5 : working great here. If you want helling setting it up then you are at the right place here at Avsim.


Gerard

7940x ( 14 cores ) : 14 cores @ 4.7 - Gigabyte X299 Gaming 7 - 32 Gb G.Skill Trident Z 3200Mhz Cl 14 - Inno3D RTX3090 X4 iCHILL 24 Gb - 1x SSD M2 1800/1800 2TB - 2x  Sata 600 SSD 500 Mb - Thermaltake Level 10 GT case - EKWB Extreme 240 liquid cooling set push/pull - 2x 43” Sony 4K tv's in NVSurround

8700K : all 6 cores @ 5.0 GHz - Asus ROG 370 - 16 Gb 4000 MHz @ 3600 Mhz - Inno3D RTX 3090 X3 iCHILL 24 Gb  - 1x SSD M2 1800/1800 2TB - 2x  Sata 600 SSD 500 Mb - 1x 55” Sony 4K tv

My flightsim vids :  https://www.youtube.com/user/fswidesim/videos?shelf_id=0&sort=dd&view=0

 

Share this post


Link to post
16 hours ago, Pdewey said:

I installed p3d v5 and it never worked .  So I asked for a refund or get the v4 instead.  No response after they just said refunds available for first 14 days just send a email.. so sent several emails and just what no response.  Also no support

So ... how many days had passed until you requested refund?


System: i9 9900k@4.9 - 32 GB RAM - Aorus 1080ti --- Sim/Addons: P3D v5 + ProSim737
Signature3.png

Share this post


Link to post

Sounds like a hardware problem.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Donation Goals

    AVSIM's 2020 Fundraising Goal

    Donate to our annual general fundraising goal. This donation keeps our doors open and providing you service 24 x 7 x 365. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. We reset this goal every new year for the following year's goal.


    33%
    $8,485.00 of $25,000.00 Donate Now
×
×
  • Create New...