Jump to content

Sign in to follow this  
BigT65

Many duplicate key and section name errors

Recommended Posts

HELP! I have just recently started having problems with P3D v4.5 crashing to desktop and weird time issues. Everytime I try to start up a saved flight the Date and Time screen shows Night even if the time would make it show Day. The only way I can get the program to stay on for a flight is to start a new flight from scratch. I activated the error reporting and got a message saying that I had a content error to see file Contenterrors.txt. It shows a long list of Duplicate key name errors and duplicate section name errors. What's going on here and how can I fix it?


i7 8700K CPU @ 4.8 GHz, 32 GB DDR4 3000 memory, Gigabyte Aorus Z370 MB, EVGA RTX 2060 Super XC Ultra GPU 8GB GDDR6 Memory, MasterAir MA610P CPU cooler, 1T PCIe NVMe SSD, 500GB SSD, 2T HDD, 3 Asus 24" monitors, Saitek X56 Rhino H.O.T.A.S., Altec Surround Sound System.

Share this post


Link to post

Sounds like your saved flight file is corrupt.  Try re-creating it by first loading a default acft at a default airfield, and then switch to the acft and location of your choice, then save the scenario and see if that loads better.

Also, if the saved flight starts at an add-on airport, make sure it's still present and active in the scenery library.

 


Bob Scott | AVSIM Forums Administrator | AVSIM Board of Directors

ATP Gulfstream II-III-IV-V

System: i9-10900K @ 5.2GHz on custom water loop, ASUS Maximus XII Hero, 32GB GSkill 3600MHz CAS15, eVGA 2080Ti XC Ultra, Samsung 55" JS8500 4K TV@30Hz, 5xSamsung SSD, eVGA 1KW PSU, 1Gbps internet

SB XFi Titanium, optical link to Yamaha RX-V467, Polk/Klipsch 6" bookshelf spkrs, Polk 12" subwoofer, 12.9" iPad Pro, PFC yoke/throttle quad/pedals with custom Hall sensors, Coolermaster HAF932 case, Stream Deck XL button box

Share this post


Link to post

Thanks for the reply. The crash happens everywhere, in the air or on the ground. All the duplicate keys are in aircraft cfg files. All but 2 of the aircraft listed on the error report start with \FTX NA or \FTX AU, example: \FTX NA Learjet 35\aircraft.cfg.  This makes it look like it has something to do with ORBX. I don't even know why I have all the FTX aircraft. All of the shutdowns happen while flying A2A aircraft.  This is what one entry looks like 

[error.12]
error=Found Duplicate Key Name
 File:E:\Program Files\Lockheed Martin\Prepar3D v4\SimObjects\Airplanes\FTX NA Learjet 35\aircraft.cfg
 Section:fltsim.9
 Key:description

Another thing that happens during flights. For just a split second The whole screen will go blue and a message will appear. Then back to the flight. This had been happening 4 or five time in about an hour and a half. I have never been able to read the message so I don't know what that is but it started about the same time as the crashing problem.

Edited by BigT65

i7 8700K CPU @ 4.8 GHz, 32 GB DDR4 3000 memory, Gigabyte Aorus Z370 MB, EVGA RTX 2060 Super XC Ultra GPU 8GB GDDR6 Memory, MasterAir MA610P CPU cooler, 1T PCIe NVMe SSD, 500GB SSD, 2T HDD, 3 Asus 24" monitors, Saitek X56 Rhino H.O.T.A.S., Altec Surround Sound System.

Share this post


Link to post

I tried your suggestion and loaded up a default airplane at a default airport and flew for about an hour, landed and saved the flight. Later I loaded this saved flight and flew for about a half hour, landed and saved it. I didn't have any CTDs but did get a couple of those split second blue screens with the message. Still no time to read any of it. Then I loaded up one of my saved A2A flights and got a CTD soon after getting in the air. What are all those FTX NA aircraft? When choosing aircraft for a flight they are not on the list. The only place I see them is in the sim objects/aircraft file.


i7 8700K CPU @ 4.8 GHz, 32 GB DDR4 3000 memory, Gigabyte Aorus Z370 MB, EVGA RTX 2060 Super XC Ultra GPU 8GB GDDR6 Memory, MasterAir MA610P CPU cooler, 1T PCIe NVMe SSD, 500GB SSD, 2T HDD, 3 Asus 24" monitors, Saitek X56 Rhino H.O.T.A.S., Altec Surround Sound System.

Share this post


Link to post

Those are AI acft that come with some of their sceneries.  Those error messages should, in an ideal world, get cleaned up, but they aren't likely causing any harm.  Easiest way to deal with them is to turn off the error reporting.

The momentary blue screens...never seen that before.  Normally a Windows blue-screen error persists, and is a sign of a serious hardware or OS fault.  Never seen one just pop up and then go away, even if the error is intermittent, but I won't go so far as to say it can't happen.  Make sure you don't have another program running in the background that could be popping up and doing this.

Might not be a bad idea to open the case and make sure there's no loose cables...check both ends of the power and data cables to the drives especially.

Did you try creating a new saved flight with the A2A plane using the sequence I outlined?  If the existing scenario file is corrupt, which is what I suspect is your problem, then it won't load no matter what you do to get into it.  The trick is to create a new one from a clean start as I outlined. 


Bob Scott | AVSIM Forums Administrator | AVSIM Board of Directors

ATP Gulfstream II-III-IV-V

System: i9-10900K @ 5.2GHz on custom water loop, ASUS Maximus XII Hero, 32GB GSkill 3600MHz CAS15, eVGA 2080Ti XC Ultra, Samsung 55" JS8500 4K TV@30Hz, 5xSamsung SSD, eVGA 1KW PSU, 1Gbps internet

SB XFi Titanium, optical link to Yamaha RX-V467, Polk/Klipsch 6" bookshelf spkrs, Polk 12" subwoofer, 12.9" iPad Pro, PFC yoke/throttle quad/pedals with custom Hall sensors, Coolermaster HAF932 case, Stream Deck XL button box

Share this post


Link to post

First off, I started up FSX to see if it is showing any of these symptoms. My FSX has all the same stuff as P3Dv4.5 so it's as close to the same thing as P3D as it can probably get. As it turned out I didn't have any of the problems I am having with P3D. 

The only time I get the quick blue screen is when I am flying P3D. I can barely get a look at it before it disappears. It's kind of like it is loading something. The screen is blue and there is a box in the center with a progression bar and some text. The procression bar is moving quickly to the right, when it gets to the end the blue screen goes off and I am back to flying. It's not like a regular catchup stutter where the sim just stops for a second then continues on.

I had the error reporting turned on to see if I would get something about the blue screen and the CTDs. But all it has is the AI aircraft issues. I thought I might go through the list and edit each one when I have time. There are 63 of them.

I am going to do some more experimenting with the P3D and A2A aircraft and will report back afterwards.


i7 8700K CPU @ 4.8 GHz, 32 GB DDR4 3000 memory, Gigabyte Aorus Z370 MB, EVGA RTX 2060 Super XC Ultra GPU 8GB GDDR6 Memory, MasterAir MA610P CPU cooler, 1T PCIe NVMe SSD, 500GB SSD, 2T HDD, 3 Asus 24" monitors, Saitek X56 Rhino H.O.T.A.S., Altec Surround Sound System.

Share this post


Link to post

A blue screen with a progress bar doesn't sound like an error condition.  What other software are you running?  Could it be a weather program update, or an autosave?


Bob Scott | AVSIM Forums Administrator | AVSIM Board of Directors

ATP Gulfstream II-III-IV-V

System: i9-10900K @ 5.2GHz on custom water loop, ASUS Maximus XII Hero, 32GB GSkill 3600MHz CAS15, eVGA 2080Ti XC Ultra, Samsung 55" JS8500 4K TV@30Hz, 5xSamsung SSD, eVGA 1KW PSU, 1Gbps internet

SB XFi Titanium, optical link to Yamaha RX-V467, Polk/Klipsch 6" bookshelf spkrs, Polk 12" subwoofer, 12.9" iPad Pro, PFC yoke/throttle quad/pedals with custom Hall sensors, Coolermaster HAF932 case, Stream Deck XL button box

Share this post


Link to post
On 9/13/2020 at 9:30 PM, BigT65 said:

This is what one entry looks like 

[error.12]
error=Found Duplicate Key Name
 File:E:\Program Files\Lockheed Martin\Prepar3D v4\SimObjects\Airplanes\FTX NA Learjet 35\aircraft.cfg
 Section:fltsim.9
 Key:description

From the error entry you posted.
You have duplicated  ORBX AI aircraft entries.
This can happen when someone adds them to the \Simobjects folder and also on \Documents\Prepar3D v4 add-ons\ via ORBX Central or manually.


Ramón.
Time, is the one thing no one can buy.
ovbe94a9nab0bbc6g.jpg

 

Share this post


Link to post

Have you turned of AI in the sim to see if it you still get CTD, this is a know problem with incompatible AI aircraft and can happen any time you come into cache range of the faulty AI the sim will throw you back to desktop without warning. 


i9 10900K\ASUS APEX MB \ MSI RTX 2080Ti GAMINGX TRIO \ M.2  Samsung 970 EVO Plus 1TB C Drive \ 2+1TB Samsung 850 EVO \ 2TB BarraCuba \ 32GB G.SKILL Z DDR4 3600MHZ \ Windows 10 Home\ ASUS 28" 4K monitor\ 4TB Portable Drive\P3DV5

Raymond Fry.

PMDG_Banner_747_Enthusiast.jpg

Share this post


Link to post

I finaly got one of the "blue screens" to pop up while I was waiting for it. It was still extremely quick but it appeared to be more of a grayish screen with the progress bar and text. Still could not read any of the text. Something is definately loading. It is not like a scenery load where the sim just stops for a second then continues on. I never saw the progress bar with those. I do not have a weather program that I am using right now so it's not that. I do have FSUIPC setup to record saves every 10 minutes. It could be that. Although I have been using that for ever.  I will turn it off and see what happens. I don't think the AI aircraft or this progress bar has anything to do with the CTDs though. I have a saved flight where I am flying a P-51 civilian around the world. This CTD problem started with that while I was flying through Greece. When I got to Italy I had to give up on that flight because of the CTD. The strange thing is that the CTD always happens in exactly the same place. Even if I delete that flight and all the saved flights and start it over at a different nearby airport. This is what happens. When I get to that point on the map the sim stops and the screen image shrinks up (I use 3 monitors) and if I move my curser the screen goes whitish. Then the only thing I can do is shut it down. Then if I try to start that flight again from one of the saved flights the flight starts to load. When it gets loaded within a few seconds it just crashes to desktop. Because of this geographical component I have uninstalled and reinstalled ORBX Europe Open LC. I have not tried it since I did that late last night. I am also thinking about doing a repair of P3D if I don't solve the problem soon.


i7 8700K CPU @ 4.8 GHz, 32 GB DDR4 3000 memory, Gigabyte Aorus Z370 MB, EVGA RTX 2060 Super XC Ultra GPU 8GB GDDR6 Memory, MasterAir MA610P CPU cooler, 1T PCIe NVMe SSD, 500GB SSD, 2T HDD, 3 Asus 24" monitors, Saitek X56 Rhino H.O.T.A.S., Altec Surround Sound System.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Donation Goals

    AVSIM's 2020 Fundraising Goal

    Donate to our annual general fundraising goal. This donation keeps our doors open and providing you service 24 x 7 x 365. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. We reset this goal every new year for the following year's goal.


    28%
    $7,180.00 of $25,000.00 Donate Now
×
×
  • Create New...