Jump to content

Sign in to follow this  
MrSpeaker

Code: 0x80070141 MS Store

Recommended Posts

I keep getting a Code: 0x80070141 error from the MS Store when trying to get the new update, anyone else getting this? or have got this in the past?

  • Like 1

 

as.jpg

Seinfeld Quote of the Month:

"Course, it would have to be someone who hasn't heard the story before. Someone who is unencumbered by any emotional attachment. Someone whose heart is so dark, it cannot be swayed by pity, compassion, or human emotion of any kind"

Share this post


Link to post
Share on other sites

Try resetting store app's cache. Worked for me during last update. Go in command prompt and type wsreset. Restart the PC and see if that helps

  • Like 1

Share this post


Link to post
Share on other sites
25 minutes ago, rohit32407 said:

Try resetting store app's cache. Worked for me during last update. Go in command prompt and type wsreset. Restart the PC and see if that helps

Thank you!!! this worked for me.  I've been trying for hours to get the update started.   I never got an error message, just endless spinning circles when I clicked on the "download now" icon.  

I just ran wsreset from the command prompt, it took about 30 seconds and then launched the store.   Update then worked from there.   I did not have to reboot.

Edited by N7470
  • Like 1

Share this post


Link to post
Share on other sites

Had the same problem and tried every troubleshooting I could find but the problem remained.

I finally got rid of the error by going into the registry (regedit.exe) to the following branch:
Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Appx\PackageVolumes\
There, I had 3 sub-branches named 1, 2 and 3.

After exporting that branch for safe keeping (just in case), I deleted sub-branch "2" and was then able to install the part from the MS Store.

My MSFS is installed on a dedicated SSD. I don't know if it is appropriate for those having MSFS installed at the default location.

Try at your own risk. This trick I saw on internet, but was reluctant to try at first, but it was my last resort (short of an uninstall/reinstall) and I am glad it worked.

 


 

Normand

Intel i7 9700K @ 4.9 GHz / Asus Prime Z390-A / 32GB DDR4 3200 MHz / GTX 1080 TI 11GB / PSU 750 Watt / Prepar3D V5.1 / Microsoft Flight Simulator / Windows 10 Pro x64

Share this post


Link to post
Share on other sites
16 minutes ago, NBouc said:

Had the same problem and tried every troubleshooting I could find but the problem remained.

I finally got rid of the error by going into the registry (regedit.exe) to the following branch:
Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Appx\PackageVolumes\
There, I had 3 sub-branches named 1, 2 and 3.

 

 

Appreciate the help but that is probably over my head. I'll keep working on it and if I can't get it resolved I'll shoot email off to Microsoft support. Thanks 


John Snyder Jr

Share this post


Link to post
Share on other sites
41 minutes ago, John Snyder Jr said:

Appreciate the help but that is probably over my head. I'll keep working on it and if I can't get it resolved I'll shoot email off to Microsoft support. Thanks 

No problem John, better not touch what you're not comfortable with 😉 that is wisdom.

Edited by NBouc
typo

 

Normand

Intel i7 9700K @ 4.9 GHz / Asus Prime Z390-A / 32GB DDR4 3200 MHz / GTX 1080 TI 11GB / PSU 750 Watt / Prepar3D V5.1 / Microsoft Flight Simulator / Windows 10 Pro x64

Share this post


Link to post
Share on other sites

Thanks guys will try when I get home from work and see if it works. 

 

 


 

as.jpg

Seinfeld Quote of the Month:

"Course, it would have to be someone who hasn't heard the story before. Someone who is unencumbered by any emotional attachment. Someone whose heart is so dark, it cannot be swayed by pity, compassion, or human emotion of any kind"

Share this post


Link to post
Share on other sites

@MrSpeaker     Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Appx\PackageVolumes\   is the correct path in the registry.

It is a general problem and not only related to MSFS. Can happen for example for other games you bought from the store or x-box.

 

The number of entries there depends on how many drives you have in your computer there Windows Apps are installed.

 

You can (have to) delete all entries without a subfolder. These are like copies from the correct entries but without to specify the correct path and leading into the nirvana.

 

Further advice you can find in   forums.flightsimulator.com/t/patch-5-i-get-0x80070141-error-message/309786/5 and reddit (search for 0x80070141).

 

Remember: open regedit as admin and always make a copy before you change something in the registry......

 

Best regards

  • Like 1
  • Upvote 1

Share this post


Link to post
Share on other sites
8 hours ago, stratone said:

@MrSpeaker     Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Appx\PackageVolumes\   is the correct path in the registry.

It is a general problem and not only related to MSFS. Can happen for example for other games you bought from the store or x-box.

 

The number of entries there depends on how many drives you have in your computer there Windows Apps are installed.

 

You can (have to) delete all entries without a subfolder. These are like copies from the correct entries but without to specify the correct path and leading into the nirvana.

 

Further advice you can find in   forums.flightsimulator.com/t/patch-5-i-get-0x80070141-error-message/309786/5 and reddit (search for 0x80070141).

 

Remember: open regedit as admin and always make a copy before you change something in the registry......

 

Best regards

 

16 hours ago, NBouc said:

Had the same problem and tried every troubleshooting I could find but the problem remained.

I finally got rid of the error by going into the registry (regedit.exe) to the following branch:
Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Appx\PackageVolumes\
There, I had 3 sub-branches named 1, 2 and 3.

After exporting that branch for safe keeping (just in case), I deleted sub-branch "2" and was then able to install the part from the MS Store.

My MSFS is installed on a dedicated SSD. I don't know if it is appropriate for those having MSFS installed at the default location.

Try at your own risk. This trick I saw on internet, but was reluctant to try at first, but it was my last resort (short of an uninstall/reinstall) and I am glad it worked.

 

Thanks so much guys, it worked, i had 4 entries, 1,2,3,4 I had to delete 2 and 3, ADMIN should stickey this, probably wont be the last time this happens. I probably would have deleted my sim for a fresh install and it probably still would not have worked, thanks again


 

as.jpg

Seinfeld Quote of the Month:

"Course, it would have to be someone who hasn't heard the story before. Someone who is unencumbered by any emotional attachment. Someone whose heart is so dark, it cannot be swayed by pity, compassion, or human emotion of any kind"

Share this post


Link to post
Share on other sites

@MrSpeaker You're welcome. I am glad it worked.

@stratone Thank you for adding more information regarding this fix. I learned something more today.


 

Normand

Intel i7 9700K @ 4.9 GHz / Asus Prime Z390-A / 32GB DDR4 3200 MHz / GTX 1080 TI 11GB / PSU 750 Watt / Prepar3D V5.1 / Microsoft Flight Simulator / Windows 10 Pro x64

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Donation Goals

    AVSIM's 2020 Fundraising Goal

    Donate to our annual general fundraising goal. This donation keeps our doors open and providing you service 24 x 7 x 365. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. We reset this goal every new year for the following year's goal.


    49%
    $12,400.00 of $25,000.00 Donate Now
×
×
  • Create New...