Sign in to follow this  
siggy

Panning in 2D cockpit

Recommended Posts

I was advised to add the following to the .cfg file (below) but it did not work. Does anyone else know. I for the life of me cannot remember.In the (CONTROLS) section add: pan_in_cockpit_mode=1.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Yes, that directive does work in FS9.But with the new "camera" system in FSX, it doesn't anymore.And as far as I know, there's no way to have this "panning in Cockpit view" in FSX like you could in FS9.But I would love to be corrected on this :-)Rob

Share this post


Link to post
Share on other sites

I reiterate that I require to pan in 2D cockpit mode using my hat switch. If you enable track IR it works, so there must be a way of enabling it to pan with the hat switch.

Share this post


Link to post
Share on other sites

Slip-stream;change the pan mode in the cameras.cfg to Swivel/No-return instead of Ordinal/Return (just like in the VC)*-CameraDefinition.001-*Title = Cockpit (2D)Guid = {B1386D92-4782-4682-A137-738E25D1BAB5}Description = This is the description of the cockpit viewOrigin = CockpitShowPanel = YesSnapPbhAdjust = OrdinalSnapPbhReturn = True//PanPbhAdjust = Ordinal // change this//PanPbhReturn = True // change thisPanPbhAdjust = SwivelPanPbhReturn = FalseYou still get the VC view once you leave the front view, so you may not like it. At least you have an option.Loyd

Share this post


Link to post
Share on other sites

If you want to enter square brackets in forum posts, it can be done. Just enter:[ for the left square bracket: [] for the right square bracket: ]Cheers,Siggy

Share this post


Link to post
Share on other sites

OK, I have tried both of these tips but no change. Please, does anyone know how I can pan in the 2D cockpit using my hat switch? Many thanks.

Share this post


Link to post
Share on other sites

>OK, I have tried both of these tips but no change. Please,>does anyone know how I can pan in the 2D cockpit using my hat>switch? Many thanks.Do like Loyd said but make sure that you are editing the correct cameras.cfg file. There is one in the FSX root folder but this is not the one that you are using. The one that you're looking for is underC:Documents and SettingsApplication DataMicrosoftFSX.Change that one and it will work.R-EDIT - To change format so that :D doesn't get converted to a smiley face. R-

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this