Jump to content

Sign in to follow this  
Steff Fabiano

sudden-FPS-drop to 8 after unpausing (P3Dv4.5)

Recommended Posts

hi community,

everything went fine with about 30 FPS until a week ago. But since a few days I start P3D v4.5 and as soon as I unclick PAUSE, FPS drop to 8 !!? and no flying is possible anymore. I did not change anything inside the PC, same settings as last week.

I checked WIN10 updates, Defender settings, Performance (CPU 20%, GPU 30% standing at a gate, so a lot of room for calculations), deselected any frame-killer like UTliveTraffic, GSX, GSX2 and so on, but the frames per second stay around 8. When pressing PAUSE again, the FPS rise to around 30 ! What can be the reason ?

Did you encounter this weird situation before ?

Thanks for any idea

Share this post


Link to post

... and the weirdest thing is, that for testing, I started MSFS2020 before to look, if it´s performance is the same. but it runs smooth as always at around 40 FPS ... Now why is it P3D v4.5 reacting so strangly all of a sudden ??

Share this post


Link to post

When reboot the PC and then start P3D and load the P3D default flight do you see the same problem?


Best Regards,

Vaughan Martell - PP-ASEL KDTW

Share this post


Link to post

Did Win10 sneak in an automatic update? 

You might try clearing out your shaders.


Bob Scott | AVSIM Forums Administrator | AVSIM Board of Directors
ATP Gulfstream II-III-IV-V

System: i9-10900K @ 5.2GHz on custom water loop, ASUS Maximus XII Hero, 32GB GSkill 3600MHz CAS15, EVGA RTX3090 XC3 Ultra
Samsung 55" JS8500 4K TV@30Hz,
3x NVME 2x SATA Samsung SSD, EVGA 1KW PSU, 1Gbps internet
SoundBlaster XFi Titanium, TOSLINK to Yamaha RX-V467 HT Rcvr, Polk/Klipsch 6" bookshelf spkrs, Polk 12" subwoofer, 12.9" iPad Pro
PFC yoke/throttle quad/pedals with custom Hall sensors, Coolermaster HAF932 case, Stream Deck XL button box

Share this post


Link to post

yes there was an WIN 10 update, but i already uninstalled it, cleared the SHADERS and to be sure - the prepare.cfg.

without any success until now

Share this post


Link to post

I investigated last 2 days what the reason might be ...

I found in taskmanager under process - the entry WINDOWS AUDIO which was already in 2nd to 3rd row from the top, so very busy for the pc and disabled it - which gave me right away my around 40 FPS back !!! I have no idea where it came from ...

Now there is something strange left over that did not happen before ... When taxiing out (away from gates) i notice micro-stutters now every 3-4 seconds, the same when taxing-in to gates later (at another airport). But shortly after lift-off, everthing is smooth and the flight is stable.

Do you have an idea, what issue it could be ?

Thanks.

 

Share this post


Link to post

Could well be you have (or had) multiple active audio devices that are conflicting with each other.

Just a guess, your stutters may be issues with a looping audio file associated with taxi?

Might be a good idea to check all your audio devices and update/reinstall drivers.  If there are any you don't use (like the HD Audio on most nVidia video cards), disable them in the Device Manager.  Make sure your default audio device wasn't changed by the Windows auto-update.  And set your audio devices explicitly in P3D rather than using the default setting.  Do the same for any add-ons like PMDG acft that have their own audio configs .

 


Bob Scott | AVSIM Forums Administrator | AVSIM Board of Directors
ATP Gulfstream II-III-IV-V

System: i9-10900K @ 5.2GHz on custom water loop, ASUS Maximus XII Hero, 32GB GSkill 3600MHz CAS15, EVGA RTX3090 XC3 Ultra
Samsung 55" JS8500 4K TV@30Hz,
3x NVME 2x SATA Samsung SSD, EVGA 1KW PSU, 1Gbps internet
SoundBlaster XFi Titanium, TOSLINK to Yamaha RX-V467 HT Rcvr, Polk/Klipsch 6" bookshelf spkrs, Polk 12" subwoofer, 12.9" iPad Pro
PFC yoke/throttle quad/pedals with custom Hall sensors, Coolermaster HAF932 case, Stream Deck XL button box

Share this post


Link to post

Thank you for your ideas ... the problem was the AUDIO file (noticed in process-manager). Now it runs smooth again.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Donation Goals

    AVSIM's 2020 Fundraising Goal

    Donate to our annual general fundraising goal. This donation keeps our doors open and providing you service 24 x 7 x 365. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. We reset this goal every new year for the following year's goal.


    49%
    $12,400.00 of $25,000.00 Donate Now
×
×
  • Create New...