Sign in to follow this  
jdyoung

Has anyone else noticed...

Recommended Posts

the HSI on the Mooney Bravo does not turn properly when the aircraft is turning in slew mode. The HSI turns at a much slower rate than the actual turning of the aircraft resulting in an erroneous reading on the heading when switching back from slew to normal. The only way to reset the HSI after exiting slew mode is to reselect the aircraft from the menu. Try it and see.John

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

How true! However, I only use slew to positon my aircraft on the ground for a good starting position (parking spot) and then save the flight for future use. I don't like the default parking spots.

Share this post


Link to post
Share on other sites

On many aircraft synchronising the HSI is a manual operation as part of the pre-flight and startup. You'd be amazed how many thing in FS you take for granted are actually an OVER-simplification of the real thing.;)Allcott

Share this post


Link to post
Share on other sites

Have you got your engine running and avionics switched on before you slew? I noticed in FS9 that I would get this problem if I slewed the aircraft before firing up the donk and switching the avionics on. You could always taxi the aircraft to your chosen spot and direction then switch the donk and electrics off before saving.Bon Voyage

Share this post


Link to post
Share on other sites

Thanks for the input. I believe that most of the time the engine/avionics are off before I slew. I appreciate your help!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this