Sign in to follow this  
McCrash

Help With a Couple of FSX Problems?!

Recommended Posts

I need some help on a couple of problems I am having with FSX.1) Default Autopilot: When I set an altitude, say 3500 feet, press the ALT button (but NOT also the NAV or HDG button) and then activate the Autopilot button, the newly engaged autopilot will not allow me to change course....I cannot steer the aircraft...it resists banking or turning (even though I have only set ALT). I would just like to hold an altitude while adjusting course, say while I am intercepting an ILS. Am I doing something wrong in the way I am setting the default autopilot, or does anyone else have this problem, or am I not using the autopilot properly? 2) Responding to ATC: Sometimes when I want to hit "1" to acknowledge an ATC command, I hit the "1" key but nothing happens. This is only occasionally (usually the "1" key response works fine). When it doesn't work, I quickly close and reopen the ATC window and then the "1" key works again. Does anyone else have this problem with FSX?Thanks,Steve JonesKHEFBasic System Specs: Dell XPS 600 Gen5 P4 650 3.4GHz (800FSB) w/HT 2MB Cache, 1 GB Dual Channel DDR2 SDRAM @ 667MHz, Dual 256MB PCI Expressx16 GeForce 6800 in SLI w/.9147 drivers 1280x1024/32/85Hz, 250GB Serial ATA HD (7200rpm) 72% free, SB Audigy 2 ZS, Windows XP Media Ed SP2, DirectX 9.0c, Viewsonic A95f 19in, CHProducts Yoke and Pedals, Ultimate Defrag, PC Pitstop Optimize.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Can't speak for the ATC problem, never use it myself, mostly because I never fly singleplayer anymore haha.The default FSX autopilot automatically turns on the wing leveler if you have altitude hold on. You can resolve that problem on the autopilot on an aircraft by aircraft basis.Load the aircraft.cfg file of the plane in question into wordpad, and scroll down until you find the Autopilot section.Add these lines to that section:default_bank_mode=0default_pitch_mode=0Save it out, restart FSX, and next time you load the plane you should have roll control with autopilot altitude hold on. If it works you can go through the rest of your common rides and similarly fix them up.Hope that helps.

Share this post


Link to post
Share on other sites

Regarding your ATC problem, the answer is yes. It happens to me too. The ATC box loses focus. Are you aware that you can mouse-click the options in the ATC box now? That seems to overcome the focus problem. R-

Share this post


Link to post
Share on other sites

Haldir -Thanks for the fix. I'm sure this must have been covered elsewhere, but guess I missed it. Also, do you know if this a "bug," or is this a limitation with some autopilots and FSX accurately models this particular type? I haven't used the autopilots for some time, but I was sure that on previous aircraft (such as in the A36 in fs9) that I only activated the autopilot altitude hold and still had full roll control.Thanks,Steve J.Basic System Specs: Dell XPS 600 Gen5 P4 650 3.4GHz (800FSB) w/HT 2MB Cache, 1 GB Dual Channel DDR2 SDRAM @ 667MHz, Dual 256MB PCI Expressx16 GeForce 6800 in SLI w/.9147 drivers 1280x1024/32/85Hz, 250GB Serial ATA HD (7200rpm) 72% free, SB Audigy 2 ZS, Windows XP Media Ed SP2, DirectX 9.0c, Viewsonic A95f 19in, CHProducts Yoke and Pedals, Ultimate Defrag, PC Pitstop Optimize.

Share this post


Link to post
Share on other sites

Ron -Thanks for your fast response, and the tip! (Just curious, though, what do you mean by losing "focus," ...could you explain that in more detail?)Thanks,Steve J.Basic System Specs: Dell XPS 600 Gen5 P4 650 3.4GHz (800FSB) w/HT 2MB Cache, 1 GB Dual Channel DDR2 SDRAM @ 667MHz, Dual 256MB PCI Expressx16 GeForce 6800 in SLI w/.9147 drivers 1280x1024/32/85Hz, 250GB Serial ATA HD (7200rpm) 72% free, SB Audigy 2 ZS, Windows XP Media Ed SP2, DirectX 9.0c, Viewsonic A95f 19in, CHProducts Yoke and Pedals, Ultimate Defrag, PC Pitstop Optimize.

Share this post


Link to post
Share on other sites

FS9 behaved the same way with autopilots. The default setting is for the wing leveler to activate when altitude hold is selected. It's neither a bug nor a feature, it just...well... is. :) If your A36 didn't do that it's because it was set in the aircraft config not to, by adding those lines I mentioned, or they used a custom autopilot gauge instead of the default one.I'm not sure whether most real autopilots do that or not as I haven't had the opportunity in real life to fly anything more complex than a Piper Arrow hehe. Maybe someone with more real world experience will comment on that.

Share this post


Link to post
Share on other sites

Hi SteveWell on the ATC issue, I don't know; I dont use it much-in FSX I mostly do what I do when I got to fly in r/l-mostly short to medium VFR flights in singe and twin engine pistoon powered aircraft, around the southern california area. I've never been much into airliners, or even jets, though sometimes I do like to bring out the 737 and do, say a Lindbergh Field to San Francisco Intl run. As I have no money for real flight hours right now, I'm really loving FSX.Anyway, on the autopilot thing, I usually still use the key shortcuts, rather than the panel autopilot; i.e. "Z" to engage, CTRL-Z for altitude hold, CTRL-H for heading hold, CTRL-N for NAV1 hold (or GPS if set that way, I've mapped CTRL-Q to toggle the NAV/GPS swtich, and I found that worked even in planes without a NAV/GPS switch, but they do have to have an autopilot, NAV1, and GPS). There are a bunch of other keys I don't even remember, or, you can configure your own; I've switched a lot of key commands from the defaults to my own combos, that I can either remmeber easier, or type easier, or just like better for some other reason ;)This, to me is easier; for one thing say you're flying around at 08500 feet, just type CTR=Z and your aircraft will settle in at there, no clicking things, etc. Anyway I hope this was helpful.

Share this post


Link to post
Share on other sites

"Focus" (generally) refers to the "active window."What is probably happening is that the ATC window is no longer the active window even though it is up and on top of all other windows (could be a bug, I think I've noticed this from time to time). Since the window has "lost the focus" that window ignores your keypress.In most applications, the title bar of the window currently "with the focus" turns blue to indicate that status.

Share this post


Link to post
Share on other sites

I see you've had lots of great responses here and thought I would add just a small bit...1) Autopilot - I leave the aircraft.cfg alone. After I activate the altitude hold, I then click on the HDG hold and immediately click HDG back off. That's it - CLICK, CLICK and you can then turn.2) Someone else talked to the out of focus. I've got where I use the mouse more than the keyboard and when you click an ATC response that brings the ATC window back into focus.Phill

Share this post


Link to post
Share on other sites

After pressing ALT try CTRL V I believe this disengages the wing leveler and allows you to change course.Len

Share this post


Link to post
Share on other sites

Thanks everyone for the great responses. Even though I've been simming quit awhile, I learned a couple of new things here in your responses that will be a big help in the future!Regarding the ATC window not being in focus, I recently started using a second monitor for my gps/atc, etc, and found being in windowed mode more convenient. Prior to this, I always used full screen mode, so I guess that is why I never encountered the ATC focus situation.Again, thank you all for your friendly help and advice. That is what makes AVSIM such a great place!Steve JKHEFBasic System Specs: Dell XPS 600 Gen5 P4 650 3.4GHz (800FSB) w/HT 2MB Cache, 1 GB Dual Channel DDR2 SDRAM @ 667MHz, Dual 256MB PCI Expressx16 GeForce 6800 in SLI w/.9147 drivers 1280x1024/32/85Hz, 250GB Serial ATA HD (7200rpm) 72% free, SB Audigy 2 ZS, Windows XP Media Ed SP2, DirectX 9.0c, Viewsonic A95f 19in, CHProducts Yoke and Pedals, Ultimate Defrag, PC Pitstop Optimize.

Share this post


Link to post
Share on other sites

Most autopilots for Ga and specifically the king that fs models aircraft do set the wing leveller when turned on. One merely puts it in heading mode, and then turns the heading bug on the compass/hsi to do what you want to do. If you use the stec autopilot which is new to fsx-there is a knob in the center-this will bank the aircraft also. http://mywebpages.comcast.net/geofa/pages/rxp-pilot.jpg

Share this post


Link to post
Share on other sites

Just hit Control h twice to restore heading control.Yes, my ATC selections also lose "focus" fairly often.Regards,Dewey

Share this post


Link to post
Share on other sites

>I need some help on a couple of problems I am having with>FSX.>>1) Default Autopilot: When I set an altitude, say 3500 feet,>press the ALT button (but NOT also the NAV or HDG button) and>then activate the Autopilot button, the newly engaged>autopilot will not allow me to change course....I cannot steer>the aircraft...it resists banking or turning (even though I>have only set ALT). I would just like to hold an altitude>while adjusting course, say while I am intercepting an ILS. >Am I doing something wrong in the way I am setting the default>autopilot, or does anyone else have this problem, or am I not>using the autopilot properly? >>2) Responding to ATC: Sometimes when I want to hit "1" to>acknowledge an ATC command, I hit the "1" key but nothing>happens. This is only occasionally (usually the "1" key>response works fine). When it doesn't work, I quickly close>and reopen the ATC window and then the "1" key works again. >Does anyone else have this problem with FSX?>>Thanks,>Steve Jones>KHEF>>>Basic System Specs: Dell XPS 600 Gen5 P4 650 3.4GHz (800FSB)>w/HT 2MB Cache, 1 GB Dual Channel DDR2 SDRAM @ 667MHz, Dual>256MB PCI Expressx16 GeForce 6800 in SLI w/.9147 drivers>1280x1024/32/85Hz, 250GB Serial ATA HD (7200rpm) 72% free, SB>Audigy 2 ZS, Windows XP Media Ed SP2, DirectX 9.0c, Viewsonic>A95f 19in, CHProducts Yoke and Pedals, Ultimate Defrag, PC>Pitstop Optimize.Just guessing but isn't the 'wing leveler' turned on? When ATC is transmitting you can't transmit.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this