Sign in to follow this  
Guest SuperFortress

MSVCR80.DLL and constant CTD

Recommended Posts

Last week I posted a question about getting a FATAL ERROR in FSX every time I switch from the VC to the external view and then back to the VC. This time I looked at the details of the error and it seems that a particular DLL is the cause of the problem. The MSVCR80.DLL. I have already read the existing thread here about this DLL problem. I've tried everything suggested in the thread but nothing seems to help. I'm so frustrated from reinstalling and reinstalling. I havent been able to use FSX at all and all I've done is experiment and experiment to alleviate this problem but absolutely nothing seems to help:(Does anyone have any kind of advice or suggestions please?Thank you.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Hi SF.Not sure what all you have done but it can really screw things up if you move the file around on your PC. It would have to be registered in the registry again.Do you have Microsoft Defender installed? From what I've read the only solution to this problem on most systems is to uinstall Microsoft Defender.Type MSVCR80.DLL in Google search and you may find some answers.Don't know if this is of any help. Good luck!

Share this post


Link to post
Share on other sites

>Hi SF.>>Not sure what all you have done but it can really screw things>up if you move the file around on your PC. It would have to be>registered in the registry again.>>Do you have Microsoft Defender installed? From what I've read>the only solution to this problem on most systems is to>uinstall Microsoft Defender.>>Type MSVCR80.DLL in Google search and you may find some>answers.>>Don't know if this is of any help. Good luck!I think you're referring to Vista users. I did read about that in various google searches but this scenario does not apply to me since I am using WIN XP PRO SP2.However after spending more hours on this problem today I managed to narrow it down to anti-aliasing. If I completely disable AA in the Nvidia control panel and delete the AntiAliasing line from the FSX.CFG the problem finally stops BUT now I'm left with jagged lines everywhere since I'm not using AA. This is absolutely so annoying! Thank you for the tip though.

Share this post


Link to post
Share on other sites

This is very interesting. Being that you did something related to your video card settings, and the problem seems to go away. Maybe it is a driver related issue of some sort. Did you change your video card drivers before this problem first appeared? Also, have you tried installing new drivers just to see. The other thing you can do, is uninstall the exsisting drivers, then reinstall them again if you don't want to go with newer ones. (newer is not always better). One quick note too, there is a program called Driver Cleaner Pro that is free. This ensures all remnants of the old drivers are out of your system before installing new ones, to avoid conflicts and other issues, If you do go down that road, be very carefull to follow the directions so you do not remove the wrong thing like MB drivers etc... I do hope this helps in some way or another. Keep us posted.

Share this post


Link to post
Share on other sites

I share your pain SuperFortress. I too am plagued with this problem, although not when switching views but when loading certain aircraft. Sad to say, I have tried *everything* to fix this, including emailing both Microsoft and NVidia. But as usual... silence. There doesn't seem to be a fix right now, even rolling drivers back to the original version that first supported my card.Word from Microsoft seems to be that you need to upgrade to Vista and a better NVidia card (check the CTD section for threads discussing this problem).Sorry, but MS/NVidia just don't care about us.Vox

Share this post


Link to post
Share on other sites

>This is very interesting. Being that you did something>related to your video card settings, and the problem seems to>go away. Maybe it is a driver related issue of some sort. Did>you change your video card drivers before this problem first>appeared? Also, have you tried installing new drivers just to>see. The other thing you can do, is uninstall the exsisting>drivers, then reinstall them again if you don't want to go>with newer ones. (newer is not always better). One quick note>too, there is a program called Driver Cleaner Pro that is>free. This ensures all remnants of the old drivers are out of>your system before installing new ones, to avoid conflicts and>other issues, If you do go down that road, be very carefull to>follow the directions so you do not remove the wrong thing>like MB drivers etc... I do hope this helps in some way or>another. Keep us posted.This problem seems to be directly related to the SP1 update for FSX. Each time I did a complete reinstall I made sure to test FSX before installing SP1 and the crash never happened. It started immediately after installing SP1. It was only at this point that I began playing with various Nvidia drivers. Currently I'm using the 162.18 Beta drivers and before that I was using the 158.45 Beta driver. I guess I can try using the non-beta 94.24 driver again. And yes I always use Driver Cleaner anytime I install new video drivers. Thank you.

Share this post


Link to post
Share on other sites

>I share your pain SuperFortress. I too am plagued with this>problem, although not when switching views but when loading>certain aircraft. Sad to say, I have tried *everything* to fix>this, including emailing both Microsoft and NVidia. But as>usual... silence. There doesn't seem to be a fix right now,>even rolling drivers back to the original version that first>supported my card.>>Word from Microsoft seems to be that you need to upgrade to>Vista and a better NVidia card (check the CTD section for>threads discussing this problem).>>Sorry, but MS/NVidia just don't care about us.>>Vox

Share this post


Link to post
Share on other sites

>Is this happening only with add-on aircraft?Unfortunately this happens with any aircraft that I try, whether it's default aircraft or add-on. Thank you.

Share this post


Link to post
Share on other sites

And any add-on utility?Did you try downloading the VS 2005 SP1 redist? It has a new msvcr80.dll, and if you have any add-on permanently loaded that requires it, and that add-on didnt install it for you; that could be a problem.

Share this post


Link to post
Share on other sites

>And any add-on utility?>>Did you try downloading the VS 2005 SP1 redist? It has a new>msvcr80.dll, and if you have any add-on permanently loaded>that requires it, and that add-on didnt install it for you;>that could be a problem.The only add-ons I have for FSX are Flight1 Cessna 172, Active Sky X and X-Graphics however I've tried FSX without any of these add-ons and still manage to get the same problem. I know I did not have this problem prior to SP1. I did try the VS 2005 SP! redist yesterday but that made no difference. So far the only thing that works is disabling AA in the Nvidia control panel and deleting the AntiAliasing line from FSX.CFG. Thank you.

Share this post


Link to post
Share on other sites

>That would indicate a driver problem.I agree but is there a particular Nvidia driver that I should be using instead of my current beta 162.18 driver? Thank you.

Share this post


Link to post
Share on other sites

Hi Phil and thank you for replying.At the moment, I don't seem to have the problem with default aircraft, only with add-on aircraft. However, I can generally get default aircraft to CTD by ALT-TAB task switching out of FSX and back again.I can concur with SuperFortress that switching off all AA seems to fix the problem and that despite trying all available driver versions for my nVidia card none of them solve the problem. I too also only experienced the problem after installing SP1. I have also tried installing the VS 2005 SP1 downloadable with the new msvcr80.dll, but that didn't work either :(I understand that it may well be an nVidia driver problem, but can I say that you at least have had the decency to respond to our problem and that is much appreciated... nVidia haven't even acknowledged my contact with them over this issue and may not even have made themselves aware of it.I guess something changed in SP1 that might well have exposed a video driver bug/shortcoming - is that possible?Vox

Share this post


Link to post
Share on other sites

unfortunately the only advice I can give is to start walking back thru the versions until you find one that works.when you crash, do you get to send a report?

Share this post


Link to post
Share on other sites

Yes, it is possible.Remember that ATI Catalyst AI had an issue with SP1 that cleared up by disabling it. From reports more recent versions of Catalyst have fixed this.So this isnt unprecedented.

Share this post


Link to post
Share on other sites

>Yes, it is possible.>>Remember that ATI Catalyst AI had an issue with SP1 that>cleared up by disabling it. From reports more recent versions>of Catalyst have fixed this.>>So this isnt unprecedented.>>I wish there was a simple workaround like that for Nvidia users as well.The only question now is whether or not Nvidia is aware of this issue and whether or not it is being worked on. Thank you very much Phil for your personal attention to this problem.

Share this post


Link to post
Share on other sites

In this context does 'Beta' mean that the drivers are still in the Beta testing stage and have not been finally released?

Share this post


Link to post
Share on other sites

Hi - I'm so far from being an expert on this it hurts, but I just checked the nVidia drivers, and looked at what cards they support, and I don't believe the 100 + series of drivers supports your card. I believe the highest released version for your card under Win XP is 94.24, so you might want to give that a shot. The 100 + series of drivers is almost exclusively for the 8000 series of cards, according to what I read. The driver selection page ishttp://www.nvidia.com/content/drivers/drivers.aspHTH, Seadog

Share this post


Link to post
Share on other sites

The 162.18 version drivers for XP2 32bit claim to be for all Geforce chips, 7800GS and GTX included.Vox

Share this post


Link to post
Share on other sites

Thanks. You're absolutely right. Hence my admission of lack of expertise. I just never look at Beta stuff as a matter of habit. In this case, I should have looked further before speaking, but my recommendation would have been the same, regardless, to stick with a final release version rather than this 6 day old experimental version. -Seadog

Share this post


Link to post
Share on other sites

Ok I'm not entirely sure if this really works but so far IT'S WORKING! Phil actually made me think about something when he mentioned the problem with ATI's CCC. So I thought to myself perhaps Nvidia's Control Panel is causing problems as well. I went ahead and disabled the Nvidia Control Panel tray icon. Then I went into my registry and deleted a program called NWIZ which can be found in the following key:HKEY_LOCAL_MACHINESOFTWAREMicrosoftWindowsCurrentVersionRunI then used Nhancer to set my AA and AF settings. I ran FSX and so far I've been testing with various aircraft (default and add-ons) with absolutely no more of those horrible CTD's. I could be wrong and maybe the CTD will return but so far it's working like a charm. Perhaps someone else with this problem can try this out and let me know if it works for you. Once again thank you very much Phil.

Share this post


Link to post
Share on other sites

Well I've tried what you've suggested and there's no change for me. I've disabled all of the nVidia CPL tasks using MSConfig and still getting CTD's. But if it's worked for you, that's great news. Hope it stays stable! :)Edit: If anyone is potentially looking into this problem at MS or nVidia, after some more exhaustive testing, I believe here's the skinny on my particular problem with 'msvcr80.dll':With AA turned on in either nHancer/nVidia control panel OR just in FSX itself, if I load any aircraft that is an FS9 aircraft that has been made to be 'FSX-compatible' just after the flight loads I CTD. However, default aircraft and any add-on aircraft built from the ground up for FSX (e.g. RealAir's aircraft) don't seem to cause a CTD.Conclusion: - With AA on, FSX 'compatible' aircraft CTD. - Switching off AA solves the issue across all aircraft. - VS 2005 SP1 Distributable IS installed. - Problem never occured before FSX SP1 was installed. - Issue remains using a wide variety of nVidia drivers.Others may have similar or different issues to the above.Vox

Share this post


Link to post
Share on other sites

>Well I've tried what you've suggested and there's no change>for me. I've disabled all of the nVidia CPL tasks using>MSConfig and still getting CTD's. But if it's worked for you,>that's great news. Hope it stays stable! :)>>Vox

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this