Sign in to follow this  
pouldam

How to make FSX use a reasonable bit depth for colours?

Recommended Posts

Hi,To put it short, I am unable to make FSX use the colour depth configured in the OS. I am running in Windowed mode, but the same appears in full screen.This means that especially colour gradients often look crappy -- e.g. the sky (particularly at dusk and dawn). I have the colour depth set to 32 bit in Windows, but FSX seems to ignore this. To illustrate I have attached an image, showing the FSX menu and a graphic viewer showing the same image file. This way I can verify that my gfx card and monitor are able to show all the beautiful colours -- as long as it is not in FSX.What is even more interessting is that the graphics viewer lists the image as only being 8 bit -- so is my FSX running in 4 bit or something?!? I guess not :-hmmmHave any of you seen this? Any ideas of how to fix this? The NVidia driver does not allow to set a specific colour depth for a specific application as far as I know...WinXP SP2FSX SP1NVidia 7900GS / 256 MBAll the lastest drivers, DirectX runtime, patches etc./ Thanks in advance, Poul

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

>Hi,>>To put it short, I am unable to make FSX use the colour depth>configured in the OS. I am running in Windowed mode, but the>same appears in full screen.>>This means that especially colour gradients often look crappy>-- e.g. the sky (particularly at dusk and dawn). I have the>colour depth set to 32 bit in Windows, but FSX seems to ignore>this. To illustrate I have attached an image, showing the FSX>menu and a graphic viewer showing the same image file. This>way I can verify that my gfx card and monitor are able to show>all the beautiful colours -- as long as it is not in FSX.>>What is even more interessting is that the graphics viewer>lists the image as only being 8 bit -- so is my FSX running in>4 bit or something?!? I guess not :-hmmm>>Have any of you seen this? Any ideas of how to fix this? The>NVidia driver does not allow to set a specific colour depth>for a specific application as far as I know...>>WinXP SP2>FSX SP1>NVidia 7900GS / 256 MB>All the lastest drivers, DirectX runtime, patches etc.>>/ Thanks in advance, PoulWhat is FSX set at in the setting?Like maybe 1024*768*32 for example.

Share this post


Link to post
Share on other sites

I am using a 22" wide screen monitor and have FSX' "full screen resolution" setting set to 1680x1050x32 (have tried to set it to 16 bit, but that did not make any difference) -- however, I normally run FSX in windowed mode where I am under the impression that it uses the default settings set in Windows' Display Properties dialog, right?

Share this post


Link to post
Share on other sites

It's not your problem, a lot of users, including myself, have this problem....something with the nvidia drivers...grrrr

Share this post


Link to post
Share on other sites

Hi Ryan,I am glad to hear that... uh, I guess... in some obscure way.I have been reading this forum regularly since January, but do not remember having seen this issue discussed before. Just to get up to date -- do you or anybody else know if NVidia has been made aware of this and whether all NVidia cards and/or drivers affected by this?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this