Sign in to follow this  
Longers

Unable to Pan at all. Keeps resetting to rear view.

Recommended Posts

Hello,I am unable to pan left right. If i hold he hat left or right it just resets back to rear view. If I hit num8 key it goes to fornt view and then quickly resets to back view again.Same problem inside and outside plane. I checked my joystick config in FSX and looked through the view config for all keys, axes and joy buttons and there is nothing else configured for panning.Marius

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Find the file, Camera.CFG. It's located in C:Documents and SettingsApplication DataMicrosoftFSX. (same folder as fsx.cfg)Open this file with Notepad. In the *first* block (CameraDefinition.001), scroll down to the line:PanPbhAdjust = Ordindal --->change this to SwivelPanPbhReturn = True --->change this to FalseSave the file and if FSX is running you'll have to shut it down and restart it.BTW, the NumPad Del key will center display after a swivel action.Cal

Share this post


Link to post
Share on other sites

Same problem still. Its like gravity. I can pull left or right alittle with the hat and then in goes back to rear view again.

Share this post


Link to post
Share on other sites

Are you using multiple controllers? I have a TrackIR, mouse, racing wheel pedals, joystick, keyboard and sometimes a gamepad and a stylus that I will use all at once. It's possible that you have a conflict. Look at what other controllers you are using, and see if you have a conflict. You might have to unplug them to test for the conflict.As well, you might have a bad calibration in Windows. You should look under the Game Controllers section of the Control Panel (or its equivalent in your system) and see that the buttons and joystick travel are all working correctly.EDIT: Just thinking, if the above does not work, you could try deleting your FSX.cfg file. Just back it up and rename it, and FSX will automatically generate a new one.Jeff ShylukSeniot Staff Reviwer, Avsim

Share this post


Link to post
Share on other sites

Marius,Sometimes the simplest starting point is to go to the controls setup->{buttons/keys} tab and select the "reset defaults" and then try those things that were wacky before. If you have changed some settings there already, make notes first so you can restore them. If you have changes that you start restoring, keep checking to make sure one of these doesn't also restore the problem...The viewing default for the 2D view is the 8 "fixed view" directions (Ordinal) for both keypad and tophat. The default for both is full panning (swivel) in the VC. Spot view defaults are Ordinal/Swivel and the locked spot is Swivel/Swivel.the cameras.cfg lines that cause the 'snap back' are:SnapPbhReturn = True -- for the keypadandPanPbhReturn = True -- for the tophatthese must be "False" if you want the view to remain where you put it.The really strange thing is yours defaulting to a rear view - that's a new one...Hope you find it soon.Loyd

Share this post


Link to post
Share on other sites

Hi Marius, is your num-lock key lit ? I had some problems linking numpad key presses to joystick buttons and the solution was to uncheck the num-lock key.Sorry if this is old infogood luckLongers

Share this post


Link to post
Share on other sites

Hi Marius...........Did you manage to get this problem solved? If so could you post the solution here as I have the same problem and it's driving me crazy.Many thanks.John

Share this post


Link to post
Share on other sites

Sounds as if your Track IR is turned on. If so, hit F9 to turn it off and see if the problem goes away.Dewey

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this