Sign in to follow this  
vgbaron

For Phil Taylor - FSX SP2 WinXP OOM Oddity

Recommended Posts

Phil,Hi. In another post concerning OOM's with WinXP, FSX, and SP2, you wrote the below:"Out of Memory in FSX is almost always running out of process address space. There are 2 fixes:1)reduce settings ( including complexity of the aircraft you are flying ) 2)using the /3G switch by modifying your OS boot to give the process more address space to work within.Note, even if TaskMan shows the process is not using over 2G there can be a problem, in 2 ways:1)when that close to the limit it can be hard to get contiguous ( all in 1 piece ) blocks of the size FSX needs. If the block size isnt available, the app "sees" that as out of memory.2)any system can act strange close to the limits. dont run right at the limits because that is asking for trouble."I've run across something interesting by accident after I recently installed SP2. I don't know if it applies or applied to SP1. And I don't know the "why" it is working, but it has eliminated all my previous OOMs with FSX (which were few and far between to begin with, but they would occasionally happen). I'm curious what your thoughts are about it.I was running FSX and decided to load Task Manager to watch the memory usage. FSX gradually climbed up to over 1,000,000K in usage. I have 4GB memory, and have never applied the /3G switch (I know XP can't really use the 4GB, but I got it for the future when I go to Vista). I would usually get an OOM about the time FSX.EXE hit around the 1,300,000k reading in the past.But I did something "accidentally" that really surprised me by the results. I was running in Windowed Mode on my 3-wide TH2G setup because I also run FSX Commander on a 4th monitor (have to run FSX Windowed to do that). I "minimized" FSX on my "main" monitor...and Task Manager immediately showed the FSX usage DROP from 1,000,000k to around 86,000k usage. When I "un-minimized" FSX back to the monitor, it STAYED at 86,000k, then gradually began climbing back up again. It took over 30 minutes for it to reach anything near 1,000,000k again. So I minimized it again, and got the same results.This got me thinking. I tried the same thing just PRIOR to approaching a major airport with 100% AI traffic loaded. I had absolutely no problem completing the landing, taxiing all over the airport, etc. Not even a hint of an OOM. All of my previous OOMs were like most of the ones posted here in the forums...at the end of a long flight while approaching a major airport.I have no idea why this "works" for me. But it appears that minimizing FSX, then maximizing it again is "releasing" (?) some sort of memory that may be being "hogged" by FSX during a long period of time. Or maybe it is releasing video memory somehow.Do you have any ideas why this is happening? All I know is that it works for me, and I haven't had an OOM by doing it since I "discovered" it. And I'm running just about every darn addon you can think of with FSX...UTX, GEX, FEX, ASX, Radar Contact, etc.Looking forward to your thoughts on this.FalconAFEDIT: I'm also curious if this works for anybody else who may be experiencing OOMs. If anybody else tries this, please post your experience here.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Very good point, Falcon! Never dawned to me to look at task manager during this but almost every time I run into some sort of slowdown or vidoe artifacts I will do 2 things - toggle back and forthe between full screen and window and minimize/maximize FSX. Almost always seems to work.Hope Phil will respond - VicQ6600 G0 CPU 2.4 o/c 3.65Evga 680i A1 with P31 BIOS 2G XP2-8500 DDR2 1066FSB Mushkin 996535 RAM 5-5-4-12-2T320G 7200 HD partitioned for XP/Vista/Programs 2 - 74G Raptors in RAID0 500G 7200 HD for backup SATA DVD burner Evga 8800GTS 640 PCIx 169.13 betaKandalf LCS case w/ built in liquid cooling 850W Thermaltake power supplyVisit the Virtual Pilot's Centerwww.flightadventures.comhttp://www.hifisim.com/banners/hifi-supporter-sigbanner.jpgRadar Contact Supporter: http://www.jdtllc.com/

Share this post


Link to post
Share on other sites

Thanks Falcon for this helpful hint! For me minimizing FSX surely helps, but where is the memory management problem that makes this necessary? Phil Taylor, please, if there is any better idea how to prevent FSX from eating up memory and never releasing it...I have a Q6600, 2 GB DDR, Geforce 8800GT, WinXP SP2.Cheers

Share this post


Link to post
Share on other sites

I know SP2 changed FSX.exe by putting in the switch that showed FSX uses more than 2GB of memory. I wonder if that modification helped your situation? It was mandatory for Vista users to change the FSX.exe prior to SP2 and I don't think many XP users made the change too. I recently suffered from the OOM crashes (with the exact scenerio you stated above -- i.e., at the end of a long flight while approaching an airport) and it was because I allocated too much memory using the "/3GB switch". I have 2 8800GTX video cards with 768GB ea of memory so I lowered the bcdedit increaseuserva amount to 2560. The OOM crashes stopped and hopefully that's the cure I needed for my problem. IMHO, if you have to minimize then maximize your screen while flying, it sort of takes the fun out of playing the game (but OOM's are no fun either!). I think you need to look at the amount of memory allocated for your bcdedit and adjust it accordingly. You should also look at lowering your FSX config settings and/or your video card display settings like I did with my pretty powerful and up-to-date computer system (Dell XPS 720H2C w/30" monitor). Best regards,Jim

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this