Archived

This topic is now archived and is closed to further replies.

Guest D17S

Stu..Stu...Stu..Stutter

Recommended Posts

Ok, so I've had in my eyes a bulletproof stutter free enviro for FSX for quite some time now. I have been flying FTX scenery in Australia for about 4 months and have not even loaded a flight in the US or anywhere else for that matter outside the FTX flight area. Here is my situation..I load up the Cayman Islands with a 737 and notice upon roll that there is a rythmic stutter (frames locked at 30..how I always fly). Smooth as glass for about 3 seconds, and then a stutter choke. I can notice it only when looking out of the side window, look straight and you cannot see it at all. But...its annoying, especially with TrackIR as you look to turn. Now...im thinking its a driver issue for sure. I have udpdated drivers in the past 4 months. So I read and read and try the following driver sets..174.74 beta, 175.16, and 169.21. The SAME with all of them, and yes I know how to remove drivers properly, and follow NickN's advice on defrag and the whole bit. This is an FSX dedicated machine, with only windows XP 32 on it. I played with Vsync back on, then back off, frame lock at 30 up to 50 in increments, even unlimited...same darn thing. Now..next fun step, rip out FSX and follow through with a reinstall, that has to do it. It takes hours, and hours, but I get it done. Back with all addons and all my settings in line. Load up Cayman islands again, same stinkin stutter. So...I knock autogen OFF, no traffic, no nothing, no clouds, mid water...still there. I then load up my hometown, Houston..same thing there. Los Angeles, same..Van Nuys, same...anywhere I go, same....except..and your gonna love this...(sarcasm)Load up inside an FTX region, locked frames at 30...takeoff from Melbourne International in a 737..smooth as glass. Im thiking I changed something, so I load back to Houston, stutter, Middle of nowhere Georgia...stutter. Back to FTX, no stutter. Frames locked at 35, 37, 38, 25, 20, 30...you name it, no stutter. And yes, I am turning FTX mode off when going back to anywhere else. I have tried EVERYTHING, unless you guys can think of something I have not tried.I just find this really odd....I have the addons listed below in my sig, if that helps. Thanks for surviving this rant/read/beg for help.Danon O.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

You may well have done this but defrag your FSX partition for optimal performance using a good, commercial defragger. I can't stress how much of a difference this can make. I recently installed a 20m Victorian mesh but forgot to defrag (which I usually do after every new installation). An absolute slideshow ensued with constant stuttering and chokes .... changing settings made no differnece then I remembered I hadn't defragged. One defrag later and my sim is back to silky smooth ...*WOOPS* - I see you did defrag - my bad ... only just got up and still confussled from sleep ... apologies.Triangle :-)

Share this post


Link to post
Share on other sites

>Load up inside an FTX region, locked frames at 30...takeoff>from Melbourne International in a 737..smooth as glass. Im>thiking I changed something, so I load back to Houston,>stutter, Middle of nowhere Georgia...stutter. Back to FTX, no>stutter. Frames locked at 35, 37, 38, 25, 20, 30...you name>it, no stutter.Personally, I'd try UNINSTALLING FTX entirely and see how it performs......it may only be a coincidence, but...

Share this post


Link to post
Share on other sites

Thanks,Yep I did use both O&O defrag, and also threw Ultimate Defrag in the mix when it didnt change to make sure it was all good. Did a name defrag w/ both programs. The stutter is entirely predictable, like its on a cycle. Thats what gets me thinking it cannot be something in a bind, or under load. Also because it does it everywhere, with and w/out autogen. That pointed me to driver/OS issues. The lean setup I have here took the OS out of the way, so I literally spent 13 or so hours trying different drivers and settings till I was so sick of FSX I could care less to never see it again.I took out FTX like you suggested, and the stutter remains. Installed FTX once more, went to Aus. region and what do you know...no stutters....as long as im in Australia!!Now, I wonder if I should take out GEX, UTX, FEX and try vanilla FSX and see if it stutters, that could point a finger at the only 3 other addons I have on this machine. I have flown my test flight with clear skies so I have my doubts it could be FEX....I'll let you know how it goes...I love large un/reinstalls...phun.danon -

Share this post


Link to post
Share on other sites

My guess is not that the rest ls bad, but the Aussi scenery is especially good. An actual 30 FPS is a lot with high sliders. It is important to remember Frames Per Second are CPU limited. The Vcard it just a conduit for CPU data. Once you have an adequate Vcard "pipe," more Vcard horsepower will not help. The 8800GT is an adequate "pipe." 1) FPS is a function of the clock speed of a single core.2) Texture loading is a function of how many core are operating at that speed.3) Ram's contribution is a function of quantity. 4Gs will help performance over 2Gs. Increased ram speed does NoT provide an advantage.Theory: Any user has only "X" amount of CPU horsepower available. That capacity must be allocated between FSX functions that are CPU dependant. For instance, if a use wants more Autogen some other CPU load must be reduced (like traffic). Big, complicated airplanes are also a big load. So (for instance) if a user wants to fly a big CPU intensive airplane like the PMDG 744, additional sacrifices must be made! The stutters are a symptom of an overloaded CPU. We are going to use this dynamic as a tool to tune the sim for your specific computer. With 'The Stutters,' the frame counter will show 20-40-60 FPS, but visually FS will look like a slide show. Here's what's happening: A strong Vcard will simply repeat the same frame over and over until it gets a new, processed frame from the CPU. It will then refresh the screen with this new frame . . . then repeat that frame until the next one shows up. This is called "The Stutters." Additional Vcard horsepower will not help. Remember, an adequate Vcard is just a conduit. This is why Overclocking the CPU has become all the rage. It's the only thing that helps. A $150 8800GT is Plenty of Vcard for FSX. Once you are above 10K', frame rate is not an issue. The CPU only starts to feel the pain during departure and approach. So, setup your test flight over a metro area. My test flight with the PMDG 744 starts about 10 miles south of Manhattan, inbound for KJFK's ILS13L approach. The final turn is directly over Manhattan. With the settings described above, I can maintain an iffy, but Real ~ 20FPS all the way to the gate. Here's the tuning drill: Unlock the frame rate. Load and unload the CPU with Scenery Objects and Traffic until you find a bearable frame rate. My target is 20FPS. Unload the CPU just a bit more so the FPS average is just above your target. Now lock frame at your target. Save that setting. Other things to play with: Work with the fsx.cfg line: {DISPLAY}TEXTURE_BANDWIDTH_MULT=XFor instance, if you are locked at 25FPS and have TBM set to 40, the system will render (in the background) 40 FPS and attempt to "Fire" then into your 25FSP environment. The idea is to fill-in any of those 25 FPS the system is failing to xfer to the screen. If this strategy is successful, the stuttering effect will be reduced. It will Not be dramatic. The stutters will only appear to "soften." However, there will be a point of diminishing returns. This additional rendering uses resources. Lots. Once the HP loss becomes > the frame fill-in return, higher TBMs will actually Reduce performance. Find that number, then back-off a couple of clicks. (I'm using 70).With our current 128SP cards, 80 is about as high as we can go. It will be interesting to see if the 280 can use this function any better (It doesn't I have a GTX260 in now and it provides No benefit with Anything). In any case, above 100 is A LoT. There's no way Any system is going to render 4000FPS. Just use common sense.It appears this is what the Nvidia control panel's new function "Maximum pre-rendered frames" is doing. We'll have to see how these two (seemingly identical) functions play together. They could turbocharge or auto-destruct. We'll see.If there are pauses or big uber-stutters when panning to view in a new direction, there's hope. MSFS has confirmed FSX CaN use greater than 512M. Good news! So type in the New lines (Square brackets):{BUFFERPOOLS}Poolsize=XThis will set aside a portion of your vcard's memory for quick access. It's like a manual Vcache setting. With my 512M card, I'm using 50M (50000000). If you have a gig on board, go crazy. But not too crazy. Watch for decreased performance as you shift Vram away from ops into cache (the BP).Good luck

Share this post


Link to post
Share on other sites

Gracias,I have no antivirus prog running, nor do I have anything in the backround that could be causing this, that was my first thought. I have checked out CPU usage and ram dedication, and it is all FSX, this is a very lean system.I ran my test, a test flight coming out of KIAH (Houston) left turn towards downtown, lots of stuff to throw at the the system. I experimented with frames from 18-50 locked, and also unlocked. The rythmic stutter is there at all times, but! is ONLY noticeable, like I said, when you look to left/right. straight ahead, you cannot see it or tell it is there....which is why I figured it was tearing from Vsync or something. I should record it and post on youtube, that would make it SO much easier to describe. I have a 512 card and have bufferpools at 10 megs, perhaps I should make that larger. My TBM is at 40 which is default if Im correct. I will play with that and see what happens. My sliders are the same they have always been, and..perhaps this has ALWAYS been there and im being more critical after flying FTX scenery smooth as silk...i dont know. If it happened in FTX regions, I would give up im sure...btw..my test flight is also in a 737 coming out of YMML (melbourne) towards downtown, the autogen is more intense, as are the buildings downtown..so I know FTX is not going easy on me.thanks for the suggestions..danon - -

Share this post


Link to post
Share on other sites

For default airplanes, use the FS benchmarker run. Get it from the Avsim library at FSX > Utilities > benchmark. "fsmark07.zip."Use this as your tuning run. Take BPs to 50M. TBM is a Very fine tune as the Very last tweak. It just smooths the icing on the cake. Try these Vcard settings: -- Vcard setup: nHancer is only optional these days. I don't use it. The latest drivers have FSX using Global setting. Here's a suggested Nvidia Control Panel Global setup (works great with Crysis and CoD too). AF: 16XAA Gama : OnAA: Override / 8X Transparency: OffConf tex : Use HdwrExt limit : OffForce Mipmaps : NoneMax pre-render frames : 3Multi display : as reqTex Fliter: ClampTex Filter : HQThread Opti : OnTriple buff: OffVert Sync : Force onStart with these FSX settings:-- FSX Settings suggestions: (This is a setup that works with my Q6600@3.6/4G-ram/8800GT/Vista 64)-- Graphics:Frame rate - Lock to 20 Resolution - Set to monitors default resolution. Only use primary monitor for FS'ing.Filtering - Antistrophic AA uncheckedLen flare/Adv Anaminations - chk'd (Bloom is a killer. DX 10 is a bust) Global tex res - Full right. -- Aircraft:All chk'd-- Scenery:- Terrain and Water. Note: These sliders are all Vcard related, except Water. An 8800GT is required. Additional Vcard horsepower is not helpful. All, Full right . . . except:Mesh resolution 10mWater effects Low 2.xLand detail tex - On- Scenery Objects Note: These sliders are all CPU related.Scenery complexity - Full rightAutogen - MidGround scenery shadows - Off (Problem prone. Leave it off) Special effects - Low-- WeatherCloud draw distance - 60miDownload winds aloft - On Detailed Clouds - Chk'd-- Traffic. Note: These sliders are all CPU related. All offPlay with "Scenery Objects" to load and unload the CPU until you get 20FPS. Want more. Start turning scenery objects down. Also, that 7000 series Vcard may be limiting. Test with "Terrain and Water" sliders (except water). If you get an honest (non-frame counter) increase in FPS by turning Terrain settings down, it's time to go get an 8800GT.

Share this post


Link to post
Share on other sites