Archived

This topic is now archived and is closed to further replies.

LuisFelizTirado

SBuilder x background LOD Q

Recommended Posts

The default LOD level is Auto.What value should I have such that it maintains the crispness of the area that I want to comile the longest (meaning, I want the airport area) to remain crisp for a larger radius than what Auto does.Currently, the texture loses its resolution real quick when I Leave the area like 3000 feet and when I return, it refreshes. The scenery bgl is quite small area (The airport) and I want this are to be clear from a larger radius.Any ideas?ThanksManny

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

You'll want SBX to use the highest zoom level, which in the best of areas is level 18. From there, when compiling, Resample sets the LODs, which is the Auto that you're seeing. If that isn't giving you the detail you want at distance, then you'll have to see about modifying the INF file that's used by Resample to force a higher level of LOD. I've not tried this, so can't say what the results or impact may be.

Share this post


Link to post
Share on other sites

Hello Manny,The problem is not the LOD level at which the custom textures are compiled, but the LOD levels that the game displays.We have discussed this problem numerous times in the General forum. You can compile to a much lower resolution LOD and it will still get "blurrier" when you move away. That is how the LOD system works.You can force the game to display the highest LOD level for a larger distance by changing the LOD_RADIUS value in the fsx.cfg file. Normally, the values are set with the slider: - Small = 2.5 quadrants displayed - Medium = 3.5 quadrants - Large = 4.5 quadrantsYou can set a higher value in the fsx.cfg file, but please note what Adam Szofran wrote to a beta tester who set this to 8.0:Trust me, you don't want to set the LOD radius to 8. :-) The amount of data loaded increases by the square of the radius. At a radius of 4.5 cells, the maximum value set by the UI, we load about 358 megabytes of terrain data and textures. If you bump the radius up to 8, the terrain engine will try to load over 1.1 gigabytes of data. That's not even including autogen, AI aircraft, airports, sound, etc. so you probably pushed your machine over the edge.Best regards.Luis

Share this post


Link to post
Share on other sites

Thanks guys.And yeah..setting anything over 4.5 is resource hog.I was trying to avoid building ground poly for airports (I don't know how). :) I wanted to use the SbuilderXI managed to edit the bmp file in photoshop and recompile..But can I do this? But can I change the bmp to double the resolution? Meaning..proportionally increase the image size (the bmp) file and not change anything else. The ini file does not have any parameter to say the image size. All it has is a reference to the bmp file and the coordinate the bmp needs to fill. The reason I am asking is... I can then patch up the bmp files with higher resolution textures. I need to test this out.Manny

Share this post


Link to post
Share on other sites

>I was trying to avoid building ground poly for airports (I>don't know how). :) I wanted to use the SbuilderX>Hello,A small note to say that you can texture ground polygons with SBuilderX. Make the polygon and then set its property to textured. Then specify the name of the texture and set some other parameters.Regards,Luis

Share this post


Link to post
Share on other sites

Hi Luis.I don't know anything about ground Poly. I am just starting to read about it.If I build the ground Poly using GMAX and then apply the texture. Now does it become just like any other MDL object that I add to an object library and Place them in a geo location them using something like Instant scenery or do I have to place it on the location by using some other method?Manny

Share this post


Link to post
Share on other sites

Luis,I just discovered the Polys in SBuilder (Duh!). Hee hee. WOW! This is so cool, I am adjusting all the elevation issues and what not. Now, I understand what you mean by Poly of type texture. Let me go try that out.All I want to say is Thank you for this amazing tool. You guys should be the MVP.:)Manny

Share this post


Link to post
Share on other sites

I've done some experimenting with terrain photos @ 6cm resolution. The problem is even at 6 cm, an object that's 1m wide only occupies 17 pixels in the photo. Since my screen resolution is about 96 ppi, that means to display that photo @ 1:1 pixel ratio, the object can only be about 0.2" wide as measured on the screen. i.e, your viewpoint has to be a ways away from it. As you get closer, so that the object uses more screen pixels, it will have to be interpolated creating sharpness problems. IOW, you're not going to see blades of grass kind of thing. So I'm not sure going below about 30 cm really adds much except texture data size.scott s..

Share this post


Link to post
Share on other sites

>I've done some experimenting with terrain photos @ 6cm>resolution. The problem is even at 6 cm, an object that's 1m>wide only occupies 17 pixels in the photo. Since my screen>resolution is about 96 ppi, that means to display that photo @>1:1 pixel ratio, the object can only be about 0.2" wide as>measured on the screen. i.e, your viewpoint has to be a ways>away from it. As you get closer, so that the object uses more>screen pixels, it will have to be interpolated creating>sharpness problems. IOW, you're not going to see blades of>grass kind of thing. So I'm not sure going below about 30 cm>really adds much except texture data size.>>scott s.>.> Hi Scott,I was referring to textured ground polygons that you can add with SBuilderX in addition to photo terrain.Regards, Luisps: I know it is out of topic but I just had to close Firefox and start IE to post this. With Firefox avsim.net and avsim.com acan use cookies but I can not login. The strange thing is that no error appears when I press login but I am redirected to the login page when I press the post button.

Share this post


Link to post
Share on other sites

Very strange, Luis. I only use Firefox here and have never had problems with the forum, but a serious problem with downloading from the library (cannot pause and restart.) It seems that in some instances Firefox is not completely compatible.It sounds as if you are not accepting cookies. It happens to me often, even on the PTSim forum. So, I go to Firefox options, allow cookies and sign in. Then, when the cookie has been created, I go back to options, create an exception for the cookie (allow it), and turn off cookies again. Everything works for a while, until the cookies get corrupted or expire.Basically, I keep cookies turned off and create exceptions for those web sites where I want to go and that I trust.Best regards.Luis

Share this post


Link to post
Share on other sites