Archived

This topic is now archived and is closed to further replies.

Guest GamePlayer

Having issues with X-Plane 9

Recommended Posts

Yesterday I bought X-Plane 9 PC version. One issue I'm having is constant stuttering like every 10 seconds and worse during high speed flight in excess of mach 1. Also I got like a 30 second pause during flight. Another issue I'm having is that after switching views, sometimes I get slow motion until I switch to another view. I have the latest update of X-Plane 9. My system configuration is as follows:Q9450 CPU8800 Ultra video card4 GB DDR-2 800 memory640 GB WD hard driveSound Blaster Audigy 2 ZS sound cardWindows Vista Ultimate 64-bit OS

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Not sure about the stuttering with excess speed. The 30 second pause may be related to the scenery being installed as you fly across the scenery boundaries.You might get a better response to your problems at www.x-plane.org forums.W. Sieffert

Share this post


Link to post
Share on other sites

you may want to try to up the flight models per frame in the settings, that should assist with the flight model at high speeds and also low framerates, i'm not sure if it will fix the problem, but it should hopefully help.Peter ClemenkoStaff Revieweravsimlogo-1.png

Share this post


Link to post
Share on other sites

Hi GamePlayer-I am new to X-Plane and have a sort of similiar system as you. (OC'd E6420, 8800 GTS.) I noticed the stuttering as well on my setup and tinkered with it a bit. I really know our systems can run this flawlessly, and I think the problem lies in the monitor refresh rate. The monitor shows stutters and tearing since the frame rate exceeds its refresh capacity. I have v-synch enabled in my control panel and it still does not cure this as it does in other games.What I recommend is that you download the latest update from X-Plane and go to the rendering options. You will notice the options have changed. There is an option to check "make the frame rate equal to the frame rate of my monitor" or something like that. This fixed my stutters and tearing. Of course, I do not get over 60fps now, but that's still more than FSX was able to provide and the scenery looks much better in X-Plane. Looks like there will be a need to upgrade to a 120hz LCD monitor soon, or go back to "classy" CRTs! :)Hope that helps.-Scott

Share this post


Link to post
Share on other sites