Sign in to follow this  
John_Tavendale

Radeon 9700 users.. HELP.

Recommended Posts

This is to few out there who are running MSFS2002 with a Radeon 9700 Pro. I got one last week and have had some troubles setting it up. It either doesn't display the textures clearly, it stutters like crazy using 4x AA and 16x Ansio, lowering the Ansio doesn't help, or ot freezes up completely :(Which drivers are you using?What settings do you have for Direct3D and OpenGL?Any tweaks, settings you're running that help?Thanks so much in advance, it's frustrating to say the least.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

John,I hope someone replies to your cry for help. My interest is due to my expecting to acquire a new system within the next few days. I hope I don

Share this post


Link to post
Share on other sites

Did you re-format the drive, or at the very list make sure you deleted all parts of the drivers for your old videocard?

Share this post


Link to post
Share on other sites

Sure did, brand new install, SP1 installed, latest official drivers etc. I also tried Medal of Honour, it's also stuttering etc.Really lost for ideas at the moment, don't know if it's me (Probably is LOL) or the card. My CPU is certainly fast enough, so that wouldn't be a bottle neck..

Share this post


Link to post
Share on other sites

Do you know about the site Rage3D (www.rage3d.com)? If you haven't already, post in their Radeon support forum.

Share this post


Link to post
Share on other sites

Have you tried these new (as yet unofficial) drivers?http://mirror2.ati.com/drivers/wxp-w2k-r97...10-6193-efg.exethese have been released just a day or two ago and solved problems for many.edit: you may have to look for other mirrors since the ATi downloads are often VERY slow. Check www.rage3d.com (forums) as someone mentioned earlier.I must say I've had no problem running FS 2002 so far (Athlon XP 2100+, 512 Mb PC2100, Asus A7V333, Gigabyte Maya II Radeon 9700, Soundblaster Live!, Windows XP) even with earlier drivers.settings: 1024/768*32, all FS sliders max, locked at 20 fps, D3D at FSAA 4x and Aniso 8x, 'quality' texture/mipmap detail; still experimenting with settings to find ideal IQ/FPS balance though.I DID have stutters early on though, in both FS 2002 and 3DMark 2001, and this was caused by programs running in the background, such as Asus Probe (mobo monitor), Alcatel DSL modem tray program, MS Messenger. These didn't cause stuttering earlier on (GF3) but the stuttering became apparent when I switched to the ATi. As I was using neither of these programs regularly, I eliminated them all and that cured the stuttering.Hope some of this helps, Martijn

Share this post


Link to post
Share on other sites

John, it appears I may have somewhat the same problem. Just built a new FS system this weekend. My settings are as follows: Windows & FS2 1280x1024/32, card setting anti-aliasing 4x, anisotropic 4x, FS anti-aliasing off. Here's my problem and what I have found. From computer cold boot, it boots very fast. Windows desk top looks good, start FS2, appearence is all blocks running what appears to be 640x480x16. Review of FS2 display settings, it does don't show my orgnial setting. Close down FS2 to check display and receive the following fault after click on control panel, settings, advance (An exception occured while trying to run "shell32.dll, control_RunDLL" C:windowssuystem32desk.cpl." display. To correct this problem,I found by simple reboot or starting the computer again after the cold boot (boot-up appears to take longer as compared to cold boot), the computer & FS runs great. I have about 3.2 hours on FS and it works and looks great running at FR limit set at 30. I would be very interested in knowing what is going on and how to fix this problem. Wish you luck.ASUS A7V33/AMD 2200+/512 Ram(Crucial DDR PC2700)Power Supply ANTEC SL400Crucial 128 Radeon 9700 Pro 4X/Driver Crucial 7/25/2002 6.13.10.6143 HD Seagate 40 7200Dell P991/85 HertzWin XP Home

Share this post


Link to post
Share on other sites

Looks like your control panel hasn't been installed properly (.cpl files are control panel apps) Ati drivers and Ati driver control panel sometimes come in seperate packages. Maybe one of these was'nt installed properly. Perhaps you should try reinstalling new drivers. The ones I referred to in earlier post are 6.13.10.6193.Current 'official' drivers at Ati's own site are 6.13.10.6166, here you can also download the control panel package. In the www.ati.com homepage, look for 'find a driver' in the 'Powered by ATI' section or try the link in my earlier post.Good luck!

Share this post


Link to post
Share on other sites

JohnI know that when I installed windows service pack 1, my Geforce card was acting wierd, I didnt have the prob without the SP1 installed though, so try removing the service pack, might fix the prob!Tyler Johnson

Share this post


Link to post
Share on other sites

Thanks for the suggestions, I'll shut down all the things running in the background and see if that works.I am running the latest drivers, they didn't seem to show any difference in MSFS than the other ones I have tried.Tyler: I have tried without SP1 also, and it didn't make any difference.

Share this post


Link to post
Share on other sites

Well I have tried changing the AGP Apature size, installed the latest Intel inf set, Application Accelerator, different drivers, closed everything in the background, made sure the R9700 had it's own unique IRQ and still nothing.

Share this post


Link to post
Share on other sites

Martijn,I'm curious as to the frames and smoothness of your system PRIOR to getting the Radeon card. I have a machine with similar specs as yours - if not identical (except without the video card) and want to see if I can expect the performance you are getting now!Thanks!-Greg

Share this post


Link to post
Share on other sites

I've got a solution. Return your 9700 and pop your Ti4600 back in. ;-)Ryan-Flightpro08 :-cool VATSIM Pilot/ControllerZLA ARTCC Controller 1 (C-1)SAN TRACON Lead [link:www.taxiwaysigns.com]Taxiwaysigns.com Scenery Designerhttp://members.cox.net/santracon/images/san_logo.jpg-----------------------------My "Home Made" System Specs:Intel Pentium 4 2.2GHz ProcessorTurbo Gamer ATX Mid-Tower with 420W Power SupplyEPoX 4G4A Motherboard with Intel 845G ChipsetVisiontek XTASY GeForce4 128MB Ti4600 (Det 30.30 Drivers)512MB PC2100 DDR RAM40GB Matrox 7200RPM Hard DriveWindows XP Home Edition SP1*No CPU or GPU Overclocking*3dMark2001SE Score: 11298

Share this post


Link to post
Share on other sites

I wish Ryan. I don't have that option, I wish I did.I need to run some more tests to see if it's me, or the card.I know there are two Radeon users out there who have no problems, come on fellas, help me out eh? :) Please :)

Share this post


Link to post
Share on other sites

HI John,I am using the 6.13.10.6166 driver ,open GL,and direct 3D main settings max quality,AA 4X,anisotropic filtering 8X,Texture and mipmap all the way to the right,vertical sync to application preference.My system is a P4 2.8Asus motherboardP4B533ECreative Audigy professional sound card120G HDnever had any problem with the card except when using the dash 7 it crashes back to the desk top.CK to see if your power supply has enough juice for this card also i am not using any tweaks.good luck

Share this post


Link to post
Share on other sites

Bert,Thanks for taking the time to reply to my post :)I have a 430W PSU, should be providing enough juice for the system. I'm using the 6.13.10.6193 drivers, set the same settings for the display as you mentioned and I'm still getting stutters etcI also have an Audigy soundcard, P4B533 and a CPU running a 2.85Ghz.Maybe I got a dud card?

Share this post


Link to post
Share on other sites

Sorry John, but apart from the suggestions I've made earlier, and the other suggestions made here, I can't think of anything else...except maybe flashing the BIOS of your motherboard with the newest version. There have been issues with some AGP 8x motherboards that have been fixed with a new BIOS...Good luck, Martijn

Share this post


Link to post
Share on other sites

Thanks Martijn, but it is using the latest BIOS, and doesn't have 8x AGP, so I can't see that being the problem. Might RA my card

Share this post


Link to post
Share on other sites

I also reistalled XP then SP1 on formatted drive. No problem. The card was ok on the old and latest drivers. Running 1280x1024x32 on main monitor and 1024x768x32 on secondary. My settings are:DIRECT 3DWait for vert sync enabledCompressed texture enabledW biffer support enabledZ buffer 16:24Dithering method: use error diffusionAntisotropic filtering x16Smoothvision: QualityAnti aliasing: Application preference.MONITOR70 HertzI am using quite old VIA AGP chipset drivers - did not want to risk a change (410)Approaching simflyers EDDF at night in PIC767 with all settings maxed, upgraded terrain mesh, Full project AI (Lufthansa etc)starts around 14 FPS and drops to around 7. New CPU needed...Howard

Share this post


Link to post
Share on other sites

Thanks for the suggestions :)Have tried a few, seems they don't want to work for me. Ah well, you get that. I'll deciding on waiting for new drivers or swapping back to Nvidia :-lol

Share this post


Link to post
Share on other sites

John,I would suggest that you head over to www.rage3d.com. Then go to the 9700 tech support forum and type "stutter" into the search engine. There are around 72 threads there at the moment where users have been able to find various solutions to the problem. But first up you might like to try disabling the Firewire device on your Audigy, as I know that has resolved the stuttering for more than one user. And I assume you have tried disabling AGP texturing in Directx?

Share this post


Link to post
Share on other sites

hehe no Bill, it was meant to be a fill in :-hahThanks for the tip Jon, I have been reading the threads there for a while now, my eyes are going square :-lolI'll have another read tomorrow.Thanks for the suggestions :)

Share this post


Link to post
Share on other sites

John,Try this:Open start menu,choose run,Type dxdiag.exe and try disabling hardware acceleration in the sound tabBert

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this