Sign in to follow this  
Guest christoffer petersen

TSS JTD soundpack for TinMouse 737-200

Recommended Posts

Here are a preview of the new TSS soundpack tested with the TinMouse Boeing 737-200See the video here :

Best regardsChristoffer Petersen / TSS www.turbinesoundstudios.com

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Looks very nice, Christoffer. When is it going to be available?CheersBob ScottATP IMEL Gulfstream II-III-IV-VSantiago de Chile

Share this post


Link to post
Share on other sites

Avaliable NOW! :D simmarket.comFantastic sounds there Christoffer!--------------------------------------------------------------------Fredrik Bachke

Share this post


Link to post
Share on other sites

I love the sounds that came with the TM2 and never found anything wrong with them.

Share this post


Link to post
Share on other sites

Just to set things straight, the sounds that are included with the TM II and the TSS sounds are both created by the same person, Christoffer Petersen.The freeware sounds are nice...it looks like the TSS version is even better. It's a personal choice.CheersBob ScottATP IMEL Gulfstream II-III-IV-VSantiago de Chile

Share this post


Link to post
Share on other sites

I'm pretty happy with the freeware sounds...but the TSS package IS pretty impressive. I might just have to give it a go...along with their DC9 sounds for my Ironknuckles. Vic

Share this post


Link to post
Share on other sites

I tried this payware sound pack. Although I like the nice turbine "whine" I have several issues with it. There is an annoying background noise when in exterior view that has no business there...AFAICT. As the volume rises on TO the sound starts to break up until it becomes unuseable...ALL sounds suffer from this (even those untouched by this payware) when it begins to happen. I may need to adjust some sound settings to make this payware work...but that ain't happening. Everything soundwise worked fine before this addon and I'm not going to change settings just to make this work. I'm going back to my original TM2 sounds which are just fine. Vic

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this