Sign in to follow this  
scianoir

Help with creating flight on startup

Recommended Posts

Have been using FS9 for some time but in the last few days have been unable to go to airports in Western Europe (France, UK, Ireland) and when I try to create a flight in any airport in this area the loading process stops at either 9 or 10% during the 'terrain' phase. The problem accoring to the error message to be submitted to MS is "CDocument~1Ownerlocals~1Temp|WER****.dir00FS9.exe.mdmp", where **** varies each time. Have tried uninstalling all recent addons, restarting, etc, etc, but to no avail. Can anyone help? Airports in all other areas are not a problem.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

I've been having the same problem for years in FS9 but only when opening a previously saved flight in some Western European addon (airport) sceneries like Belgium and (NL2000-)Holland. I've never been able to solve this problem despite my previous requests for help, also in this forum.My "standard solution" uptil now has been to shut down FS9 when this issue occurs, restart FS9 and the saved flight. Mostly after two, at the most 4 tries the flight then starts up normally. To me it looks as though, with "heavy" scenery, possibly combined with complex aircraft/panels, it takes more than one go to load it all up.Sometimes, starting up the FS9 default flight at Meigs first and ticking the little "make this the default Flight" button helps. Then start the "problem" flight.O.K., it sucks but I've gotten used to it by now.However, can anyone put our noses in the right direction ?GreetingsHans

Share this post


Link to post
Share on other sites

Thanks for the reply Hans!I think you are correct in that the problem may be related to having a lot of "heavy" western European scenery addons. I however have had very "heavy" European scenery for a long time but the problem has only started in the last few weeks. Like you sometimes the flight starts normally but more often than not it doesn't! It is not a problem at all however with flights starting outside the western European area, but if I then choose 'go to' a western European airport, it will usually fail to load!I tried uninstalling recent addons but that did not work and the only thing that has helped has been to go to the 'reset defaults' option, when fs9 starts without difficulty. Unfortunately however the resultant scenery images, etc are poor and I have to reset my fs9 config files, which is a little troublesome.We shall wait and see if anyone else can come up with a solution and if I find an answer myself I will let you know!Cheers, Bill

Share this post


Link to post
Share on other sites

Just a thought here, but I wonder if Filemon would give you guys any clues to what might be causing the problem. If it's crashing the sim at the same point every time, Filemon may be able to tell you which file(s) the sim is trying to load at the time of the crash. Google Filemon for a download link.Also, I pulled my hair out for a week once trying to create a flight beginning from Zurich. It would randomly crash the sim, sometimes during loading, sometimes while panning around in spot view, sometimes while taxiing, sometimes not at all. I finally figured out the problem was a particular AI aircraft I had set up on a flightplan there, who's textures had not been processed through DXTBmp (saved directly from Photoshop, my own fault of course).I guess my point here is that AI aircraft specific to that part of the world could possibly be the cause of the crash, but you can easily rule it out by setting traffic to 0% temporarily and attempting to load a flight.Good luck, I hope you get it sorted out.Jim

Share this post


Link to post
Share on other sites

Thanks JimWill try Filemon and the AI thing - this is all very frustrating just when fs9 seemed to be running well!Cheers,Bill

Share this post


Link to post
Share on other sites

Hey there Jim,Because I've had this problem for such a long time I've tried all sorts of things including sifting through the (never ending) Filemon listings and the Windows Events logs.However, our problem does not cause direct CTDs in WindowsXP but intermittend hangs within FS9.exe itself during the "Loading Terrain" part of starting a previously saved flight and/or, as Bill experiences, when "go(ing) to airport" from the drop down menu. I feel that it's because of this that the Windows Events log does not show anything specific and Filemon drives me up the wall with it's huge listings. O.K., there are filters within Filemon but in relation to our problem the question then arises as to which specific line should be searched for or what should be filtered out ? At the FS9 hang point the last Filemon line says that landclass scenery texture and texture.cab files cannot be found (many times over) but landclass sceneries shouldn't even have texture files, on top of that it concernes a totally different scenery in relation to the one inwhich I'm trying to open my flight. There are very many of these same "not found" texture(.cab) files but almost all are related to Mesh, Landclass and Exclude scenery files.Nope, it's got nothing to do with AI aircrafts, I tested that (again) by reducing the percentage to zero. Interesting idea though but I must underscore that we do not have real WindowsXP CTDs (crashes) but very specific and especially intermittend hangs within FS9.exe itself and these are renouwnd for being very difficult to solve. Your CTDs at Zurich were caused by one or more "corrupt" textures which are known causes of CTDs. Thanks for your reaction though.Still hoping for someone to come up with a possible solution.RegardsHans

Share this post


Link to post
Share on other sites

Hi Hans and Jim!Have tried reducing the AI percentage to zero but to no avail and filemon is daunting with the rapid massive file listings(wow) and I have been unable to pinpoint the problem from that although I can see that it might have potential to help if I could spend the time working with it. The hangups are still occurring but slightly less frequent since I disabled an addon called System Booster but that does not seem the whole answer. Will try disabling anti-virus and firewall software when I go offline and see if that makes a difference, as Filemon seems to show a lot of McAfee activity during fs9 "loading terrain" segment.Kind regards,Bill

Share this post


Link to post
Share on other sites

My experience with Filemon is that it's not necessarily "the last word" when it comes to diagnosing FS issues. One would think that a file not found error would indicate something seriously wrong, but as Hans pointed out with regard to landclass "textures", sometimes FS just does some odd things. I've also logged searches for files that don't and shouldn't exist, I suppose it's just the normal steps FS9 is programmed to take when loading a scenery for example. "If scenery found, check for textures, if exist, load textures"I reduced filemon's output significantly by filtering as shown in the screenshot below. It made it a lot easier to sort through the log, but obviously it won't show a problem with passing a file through your anti-virus, for example.http://www.cat-tamer.com/attach/flmn_fltrs.gifAgain, best wishes in getting this sorted out.Jim

Share this post


Link to post
Share on other sites

Hi Jim and Bill,First of all something off subject for Bill: A dynamic in the background running virus scanner like McAfee checks all file reads, writes, movements, etc. for viruses and/or "suspicious activity". However, FS9 does a heck of a lot of file accessing etc. during startup and flights which makes it a must to switch off your McAfee in order to at least improve startup time and especially frame rates. But if you normally fly "on line" then I would suggest you use a more passive virus scanner like AVG Free edition which only dynamically checks incoming e-mails and possible attachments. However, with AVG you must periodically let it scan your whole system for virusses.A firewall will also scoop up some processor capacity but only when your internet connection is open.Thanks Jim for thinking with us on our hangup problems but in our case I think Filemon cannot help even with your suggested filter. Yes, I agree with you that according to Filemon, FS9 seems to search in all the wrong places before actually finding the files for which it's looking, thereby giving whole rows of unnessary "Not Found" messages.Well, like so many times before I'm stumped again on this intermittent hangup issue. Purely by the fact that it's a hangup and not a CTD means that fs9.exe is intermittently waiting for something during a.o. a saved flight startup but for what and why is it intermittent ?At least there is something positive about these kinds of errors, they keep me off the streets !!RegardsHansHolland

Share this post


Link to post
Share on other sites

Hey there Bill,Your original post has certainly got me going again with this old problem in my huge FS9 so I have some questions for you:At which airports do you have your "hang" problems ? In which addon sceneries are those airports situated ?I'm using NL2000v2.9 (the addon scenery for the whole of the Netherlands) and my "hang" problems only seem to occur at Amsterdam airport (EHAM) and at some Northern Belgian airports like Ostende (EBOS) and Suarlee (EBNM).To me it looks as though the NL2000 scenery partially overlaps some parts of Northern Belgium which could be the cause of "hangs" occuring there also. I'm looking forward to hear if your "hangs" occur at the same airports as at mine.RegardsHans from behind the dykes in Holland.

Share this post


Link to post
Share on other sites

Hi Hans from behind the dykes!Sorry I didn't reply sooner but have been away for the last few days passing through your very efficient EHAM going to and from Vienna (in reality). Like you I have a huge fs9 with many addons especially in Europe - I used to use NL2000v2.9 but a few months ago I changed to the commercial Netherlands scenery by Horizon. I have had no problems with AMS or indeed any other airport in the Netherlands, but most of my problems seem to be in France, the UK and Ireland (although also sometimes in Germany). In reality there is no specific pattern to the hang ups and sometimes they were even occurring at airports like Shannon in Ireland, where my scenery is still relatively simple, and which I was using to test various attempted solutions to the problem. The problems in France tended to occur in the VFR France scenery areas, all of which I have, but also can occur outside of these areas. Although I used to have UT Europe installed, I uninstalled that some time ago because of compatability problems with other sceneries. I never seem to have hangs in airports outside of Europe however! It all remains a mystery! I will try going to your other problem airports and I will keep you posted with any developments and let you know which airports in which addon areas are affected - but today it has started without problems!!Kind regards,Bill

Share this post


Link to post
Share on other sites

Hey there Bill,Well, I haven't been sitting still either and have in the meantime, found that my intermittend "hangs" now also occur in Southern French addon airports like Marseille and Nice, which seems to rule out the NL2000 scenery as being the main or only culprit. I now agree with you that these "hangs" only occur in addon (and even default) European sceneries which, together with your extra reported problems in UK and Ireland, causes me to start suspecting the default EURW/scenery and maybe even the WORLD/scenery folders which could contain changes made by installer programs which some developers see as being the only way to install their scenery products "correctly". I've had quite some bad experiences with installer programs in the past and have never fully trusted them.I have e.g. found that even when installing sceneries, via an installer program to a tempory file (for safety reasons) before doing the (selective) file copying to FS9 etc., it has sometimes occurred that default FS9 scenery files have actually, unexpectedly and unknowingly been altered and/or replaced even although the scenery in question was not directly installed in FS9. However, subsequent uninstallations after the copying process to FS9, do not always correct this kind of "damage" in the default files. On the other hand however, it is also possible that a "high tech" uninstaller program not only uninstalls from the chosen tempory file but also actually repairs the "unexpected and unknown damage" in the default files leaving the copied files in FS9 as they are but now without the necessary alterations in the default scenery files.It even occurs that when a default scenery file is altered by an installer program a subsequent installer program for a different scenery alters the already altered default file(s) again.Does this make any sense to you ? I at least am now convinced that our very specific problem must be caused by something along the above lines but I'm also convinced that finding this probable single needle in the EURW/WORLD scenery haystacks will be a difficult task. At least it's a new direction to look into and I'm certainly going to have a go at it.Our Amsterdam Schiphol airport may be efficient but did you know that it's 5 meters below sea level ? Quite a lot of visitors to Holland seem to have problems with that especially when it's raining !!RegardsHans

Share this post


Link to post
Share on other sites

Hi again Hans,I agree with your theory that the cause of the problem must be along the lines you suggest. At one stage, I wondered if it was in some way related to changes made by the installation of Ultimate Terrain Europe, which I had uninstalled some months ago (mainly because of the double-coastline and a duplicate roads effect) and then reinstalled again a just few weeks ago around the time that the problems seem to begin. I therefore uninstalled it (again!) but the problem persisted. I also wondered if Simwings France 1, which I had installed around the same time, or Simwings Toulouse, might be responsible, particularly as I initially noticed problems in the Nice area. Have you ever had any of these addons installed?For some reason the problem has not been occurring with me for the last few days but I don't know what I have done that might have helped! I agree that finding the offecding file(s) may be like looking for a needle in a haystack!Kind regards,Bill

Share this post


Link to post
Share on other sites

Hi Bill,No, I've never had Ultimate Terrain Europe or Simwings France 1 on my PC but I do have many addon French airports like:Basle, Biaritz, Cannes, Entzheim, Lyon, Marseille, Nice, Paris Orly, Paris CDG, Rennes, St Malo, St Nazaire, Le Mole and the heli port De Grimaud. Some of them are Simwings but others are not. But the French hangs only seem to occur at the southern airports like Nice, Le Mole and De Grimaud.Do you by chance have the the addon northern airport St. Malo (LFRD)? There's a scenery file in that folder "HP947140a.bgl" which I have (temporarily) removed and ....... after about 15 opens of flights at Le Mole, Nice and De Grimaud everything now !! SEEMS !! to start up without hangs. My theory is that this file could cause an "unpredictable" conflict with HP947140.bgl in the EURW folder. But, in the meantime I've become convinced that it could also be Murphy's law doing it's thing again.Other than the above I'm beginning to reach the end of my teather again on this whole issue, so if Murphy's law was in fact doing it's thing then there seems to be no other option than to just wait a few weeks and then submit a new post, this time also on FlightSim.com.RegardsHans

Share this post


Link to post
Share on other sites

Nope, that HP947140a.bgl file wasn't the solution either. I just had another hang when trying to open a flight from Le Mole LFTZ.I'm stopping now and will just have to wait for further inspiration.Good luck Bill.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this