Sign in to follow this  
Sesquashtoo

To be so satisfied...which leads to being a little ticked off, LOL!

Recommended Posts

What a corundrum! I just took a 55 minute flight from KLAX to KLAS flying for World Airways (FSPassengers).What am I ticked off about? Here is the list:1..Mountains (the San Andreas) so beautifully detailed tens of miles in the distance out my left side as I climb out from KLAX. The Dodger's Stadium so clear and sharply focused, that I could swear there was a crowd inside it.... About those mountains to the North...they looked as real to me as any number of times I have flown into L.A. and seen them at that distance and altitude, less the smog.2. The Greater City of Los Angeles and Orange County spread out, crystal clear...each rooftop and street in crisp detail..what a sight!3. The mountains surrounding the Las Vegas Valley as I was descending through 10,000 feet were spectacular, with beautiful desert-scape and again, with such sharp detail that they absolutely looked real in appearance!!!All of the above has really 'ticked me off'! Why? Because I should have had this sensational graphic display from the moment I bought FS9 and at the least, when having purchased the X1950Pro. That's why, LOL!-----------------------------------------All of the above was obviously tongue-in-cheek. The 7.10's...this should-be-award-winning driver package from ATI has transformed (along with 1920x1200 resolution of it all) my FS9 world to sheer virtual credibility. It just no LONGER looks 'simulated'. The mountains around L.A. were simply, simply...REAL to the eyes. They were believable now. No cranking up the imagination engine needed.I mean folks, if you have not YET gotten on the 7.10 bandwagon and downloaded this driver-gem...you are so ***MISSING out*** on what FS9 'could' look like for you. This is such an understatement that words really don't cut it. They really don't for the graphic transformation.Does this EVER show me that just buying hardware...DOES NOT GARRANTEE that you truly upgraded to FULL POTENTIAL. I can't believe how seriously important is the **code** DRIVING THAT HARDWARE. I learned a valuable lesson in this for any other hardware future purchase. Check out the software that drives whatever FIRST, before settling in on a sole manufacturer. Check out the pertinent forums and such, FIRST!No other driver package EVER, has shown such a day and night boost of graphic display performance than this driver suite has for FS9 using of course an ATI chip'ed card.So...what the heck did they do? How could ONE iteration of a display suite make such a dramatic impact on all the gremlins we have been up in arms about FOR YEARS!Blurriness, stuttering, all of it. Since running with this package, I have had NONE of those issues any longer. Nowhere in FS9. My friend reports that his FSX ground textures, clouds, airframes, buildings--- SNAP into clarity, and he is thrilled beyond all get-out! ATI produced magic with this driver set. Cheers!Mitch

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

HelloI have been using the Catalyst drivers since 3.10The last set that gave me such a boost in performance was 4.12These 7.10 drivers are the best that ATI have ever done IMHOMaybe some AMD software engineers gave them a few tips :-)

Share this post


Link to post
Share on other sites

Mitch or anyone, I tried to download the 7.10 drivers from ATI support but I got a 403 error. Did you or anyone else experience this ?

Share this post


Link to post
Share on other sites

No, just trying to download it from ATI. I'm always hesitant when I get the window asking if I want to allow Active X content.

Share this post


Link to post
Share on other sites

You are trying to just set up right from the ATI site, right?------------------------------------If you download the entire Cat 7.10 package to your DESKTOP, and **THEN** fire it up from there, you should be OK.If THAT does not work, I suggest that you go to Microsoft's DX web page and download the DX 9c (latest) installer, and first run that before attempting to run the Cat. 7.10 install again.That should fix things up, any of the above....Make sure that you totally remove the present drivers, AND you might also want to download the AVIVO drivers to run your HD hardware on your card. Those drivers are not part of the normal package. Some installers had omitted them. You can find the link to them just below the place on the page where you would click to download the Cat. 7.10's.Mitch

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this