Archived

This topic is now archived and is closed to further replies.

AdvancedFollower

Quad core and <40 tps

Recommended Posts

So I tried TP again, this time with a Quad core CPU, but performance is still abyssmal. I'm starting to think it's my 2Mb Internet connection that just doesn't cut it. However if I view the map services' homepages in my browser, the tiles load quickly enough so that doesn't quite make sense either. But I don't know what else might be the problem - I keep throwing new hardware at the thing but it never performs well. Maybe my ISP has some sort of limitation on the maximum number of concurrent connections or something so that when FSX tries to load thousands of tiles it just sais NO! and cuts me off?So far I got the best tile loading speed out of a single core 3500+ CPU and FSX RTM. That would give me 700 - 900 tps.FSX SP1/SP2 was around 20 tps on the single-core system and 10-40 tps on an AthlonX2 and about the same with my new Phenom X4 CPU. Increasing fiber fraction to around 4.0 and locking framerate at 16 FPS seems to make cached terrain load fast enough to stay sharp, but as soon as it needs to download new tiles, it just gives up the ghost and displays horribly blurred scenery. I know the Phenom isn't as fast as the Core 2 Quads, but with four cores at its disposal, I think FSX/TP should perform a lot better than this?

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

My Q6600@2400 MHz peaks at 1600 TPS during initial load and often reaches 800 TPS during flight.I suspect something else is running foul in this FSX installation. Tried deleting fsx.cfg and letting it rebuild? Then install Tileproxy over it once more.

Share this post


Link to post
Share on other sites

A 2megs internet connection is good enough for all but the highest resolution of 30cm. in my experience. A quad core at 3000 megs should supply 1200 tps when flying.Turn off all none microsoft services on your pc. This will free up resources.Bern

Share this post


Link to post
Share on other sites

I agree with Christian. I have a mere Duo-Core machine and a 1 meg Internet connection - and I am very happy with TP, using 1 metre resolution.Delete your FSx.cfg - regenerate a new one - then change the scenery settings from within FSx to what gives you a pleasant FSx default experience. Then reinstall TP using Ed Truthans guide - make sure it shows updated maps. STOP with the FSX so-called "fixes" - for example, playing around with "Fiber frame" -- none of these are needed.You should be getting a very good TP experience straight out of the box!!And read the manual - I dont know how many times I see screenshots of people flying fast jets, and wondering why they cant get clear TP images.Barry

Share this post


Link to post
Share on other sites

I had it create a new FSX.cfg but still no luck.I do however think that the Internet connection can be ruled out as a possible cause. The same problem occours even when flying out of the same area fot the second, third time etc. when it has already been cached. The download counter doesn't appear but the speed is still very slow.Even during the initial loading, which takes 10+ minutes, the speed is only 50 to 100 TPS, and this is when starting from an airport that has already been cached by tileproxy before.Like I said, I got great performance out of single core Athlon64 3500+. The framerate was extremely low, but the performance was good - 600+ TPS. I am aware of the limitations of the program and I've limited my testing to the default ultralight and C172.Here is what it usually looks like:http://forums.avsim.net/user_files/192645.jpgMaybe it's an ATI-specific problem (Geforce cards seem to be more common here). Perhaps it's possible the Tileproxy driver conflicts with the AMD SATA/AHCI driver (again, seeing as Intel is more common here).

Share this post


Link to post
Share on other sites

OK I *think* I have solved the problem..I spent over an hour shutting down everything except the most essential services and programs, changing BIOS settings, changing Windows settings etc. but nothing helped.However, one of the two last changes I made definitely did "something" to TileProxy and/or FSX.I set water_blending and water_smoothing to Off.Loading time is much, much faster now (a minute or two instead of up to 15 minutes). When flying, it peaks at 1800 tps, allthough average is of course much lower, maybe 700. I was also seeing a TPS of "0" for short periods - the scenery was sharp however, so this was probably an indication that FS was "keeping up" with my C172 at least for short periods.http://forums.avsim.net/user_files/192646.jpgWhy would the Water options cause TPS rate to drop from 700+ to under 50? As you can see in the first screenshot I posted, there were no messages in the DOS box printout about any water masks..no error messages or anything. It just slowed to a crawl with no errors. There didn't even seem to be any water masks available where I did my test flights since all the lakes were solid with no pixel shaded water. I did all my test flights from ESCM airport.

Share this post


Link to post
Share on other sites

Well, as the ini file idicates, you shouldn't use water smoothing with FSX. And you probably shouldn't use water smoothing and water blending together at all - that's trying to do the same thing (well, sort of) twice. Anyway, when I did try water smoothing with FSX just for fun, it, too, took forever to load, and when it finally did, it took but a few seconds to become a blurry mess. So I'd say that either the water smoothing algorithm simply is that slow, or it doesn't work well in conjunction with FSX. But since FSX supports water blending (which looks much better anyway), that's not so much of a problem I guess.Judith

Share this post


Link to post
Share on other sites

Hi Judith Yes - the INI file recommends for FSx - Water Soothing OFF and Water blending ON - I get nice results that wayBarry

Share this post


Link to post
Share on other sites

My mistake - the options I set to Off were water_mask and water_blending. Water_smoothing was Off all the time.Maybe there's no water mask available for Sweden but it still tries to use one, causing this slowdown?Edit: I re-enabled both water_mask and water_blending and did some more tests: Over California, the scenery stayed sharp and the loading time was OK. Around ESCM airport in Sweden, the loading time was again extremely long and the scenery quickly became blurred. When I disabled the water options, performance around ESCM once again improved.

Share this post


Link to post
Share on other sites