Sign in to follow this  
Guest FS_freak

Praise for FFX-SGA

Recommended Posts

I just wanted to say how impressed i am with the 737-200 and 727-200 by FFX-SGA. Finally, we've got some outstanding Boeing models that actually look like the real deal, putting Yeodesigns (737) and Mike Stone (727) to shame! I've been especially waiting for an accurate GMAX 737-200 for a long time.Here's to FFX-SGA, a rapidly-emerging powerhouse in freeware modeling! They're doing it right.-jak1421

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

No no no, don't go casting shame around on other groups just to boost another. I assume you're being humorous here, even though it's not very obvious.I for one am very happy with the Yeo and Mike Stone offerings... keep up the good work, all of you! :-yellow1--jr

Share this post


Link to post
Share on other sites

FFX-SGA 732 is yet another appreciated contribution to the flight sim community. Others like Mike Stones and Yeodesigns have and are providing thousands with countless hours of facination and entertainment. I appreciate all the hours they dedicate to develop what becomes appreciated gifts to the flight sim community.Thanks all,Dave Vega

Share this post


Link to post
Share on other sites

Whoa. Shames not the word. Yeodesigns and Mike Stone both did (and do!) fine work. I certainly didnt blow away my Yeodesigns 732 models when this FFX/SGA bird came out! it was complimentary content to me. Mikes work is well known as well.In any case, its all good! Im so delighted people take their time to contribute to my enjoyment...for free. Eric

Share this post


Link to post
Share on other sites

I am currently trying to configure the absolute best freeware 727 available to date, FFX's 727. I can't get this bird to slow down on approach, even with gear extended, confirmed throttle idle, full flaps and spoilers deployed. Anything over -500 ft x min will get me speeds in excess of 160kts. I have tried increasing the drag scalars (induced and parasite) in the flight tunning section of the aircraft.cfg from 1.000 to 4.000 to no avail. I tried three different FDE's: Mike Stone's, Charles Fox's and Kevin Trinkle's but the plane keeps speeding. Is there any other parameter on the aircraft.cfg file that I can try tweaking?As a last resort I currently fly the FFX 727 with FFX's own 737-200 FDE which allows for a power-on slow approach but takes away the heavy feel of the 727 as well as it's higher (.80+ mach) cruise speed. I also find myself putting in very high elevator trim settings in all fases of flight which makes for weird vertical stab angles. Has anyone found a proper FDE to suit this bird?Thanks in advance.Maurice

Share this post


Link to post
Share on other sites

Thanks a lot guys! Hey Bigshot, I got your FDE and will try it out as soon as I get home. I'll get back to you.Hey Mike, If your butt is really on the line here then it

Share this post


Link to post
Share on other sites

OK, this is killing me, where do you folks go and actually download this plane? im interested in the b732 and the b727. everytime i go to the ffx website and hit downloads all i get is the link to d/l the md80. any help would truly be great ciao!Brian S

Share this post


Link to post
Share on other sites

Hey Brian. Do a search for "b73720fx.zip" no quotes. Inside this file you will find both the 737 and the 727.MauriceSearch at flightsim.com!

Share this post


Link to post
Share on other sites

Aren't you the one I got emailed about this already? Maybe not. If the latter is the case, I'll tell you like I told the other person. From all indidcations of your problem as you describe, you have your FS Realism settings wrong. You have "true airspeed" selected instead of "indicated airspeed". Only 1 or 2 reports of the identical problem have been brought forward and I have repeatedly retested and reflown the 727 WITH the FDE that I created and was in the intial release, and for the life of me..... I cannot duplicate this problem!In other words, our 2 FS' are set up quite differently for sure. The aircraft did EVERYTHING it was supposed to when it was supposed to. I really want to help solve this problem of yours because it's my butt on the line here. So check you FS realism settings and make sure that you have INDICATED AIRSPEED selected and NOT true airspeed. Attached is the config that I have been using as well as the airfile. Just edit the aircraft entries to the ones that you use. Email me with the results, or thru here on the forum or on SGA's forum.Also I need to know what panel you are using. If it's Richard Probst's panel, there are numerous reports that there are some problems with it when used with our 727. I can't verify all of these claims because I don't use it anymore mainly because of the YD issue. There are other issues too I've been told.mike@sgair.nethttp://sgair.net/images/member_name_banners/mike_small.jpgPS, Sorry, but I can't seem to get the airfile attached here the correct way, so if you want it, please email me. Also for the config, since it's not the actual config file itself, just copy and paste the info from "GENERAL" on down and leave out the aircraft info.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this