Archived

This topic is now archived and is closed to further replies.

BigRick

Problem with recognizing green/red buttons

Recommended Posts

Morning Bryan! I'm posting for a friend of mine that does not have access to the internet at the moment. Lucky dog is on vacation in Hawaii. :-) Anyway, he has a Saitek yoke (and pedals+ 2 throttle quads) and the MD version does not recognize his button assignments for FS2C. FSUIPC reports the button #'s as 6 & 7 and the control panel reports them as 7 & 8. He's tried both combos and still it will not recognize the buttons. I've asked him to make sure that neither FSX nor any other software is catching those assignments and he assures me that nothing else is installed that would do so. Also, he said he has disabled the joystick in FSX and handles all interrupts through FSUIPC. I'm thinking maybe THAT might be the problem, but I wanted to address it to you to see what you thought. I have pretty much the same setup, but do not run FSX. I only use the Airbus version of FS2C and it recognizes my flight yoke just fine....although it's assigned differently due to the fact that the red/green buttons are actually assigned an FS keystroke value. Thanx in advance and I'm going to be getting the REST of the FS2C products as soon as I upgrade my system. I'm VERY impressed with the time and effort take to offer these fine programs. Take care.-Rick

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Hello Rick,The system used for the joystick/keyboard input is exactly the same as that used in the Airbus version. It's identical code.Have your friend try this:1. Re-install Direct X from Microsoft.2. re-install his Saitek drivers.Also, be sure to search the 747 FSX and Airbus forum using the term 'Saitek' to see how others have solved this issue.As mentioned, the code is the same so what works for the 747 or Airbus will also work for the MD-11.All the best,Bryan

Share this post


Link to post
Share on other sites

Hi Bryan!I got the same problem although with CH Products Flight Sim Yoke. Got Green and Red Button configured to button 3 and 4 on the yoke, which is the rudder trim button(s). Got FS2Crew working perfect with PMDG747 and the Level-D767.The weird thing is that I got ATS disconnect and autopilot disconnect(in the MD-11) perfectly configured on two other buttons without doing a thing. =/This is in FS9.Best regards/Niclas

Share this post


Link to post
Share on other sites
Hi Bryan!I got the same problem although with CH Products Flight Sim Yoke. Got Green and Red Button configured to button 3 and 4 on the yoke, which is the rudder trim button(s). Got FS2Crew working perfect with PMDG747 and the Level-D767.The weird thing is that I got ATS disconnect and autopilot disconnect(in the MD-11) perfectly configured on two other buttons without doing a thing. =/This is in FS9.Best regards/Niclas
If you're getting autopilot disconnects, try increasing the null zone on your yoke. If your yoke is sending out "noise", the sim might interpret that as you moving the stick and thus disengaging the autopilot.Also ensure that your button isn't tied to the key command used by the PMDG MD-11 for autopilot/ATS disconnects.For the Green/Red button, something to try is this: Reset your key and joystick commands via the FS2Crew Start Center so the default settings are used (Numeric Keypad Plus and Minus for the Red and Green buttons respectively).Next, using FSUIPC, map those keys to the joystick buttons of your choice.Cheers,

Share this post


Link to post
Share on other sites
If you're getting autopilot disconnects, try increasing the null zone on your yoke. If your yoke is sending out "noise", the sim might interpret that as you moving the stick and thus disengaging the autopilot.Also ensure that your button isn't tied to the key command used by the PMDG MD-11 for autopilot/ATS disconnects.For the Green/Red button, something to try is this: Reset your key and joystick commands via the FS2Crew Start Center so the default settings are used (Numeric Keypad Plus and Minus for the Red and Green buttons respectively).Next, using FSUIPC, map those keys to the joystick buttons of your choice.Cheers,
Sorry, you missunderstood. ATS and autopilot disconnect when I push the buttons I want, they work as they should but not red and green button.

Share this post


Link to post
Share on other sites

Thanks Bryan!That worked perfect!Many thanks again, keep making these great products!

Share this post


Link to post
Share on other sites
Thanks Bryan!That worked perfect!Many thanks again, keep making these great products!
Any time :(

Share this post


Link to post
Share on other sites