Archived

This topic is now archived and is closed to further replies.

Guest MOC

Computer Has Run Out Of Memory

Recommended Posts

For the first time, I had a crash that wasnt a complete lockup of my GPU (I just installed a nice shiny new Asus EAH4850 and it runs very nicely) but I did get this message:your computer has run out of available memory. Please restart Flight Simulator and select different graphics, scenery or traffic settingsHas anyone else seen this? Its a new one to me.Thanks-

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

For the first time, I had a crash that wasnt a complete lockup of my GPU (I just installed a nice shiny new Asus EAH4850 and it runs very nicely) but I did get this message:your computer has run out of available memory. Please restart Flight Simulator and select different graphics, scenery or traffic settingsHas anyone else seen this? Its a new one to me.Thanks-
I've gotten that before. How much RAM do you have? All I did was restart my computer and FS worked. That happened on my old computer which I had FS9 on and 1GB of RAM.

Share this post


Link to post
Share on other sites
I've gotten that before. How much RAM do you have? All I did was restart my computer and FS worked. That happened on my old computer which I had FS9 on and 1GB of RAM.
Im running Windows XP with 4GB of ram, a 3.1 GHZ processor with nothing overclocked. I dialed back a few scenery settings ( I had placed all on MAX as I was beating up my new video card ) and the issues hasnt come back.

Share this post


Link to post
Share on other sites
For the first time, I had a crash that wasnt a complete lockup of my GPU (I just installed a nice shiny new Asus EAH4850 and it runs very nicely) but I did get this message:your computer has run out of available memory. Please restart Flight Simulator and select different graphics, scenery or traffic settingsHas anyone else seen this? Its a new one to me.Thanks-
Happened to me the other day... but since I had Task Manager/performance window open at the time I noticed that my 3G page file was at 3G. Normally I check this occasionally and restart when it gets close but I was away from sim at the time and didn't prevent it this time. Loyd

Share this post


Link to post
Share on other sites

MOCThis is a limitation of a 32-bit OS. There are one or two tweaks to prevent it. There is a switch to add to the boot.ini file /3GB /userva=2560. You also need FSX + Sp1 + SP2. This allows a 32 bit system to access/use more virtual memory than it normally can. It does not depend how much phsyical ram you have on board it is due to the way a 32-bit sytem acceses and uses the Virual address space. The answer - switch to a 64-bit OS - problem solved. The boot.ini is in the root directory usually C:\. See Phil Taylor's blog here: http://blogs.msdn.com/ptaylor/archive/2007...ress-space.aspx.RegardsPeterH :(

Share this post


Link to post
Share on other sites
Im running Windows XP with 4GB of ram, a 3.1 GHZ processor with nothing overclocked. I dialed back a few scenery settings ( I had placed all on MAX as I was beating up my new video card ) and the issues hasnt come back.
Have a look at my postings under Selkan (ctd ntdll.dll), it might be of help to you

Share this post


Link to post
Share on other sites

I am running into these now with the MD-11, which from reading I KNOW isn't their fault, but Windows 32 Bit Vista. So, what can I "switch" to get the OOM's to go away? I'd really not wanna turn down scenery to sacrifice or upgrade to 64 bit. :(What switches can be used in Vista 32-bit?Thanks!

Share this post


Link to post
Share on other sites
I am running into these now with the MD-11, which from reading I KNOW isn't their fault, but Windows 32 Bit Vista. So, what can I "switch" to get the OOM's to go away? I'd really not wanna turn down scenery to sacrifice or upgrade to 64 bit. :(What switches can be used in Vista 32-bit?Thanks!
JohnThis is what I posted on the http://forums1.avsim.net/index.php?showtopic=240028 forum:From: http://www.neowin.net/forum/index.php?show...#entry5902616161. Log in as an administrator 2. Open the Start menu, type cmd in the Search box, and right-click on cmd.exe and choose "Run as Administrator"3. Type in BCDEDIT /Set IncreaseUserVa 3072 (Note: the '3072' can be changed to suit your needs. I would not go below 2600 or higher than 3100 personally. Refer to Microsoft's guidelines on the /3GB & UserVA switches for XP for more information) --This method will set the UserVA for the boot option currently in use. 4. Hit Enter; you should get a confirmation message. Reboot. The next time you boot into the modified boot option, it should be using UserVA.5. If you wish to check whether you did things correctly, simply type bcdedit in the command prompt. The modified boot option should have a userva option, whereas the other one(s) shouldn't.This is not needed in Vista 64 and that's the best solution to this issue RegardsPeterH

Share this post


Link to post
Share on other sites

Ok, I am using Vista 32 bit, what can I do for that?

JohnThis is what I posted on the http://forums1.avsim.net/index.php?showtopic=240028 forum:From: http://www.neowin.net/forum/index.php?show...#entry5902616161. Log in as an administrator 2. Open the Start menu, type cmd in the Search box, and right-click on cmd.exe and choose "Run as Administrator"3. Type in BCDEDIT /Set IncreaseUserVa 3072 (Note: the '3072' can be changed to suit your needs. I would not go below 2600 or higher than 3100 personally. Refer to Microsoft's guidelines on the /3GB & UserVA switches for XP for more information) --This method will set the UserVA for the boot option currently in use. 4. Hit Enter; you should get a confirmation message. Reboot. The next time you boot into the modified boot option, it should be using UserVA.5. If you wish to check whether you did things correctly, simply type bcdedit in the command prompt. The modified boot option should have a userva option, whereas the other one(s) shouldn't.This is not needed in Vista 64 and that's the best solution to this issue RegardsPeterH

Share this post


Link to post
Share on other sites
Ok, I am using Vista 32 bit, what can I do for that?
JohnThis IS what you do for Vista 32.1. Log in as an administrator 2. Open the Start menu, type cmd in the Search box, and right-click on cmd.exe and choose "Run as Administrator" (or temporarily disable UAC)3. Type in BCDEDIT /Set IncreaseUserVa 3072 (Note: the '3072' can be changed to suit your needs. I would not go below 2600 or higher than 3100 personally. Refer to Microsoft's guidelines on the /3GB & UserVA switches for XP for more information) --This method will set the UserVA for the boot option currently in use. 4. Hit Enter; you should get a confirmation message. Reboot. The next time you boot into the modified boot option, it should be using UserVA.5. If you wish to check whether you did things correctly, simply type bcdedit in the command prompt. The modified boot option should have a userva option, whereas the other one(s) shouldn't.If you read my post you will see full instructions on how to use bcedit and change your values in Vista 32 to avoid SOME but only SOME of the OOM issues. My last line about Vista 64 is that you don't need to do anything in Vista 64 as OOM's are not usually an issue in FSX Please also read the link that I put in my post above so that you can see why you are doing this.RegardsPeterH

Share this post


Link to post
Share on other sites

HiCan anyone help with the procedure for changing the XP memory allocation, the link in P.Taylors article is not working anymore, and i am very unsure how to approach this :( Thanks if anyone can helpTake CareJP

Share this post


Link to post
Share on other sites
HiCan anyone help with the procedure for changing the XP memory allocation, the link in P.Taylors article is not working anymore, and i am very unsure how to approach this :( Thanks if anyone can helpTake CareJP
PeterYou need to find your boot.ini file in the sysytem drive, eg C:\boot.ini (Make sure that you can see all hidden files and folders.0Open with note pad and add the following statement: "/3GB /USERVA=2800" (NO " " marks) - you usually place it on the line after the OS as shown below. (NOTE: USERVA should be set to a number less than 3000 to allow your graphics to address more virtual address space)EXAMPLE LINE: multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="XP 2850" /noexecute=optout/fastdetect /3GB /USERVA=2850OR use this method from: http://www.solidsmack.com/how-to-suck-all-...-xp/2007-08-23/Go to Start, right click on My Computer and select Properties. Select the Advanced tab In the Startup and Recovery section select Settings In the System Startup area select Edit On the line after [operating systems] add this line:multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="XP Professional 3GB" /noexecute=optin /fastdetect /3GB /USERVA=2850 This is my entry which may be different to yours as this is on an AMD machine[boot loader]timeout=30default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS[operating systems]multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional" /noexecute=optin /fastdetect /3GB /userva=2850 /usepmtimerYou can try this tweak with or without the "USERVA=2850" entry as it sometimes works OK without this entry.RegardsPeterH

Share this post


Link to post
Share on other sites

Hej Peter :( Thanks a Billion for the reply, i made the fix and it helped, because for the first time i did not have a complete PC crasch (blue screen).Anyhow to make my FS work without problems i had to continue to de-install the Aerosoft VFR Germany 1,2 and 3, a pity because they are realy fantastic. Now it seems i have adjusted reality to my PC performance.Anyhow wondering, has anyone with a 64bit Vista run into same havoc ???Take CareJP

Share this post


Link to post
Share on other sites

PeterUnder most conditions when using Vista 64 and FSX you shouldn't get OOM errors with complex planes or scenery. A 64-bit OS is much more efficient on how it handles the virual address space (VAS) (the lack of which is what causes an OOM error in 32-bit systems). Strangely enough modern graphics cards with oodles of Video Ram can make the situation worse in a 32-bit system as they need more of the VAS to operate efficiently. Vista 64 with SP1 with modern hardware is a very stable system - ideal for a program like FSX. You can still get OOM errors in a 64-bit system but they are usually pretty rare and/or due to a malfunction of some type.Glad to helpRegardsPeterH

Share this post


Link to post
Share on other sites

This happened to me two days ago for the first time. I tried everything that people have mentioned above with no success. After hours of research and trying just about everything, I found the following solution which worked! Keep in mind that I have XP, but I think it might work for Vista as well.1) In your virtual memory settings, select the button that says "No Paging File."2) Reboot.3) Defrag your hard drive where your page file usually resides.4) Go back into your virtual memory settings and select the button that says "System Managed Size."5) RebootThat should do it! Now, you can play around with the virtual memory settings and page files to suit your self, but I haven't because I'm just happy that I can fly again!Good Luck!Paul

Share this post


Link to post
Share on other sites

question silly one it mite be but to do the 3 g switch for xp for 32 os bit do u need to have 2ram or do u need 4

Share this post


Link to post
Share on other sites