Archived

This topic is now archived and is closed to further replies.

martinlest2

Scenery Wobble

Recommended Posts

Hi. I resisted for a long time, but I asked for (an got) FSX for FSXmas (?!): after a few days testing I can't imagine I'm going to fly it in preference to FS9, mainly because of all the addons I have for FS9 (airports, aircraft GE Pro, FE, FSGenesis etc. etc. - not to mention poor old FS navigator of course) which make the whole FS9 experience even better than FSX out of the box (IMHO): but I like it very much, as an out-of-the-box product, so am happy to have both installed on my PC.The point of this post though is to ask how I can avoid the landscape 'wobbling' in FSX as I pan, a wave-like effect, a bit like a theatre backdrop in a breeze. I have fps set at 20 and pretty much get that even with my settings quite high. Turning the display settings much lower doesn't stop the scenery rippling as I pan though, so I am at a bit of a loss. I haven't tweaked the FSX.cfg file in the way I have the FS9.cfg file. Is there something there that would stop this?Many thanks,Martin

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Hard to imagine what you are seeing...are you seeing tearing due to vsync?Is your VSync set to ON or OFF in your graphic card settings?

Share this post


Link to post
Share on other sites
Hard to imagine what you are seeing...are you seeing tearing due to vsync?It's a kind of ripple - hard to describeIs your VSync set to ON or OFF in your graphic card settings?
It is set to 'Use the 3D application setting' (this is in NVidia Control Panel). There are options to 'Force On' and 'Force Off'..I did once, many moons ago, occasionally see this problem in FS9, but I have no memory now of what I did to resolve it, unfortunately.Martin

Share this post


Link to post
Share on other sites

I am new to FSX as well and know just what you are talking about and a wobble is an excellent word to describe it. Basically, the secenry position keeps shifting a bit as you traveland it does appear to move in a wave.all set at ultra high except plane medium-high, traffic X 69%SWISS OUTING 30 - 60 FPSEGLL loaded with PMDG 747 spot view 11 - 15fpskrishan

Share this post


Link to post
Share on other sites

SP2/Accel broke Vertical Sync partially in DX9 and completely in DX10. Your videocard's output is not synchronized with your monitor's refresh rate without it, hence you're seeing a sine wave type effect between them. It used to be on by default in RTM and SP1, now it's off unless you force it. Just go into your nvidia driver control panel and set VSync to "Force On", problem should be solved, at least if you're running in DX9. It will never work in DX10 however, which is sadly the main reason I can't use it. Screen tearing gives me a migraine in minutes haha. ATI should have a similar capability in the catalyst control center as well.BTW: If you're running with Vsync on, then be sure to set your FPS lock to a perfect factor of 60 fps/hz (standard refresh rate for LCD monitors). Framerate lock values of 10, 15, 20, or 30 work best. Any other values than those, 29 fps for instance, will lead to stutters.-mike

Share this post


Link to post
Share on other sites
SP2/Accel broke Vertical Sync partially in DX9 and completely in DX10. Your videocard's output is not synchronized with your monitor's refresh rate without it, hence you're seeing a sine wave type effect between them. It used to be on by default in RTM and SP1, now it's off unless you force it. Just go into your nvidia driver control panel and set VSync to "Force On", problem should be solved, at least if you're running in DX9. It will never work in DX10 however, which is sadly the main reason I can't use it. Screen tearing gives me a migraine in minutes haha. ATI should have a similar capability in the catalyst control center as well.BTW: If you're running with Vsync on, then be sure to set your FPS lock to a perfect factor of 60 fps/hz (standard refresh rate for LCD monitors). Framerate lock values of 10, 15, 20, or 30 work best. Any other values than those, 29 fps for instance, will lead to stutters.-mike
Mike, I have had this a long time with two LCD's and on a P4 and now an i7. I just thought it had something to do with maybe the response time for the LCD...although the one I have now is 4ms. I don't recall reading anything about this before in the forum...never did a search for it as I just thought I had to live with it. Just set my FPS to 30 and monitor from 75hz to 60hz and it is gone. I understand the force v sync but why the division of 2 or 3..or it seems that way for the FPS? What is the reason it will not work with say 27 or 33? Just curious. Regards

Share this post


Link to post
Share on other sites
Mike, I have had this a long time with two LCD's and on a P4 and now an i7. I just thought it had something to do with maybe the response time for the LCD...although the one I have now is 4ms. I don't recall reading anything about this before in the forum...never did a search for it as I just thought I had to live with it. Just set my FPS to 30 and monitor from 75hz to 60hz and it is gone. I understand the force v sync but why the division of 2 or 3..or it seems that way for the FPS? What is the reason it will not work with say 27 or 33? Just curious. Regards
Hey Alphahawk. Vsync will work regardless of what fps you choose in FSX, but the way the framerate limiter works, if it's locked to something that isn't a perfect divisible factor of your monitor's refresh rate, usually 60 fps/hz, then it will 'hitch up' every few frames as FSX tries to synchronize with the monitor. In essence it'll have to drop or add a frame every second or two in order to keep in step, and that produces a noticeable stutter.Unfortunately FSX doesn't have a perfect framerate limiter, it's always just slightly off, hitting 29.9 or 29.8 even if you're able to maintain 30 fps no problem. So you will always get a very slight rhythmic stutter every few seconds with Vsync on, especially in multiplayer. For some reason FSX chops 0.3 fps off the top when flying in multiplayer mode, even if you're flying by yourself, regardless of what your limit is set to. Never could figure that one out hehe. In a perfect world, if the limiter could always maintain exactly 30 fps, then stutters would be gone, at least from frame mismatches.Bottom line though is that locked framerates of 10, 15, 20, and 30 are all perfect factors of 60hz, so in essence your monitor is either refreshing 6, 4, 3, or 2 times per frame respectively; nice even and whole numbers, rather than something like 4.6 refreshes per frame which results in a constant mismatch, and stutters. If you're running your screen at 75hz refresh though, then really your only feasible synchronized whole number framerate lock in FSX would be 25 fps, giving 3 monitor refreshes per frame.Yes I'm allergic to stutters, but screen tearing without Vsync makes me want to scratch my eyes out, haha. I'll take a touch of stutter over that mess any day.Hope that long winded explanation makes sense.cheers,-mike

Share this post


Link to post
Share on other sites

Mike,Yes, turning Vertical Sync on has stopped the 'billowing' of the ground textures. Thanks. Panning around in FSX is not ultra-smooth, as I get in FS9, but things are more than acceptable now.Incidentally, maybe you are able to answer another point? What is the setting in FSX that corresponds to "SpotFastTransition=" in an FS9 flt file? If this is set to true in FS9 you get a 'dry' pan, that stops dead as soon as you release the hat-switch. When set to false, you get a smooth, gliding pan. In FSX there is no such value in the flt file - seems to be in the camera settings, but I can't work out what would need to be changed. (This is the other thing about FSX - I feel I know pretty much how to tweak just about anything in FS9 after all this time, where all the cfg settings are, editing bgl files etc. but I 'm back to being a bit of an incompetent beginner with FSX!!).Thanks!Martin

Share this post


Link to post
Share on other sites
Mike,Yes, turning Vertical Sync on has stopped the 'billowing' of the ground textures. Thanks. Panning around in FSX is not ultra-smooth, as I get in FS9, but things are more than acceptable now.Incidentally, maybe you are able to answer another point? What is the setting in FSX that corresponds to "SpotFastTransition=" in an FS9 flt file? If this is set to true in FS9 you get a 'dry' pan, that stops dead as soon as you release the hat-switch. When set to false, you get a smooth, gliding pan. In FSX there is no such value in the flt file - seems to be in the camera settings, but I can't work out what would need to be changed. (This is the other thing about FSX - I feel I know pretty much how to tweak just about anything in FS9 after all this time, where all the cfg settings are, editing bgl files etc. but I 'm back to being a bit of an incompetent beginner with FSX!!).Thanks!Martin
Hey Martin. I'm not sure on the panning actually, I haven't used a pan key or hat switch in about 4 years thanks to Track-ir. There's just no going back. :)You can try messing with these values in the virtual cockpit camera section of the cameras.cfg file though:PitchPanRate=30HeadingPanRate=75PanAcceleratorTime=0Cheers,-mike

Share this post


Link to post
Share on other sites
Mike,Yes, turning Vertical Sync on has stopped the 'billowing' of the ground textures. Thanks. Panning around in FSX is not ultra-smooth, as I get in FS9, but things are more than acceptable now.Incidentally, maybe you are able to answer another point? What is the setting in FSX that corresponds to "SpotFastTransition=" in an FS9 flt file? If this is set to true in FS9 you get a 'dry' pan, that stops dead as soon as you release the hat-switch. When set to false, you get a smooth, gliding pan. In FSX there is no such value in the flt file - seems to be in the camera settings, but I can't work out what would need to be changed. (This is the other thing about FSX - I feel I know pretty much how to tweak just about anything in FS9 after all this time, where all the cfg settings are, editing bgl files etc. but I 'm back to being a bit of an incompetent beginner with FSX!!).Thanks!Martin
Try this Martin. Once you get into SPOT view press the "A" key. You will now have LOCKED SPOT view. I think this is what you want. R-

Share this post


Link to post
Share on other sites

Martin,The "Fast Spot Transition" is equivalent to FSX "Locked Spot" camera view.You can reach it with the "A" key when you are in the "Outside" group selected by the "S" key or Right-click on the screen to see the views menu on-screeen; you can select any available view from there.The four default F-key views (F9-F11) are defined in the ...\Applications and Data\Microsoft\FSX\Cameras.cfg with the lines "HotKeySelect=" in the various camera definitions. I moved the HotKeySelect lines to my view preferences - Nearest Tower~1, Locked Spot~2, VC~3, TopDown~4.This gives you your most common/preferred views at a single touch. You can also BLOCK a camera from showing in the "A" key rotation by adding "CycleHidden=Yes" to the end of the definition.Loyd

Share this post


Link to post
Share on other sites

Yes, that's what I meant. I can get rid of the 'Locked Spot' view (which I don't like) and get back to an smooth, 'floating' kind of pan with the A-key. Can also select customised view options of course, as you suggest. Thanks,Martin

Share this post


Link to post
Share on other sites