Archived

This topic is now archived and is closed to further replies.

--Randy--

FS9 & Vista 64 problem.

Recommended Posts

This problem has three parts:Part 1 Vista 64Part 2 FS9Part 3 Saitek Yoke and Rudder PeddlesI have loaded FSX onto Vista 64 and it is working perfectly, my Saitek Yoke works flawlessly along with the Rudder Peddles. I loaded FS9 onto Vista 64 and it works fine except I can not set the Mixture and Prop quadrant assignments. I have tried everything I can think of. I know it will work because I had it installed and running fine before I had a drive crash and had to reinstall everything. I have removed FS9 and reinstalled.....Installed Saitek Vista 64 drivers......rebuilt FS9.cfg. What is really weird is I can go into Settings and Calibrate Joystick and move the mixture and Prop controls and it will see them move...but when I add them into the control assignments as mixture axis and propeller axis....then create a flight...they do not work. If I go back in and check the assignments they are there.....but FS9 just isn't reading them. If anyone has any ideas at all.....I would love to hear them.Thanks!!

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

This may sound idiotic, but are you selecting the quadrant in the FS9 menu? It a seperate controller from the yoke and throttle.(I'm assuming you have the yoke with throttles and another throttle quadrant).One will say "YOKE" and scroll down to see "Quadrant".

Share this post


Link to post
Share on other sites
This may sound idiotic, but are you selecting the quadrant in the FS9 menu? It a seperate controller from the yoke and throttle.(I'm assuming you have the yoke with throttles and another throttle quadrant).One will say "YOKE" and scroll down to see "Quadrant".
I am sorry, but I don't quite know what you mean. I am in FS9 when trying to set the assignments for the quadrant that is connected to the Saitek Yoke. The assignments are saved, or so it appears, when I pull up the control assignments and look at them...they are right. For some reason FS9 is just not handling them properly....and I have reinstalled FS9 twice, just in case I had a bad install.

Share this post


Link to post
Share on other sites

The confusion is that the "throttle" is part of the yoke, and appears as "Saitek Pro Flight Yoke". It should appear to fs9/fsx as a controller with 5 axes:XYZX rotationY rotationI've had a problem with FSX not recognizing all axes properly in Vista x64 using the latest Saitek driver 6.0.6.5. What I saw was when assigning an axis, FSX did not see the correct axis. In particular, it saw the 3rd lever (mixture) as "Z Axis", not "Y Rotation Axis".I removed the Saitek driver and used the default MS vista x64 HID driver and now FSX properly recognizes all 5 axes. I still have a problem of FSUIPC4 not recognizing any of the axes, but haven't worked on that yet.I haven't done an FS9 install on vista x64, but could you attempt to assign each Yoke axis and advise what fs9 is calling them?scott s..

Share this post


Link to post
Share on other sites

Thanks Scott....will try removing the Saitek Drivers and see what happens. Will check on what FS9 is calling the assignments when I get a chance...thanks

Share this post


Link to post
Share on other sites