Archived

This topic is now archived and is closed to further replies.

Gottedammerung

Black VC glass - any fixes?

Recommended Posts

I'm getting mighty ticked off that half my addon aircraft, enen those that say they are Aceeleration friendly, display black VC glass. I finally got the Wigla for FSX, one of my favourite little AC, and can I use it - no.Apart from the gripe about making SP2 affect the alpha channel so ac that previously worked no longer do (great move), does anyone know if there is a fix for it, other than editing the alpha channels of each AC?Can I simply unistall SP2, and if so, will it return functionality, and what will I lose.Many thanksPhil

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

My word. That's great. Many thanks.All the bestPhil
Has anybody else tried that utility? I uninstalled SP2 then reinstalled FSX to put this same issue correct. If the utility DOES work, what will I gain from SP2 if I run XP Pro SP3 32bit edition? Apart from adding Direct X 10 support (ish) and change multiplayer performance, what else does SP2 do which would be of value to me?

Share this post


Link to post
Share on other sites
Has anybody else tried that utility?
I had a look at it, and it fixes a problem with rain textures in FSX. FSX shipped with some dummy rain textures and this utility replaces these with the ones from FS9 so that the cockpit glass of some FS9 imports will work in the rain.Unfortunately it does not fix the black cockpit glass you find when importing some FS9 birds. This has to do with the Alpha channel properties of the glass texture bitmaps, and is a little harder to fix. As far as I can tell you'll need a special bitmap editor which will allow you to edit the bitmap properties list.

Share this post


Link to post
Share on other sites
I had a look at it, and it fixes a problem with rain textures in FSX. FSX shipped with some dummy rain textures and this utility replaces these with the ones from FS9 so that the cockpit glass of some FS9 imports will work in the rain.Unfortunately it does not fix the black cockpit glass you find when importing some FS9 birds. This has to do with the Alpha channel properties of the glass texture bitmaps, and is a little harder to fix. As far as I can tell you'll need a special bitmap editor which will allow you to edit the bitmap properties list.
Yes, I came to the same conclusion.It's a shame, but I've gone back to SP1. I'm good with photoshop, but the amount of time it will take me just to find out what I need to specifically do with the alpha textures, how to save then etc, puts me off embraking on it. So like I said, I just reverted to SP1.What's going on with the developers? Who in their right minds would affect this chance from sp1 to sp2, making a whole host of AC unflyable? Ridiculous, if you ask me.But thanks for the input, all.Oh, BTW, I haven;t noticed any FPS change since reverting to SP1. If anything, it seems to make it a whole lot better in that I can fly more AC. One thing I did notice, though, was that the AC images in the menu were jumbled up, which is slightly annoying.

Share this post


Link to post
Share on other sites

All you need to do is replace the glass texture in the offending aircraft with one from a different aircraft that does work in SP2. For example, I installed the Nemeth AC-350 helicopter for FS9 into FSX/Acceleration and all the windows were black. In the texture folder was a file called windows_t.bmp. I looked at a helicopter that did work in SP2 which had a file named glass.bmp. I copied the glass.bmp to the texture folder of the Nemeth and renamed it windows_t.bmp. Voila! Sparkling clear glass! Jim

Share this post


Link to post
Share on other sites
All you need to do is replace the glass texture in the offending aircraft with one from a different aircraft that does work in SP2. For example, I installed the Nemeth AC-350 helicopter for FS9 into FSX/Acceleration and all the windows were black. In the texture folder was a file called windows_t.bmp. I looked at a helicopter that did work in SP2 which had a file named glass.bmp. I copied the glass.bmp to the texture folder of the Nemeth and renamed it windows_t.bmp. Voila! Sparkling clear glass! Jim
From what I understand, though, the problem is that the VC's have glass and cockpit features, and an alpha layer. I believe it it the way the alpha layer is saved which affects the opacity of the cockpit. But, with a VC, you have to first find the correct texture bitmap (quite often they are not obviously named, nor will display as a thumbnail, then edit the alpha layer of that bitmap, then save it as a certain format (which off the top of my head, I cannot remember).And do it for side windows and back windows as well. All a lot of work, and unecessary, really, when you think, the majority of them used to work before SP2 or acceleration.All very frustrating.

Share this post


Link to post
Share on other sites

Yes I struggled the same to fix some textures for Wilco Airbus vol 1 that are not transparent in external spot view for a variant of the A320 (IAE I think). I never found where the texture was (while I fixed some other planes for similar problems). It's even more upsetting when it's product sold as compatible with Acceleration/sp2 as the Wilco bus is (and we are many to have this one), and devs should be able to fix it in minutes or at least tell where the textures are supposed to be. Well, good luck anyway

Share this post


Link to post
Share on other sites

I'm new to fltsims and I am just beginning to learn about the 'black glass' issue. I've yet to find the fix but I do understand the frustration. Some say that you must modify the 'alpha channel' in the glass file yet there is no mention of what to do when there doesn't seem to be a 'glass' file. Others say that the problem is with the model itself and that that cannot be fixed. Yet I've seen 'black glass' aircraft load properly on other systems with the only differences seeming to be the particular service pack installed.That, for me, is the most frustrating issue. The same aircraft file will load differently on different systems so obviously there is a fix. I'm beginning to suspect that those 'in the know' just ain't tellin'... :(

Share this post


Link to post
Share on other sites
Did you ever get the Wilga sorted....got the same issue here. TIAPhil Webb
You do realize this was more than 2 yrs ago and what's a "Wilga"? :(

Share this post


Link to post
Share on other sites