Archived

This topic is now archived and is closed to further replies.

Smoky942

Access Denied

Recommended Posts

Hi, I've just recently re-installed fs9. I have some modified fx files in the effects folder, so, as I've previously done, I first removed them, along with one aircraft cfg. and put them in a folder outside fs9. After re-installing fs9 I can open the aircraft cfg. in the spare folder, in order to copy the entries, but can't open..copy..or move any of the fx files. All I get is..Access Denied. A couple of zip files in the same folder also give the same message. I don't understand whats going on. Any advice would be more than welcome.Russell.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Hi, I've just recently re-installed fs9. I have some modified fx files in the effects folder, so, as I've previously done, I first removed them, along with one aircraft cfg. and put them in a folder outside fs9. After re-installing fs9 I can open the aircraft cfg. in the spare folder, in order to copy the entries, but can't open..copy..or move any of the fx files. All I get is..Access Denied. A couple of zip files in the same folder also give the same message. I don't understand whats going on. Any advice would be more than welcome.Russell.
Are you running Vista by chance? Might it be a permissions issue? If so, you may need to right click on the folder in question and turn off the permissions for that and any any subfiolders it may have.Just a thought. :(

Share this post


Link to post
Share on other sites

Thanks David. I'm on XP. It's in D / programme files / microsoft games. There are several folders in there, including fs9. The majority work fine. When I try to open the couple of zip files, it does indeed say the problem could be a file sharing one. But sharing with what..or whom ? The zips have been in that position for ages, and used a few times with no problem...before I re-installed fs9.Russell.

Share this post


Link to post
Share on other sites

Could it be virus related ? I run AVG, which I check for updates, then run every morning. It always gives my machine a clean bill of health. however, a very strange event occured after the fresh install of fs9. Before the re-install, I was using FSUIPC to try and correct a fault with the X52pro. It clearly stated my name and email as the registered person (as it has since 2003) Before removing fs9, I cut the FSUIPC.Key from the modules folder, and placed it in a folder on it's own. After the re-install, I cut the SAME FSUIPS.Key from the spare folder, and put it back in the new modules folder, then put in the latest FSUIPC dll. When I fired up fs9 and went to FSUIPC, I was shocked to see it registered to someone I've never heard of, with a Brazilian email address. I got round it by deleting the key, then entering my own details. I sent the offending key to Pete Dowson. Pete Dowson is a man of the highest integrity, and thats not in question at all, but his first reaction was that it was impossible for the key to change, I must have obtained it from someone. Apparently, the guy who's name appeared on my key is well known to SimMarket, and is banned for freely distributing keys. From un-installing to re-installing, I did'nt download anything whatsoever, I was'nt even connected to the internet. Every payware item is bought and paid for perfectly legitimately, nothing pirated AT ALL. But...SOMETHING changed that key. I never fly online, but my son is an avid online gamer, though nothing even remotely connected to flightsim. I can only assume that something he downloaded contained the offending key, which overwrote mine, 'tho even that seems a bit unlikely as he does'nt have anything which uses FSUIPC. Anyway, I'm wondering if it has anything to do with these files locking up.Russell.

Share this post


Link to post
Share on other sites

Just a couple of other thoughts:"File or Folder Sharing" usually is a term related to sharing them over a network. Right clicking on a file or folder will normally allow you to allow or disable the sharing function.Acess denied is something I have experienced on rare occasions. In each case the actual file had been deleted, but My Computer or Explorer still showed it as being available. When I tried to access it, I got the "access denided" message.I understand that situation has something to do with Wndows failing to release the "handles" (may be the wrong terminology) when the file was deleted.There are free utilities which will force such a release but I have never needed to use them. Turning off the computer for a few minutes and then rebooting has always "released" them for me. The file in question then no longer appears when I look for it.Hope fully you situation is similar and you can redownload the file you need or you have a copy of it saved elsewhere which can be placed where you can work on it.This article from Microsoft may be useful also:http://support.microsoft.com/kb/810881It tells how to fix the 'access denied" problem.Hope this info is useful. :(

Share this post


Link to post
Share on other sites

Thanks for that david...your valued advice is always appreciated. Following the path in the link..start/my computer/tools/folder options/view, I only get Apply to all folders...Reset all folders...Restore defaults tabs, but no Advanced settings tab. I'll have to have a closer look at it later tonight, but thanks again for pointing me in the right direction.Russell.

Share this post


Link to post
Share on other sites

The access denied message could be a permissions issue - right click the zip files you're getting the message on. Do you see a security tab? Your name should be there, and list the permissions you have. If you don't see your name (or just a bunch of numbers), then it looks like your permissions have been lost. Did you install originally to a different OS or recently rebuild your OS? This can affect permissions, particularly if you've locked them down. The attached should show you the permissions tab.

Share this post


Link to post
Share on other sites

In an earlier post the OP says he is using XP - not Vista so it is not a permissions (Vista) issue. :(

Share this post


Link to post
Share on other sites
In an earlier post the OP says he is using XP - not Vista so it is not a permissions (Vista) issue. :(
XP also uses file and folder permissions, my screenshot happened to be from Win7, but XP should display the same tab if you've formatted as NTFS.

Share this post


Link to post
Share on other sites

Well Leostr, I am formatted as NTFS, but I can't get a window up like the one you show. I tend to think that David is on the right track with the files deleted, but windows still showing them as available theory. I've managed to get all, bar two, of the offending files deleted. The funny thing is (to me, anyway) none of the items appeared in the recycle bin, which my very limited knowledge makes me lean towards Davids suggestion. I've found copies of some of the fx files, and re-downloaded the zips. FS9 is working fine now, so I think I'll leave well alone. My sincerest thanks to both of you for your help.Russell.

Share this post


Link to post
Share on other sites
XP also uses file and folder permissions, my screenshot happened to be from Win7, but XP should display the same tab if you've formatted as NTFS.
Win 7 may have it but XP, no matter how the disk is formatted, has no such screen and "security" hoops to jump through like Vista. :(

Share this post


Link to post
Share on other sites
Well Leostr, I am formatted as NTFS, but I can't get a window up like the one you show. I tend to think that David is on the right track with the files deleted, but windows still showing them as available theory. I've managed to get all, bar two, of the offending files deleted. The funny thing is (to me, anyway) none of the items appeared in the recycle bin, which my very limited knowledge makes me lean towards Davids suggestion. I've found copies of some of the fx files, and re-downloaded the zips. FS9 is working fine now, so I think I'll leave well alone. My sincerest thanks to both of you for your help.Russell.
One last thought - I probably would be a good idea to run the utility which checks your disk(s) for errors - it is built into XP.Go to My Computer, Highlite the drive in question and Right click and select Properties. You will see a Tools tab, and under it is the option to "check disk for errors".Might be worth a try. :(

Share this post


Link to post
Share on other sites
Win 7 may have it but XP, no matter how the disk is formatted, has no such screen and "security" hoops to jump through like Vista. :(
Ummm.. sorry, Opa, but yes it does. Files and folder permissions have existed with NTFS since.. well, NTFS. I agree that security hoops are less in XP than Vista, but that not withstanding, the NTFS security tab does indeed exist. And, apart from the Win/Program Files directories, NTFS security is no great a hoop in Vista as it was in XP.I concede that when simple file sharing is enabled, that screen doesn't appear!In any case, replies from the OP indicate that simple file sharing is enabled (since the security tab doesn't appear); Smoky42, have you checked that the files read only status is not checked? (right click the file(s), Properties, General ; you should see a read only checkbox. Check its unchecked).

Share this post


Link to post
Share on other sites
Ummm.. sorry, Opa, but yes it does. Files and folder permissions have existed with NTFS since.. well, NTFS. I agree that security hoops are less in XP than Vista, but that not withstanding, the NTFS security tab does indeed exist. And, apart from the Win/Program Files directories, NTFS security is no great a hoop in Vista as it was in XP.I concede that when simple file sharing is enabled, that screen doesn't appear!In any case, replies from the OP indicate that simple file sharing is enabled (since the security tab doesn't appear); Smoky42, have you checked that the files read only status is not checked? (right click the file(s), Properties, General ; you should see a read only checkbox. Check its unchecked).
I am always happy to learn "new" tricks - but I have never seen that screen and never seen the "security" tab in the several years I have been running XP.Love to know just how you make it appear.I am using classic view rather than the XP default and details instead of icons if that makes any difference.

Share this post


Link to post
Share on other sites

Its not enabled by default - you have to disable simple file sharing in Folder Options - View.. and its the last but one option in there. Its only available on XP Pro, but you can get it booting into Safe Mode on XP Home. Hope this helps,Leo

Share this post


Link to post
Share on other sites