Archived

This topic is now archived and is closed to further replies.

markoxley

Windows 7 & FS Passengers

Recommended Posts

I am running Windows 7x64 and FS9 and all my addons work really smooth, never had it so good.The one problem I do have is FS Passengers this causes FS9 to crash on loading.Does anyone know of a fix or a workround.Check FS Passengers site and their support don

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

I am running Windows 7x64 and FS9 and all my addons work really smooth, never had it so good.The one problem I do have is FS Passengers this causes FS9 to crash on loading.Does anyone know of a fix or a workround.Check FS Passengers site and their support don

Share this post


Link to post
Share on other sites
Not very much information to go on here. What is the EXACT error you are getting?What build of Windows 7 are you using. 7000, 7022,7048 or 7057. I am using 7057 (RC1) and I have no such problems.You can't expect support for an OS that is still in beta. Microsoft won't even give you support for Windows 7, so you accept the responsibility to use it at YOUR own risk.
Mike,I am using 7075.The message I get is Windows has found a problem and is searching for a solution.I am not the only one with this problem.Remove the FSPassengers dll file from the modules directory and FS2004 works fine.Mark

Share this post


Link to post
Share on other sites

I get the same problem but I'm using FSX. I also have Windows 7 x64 (Build 7000). I had FSPassengers X working ONCE! But then one of my other add-ons was not working properly so I ended up re-installing Windows 7 and everything. Then after everything was re-installed, I go to try FSX again but all that happens when I click on FSX is the splash screen shows up but never gets past that. No crash, system does not freeze, just the splash screen sits there and nothing happens. Rename the fspassengersx.dll file and try it again, works fine! I have tried uninstalling and re-installing FSX. I have tried deleting the logbook.bin file and fsx.cfg file to no avail. I cannot for the life of me figure out what it is. It definitely is something to do with the fspassengers.dll file but there's more to it because I had this working fine once. The only other add-ons I have installed are UTX and GEN-X. It has to be something with the Windows updates because that's the only thing I can think of. Right now I'm downloading another build of Windows 7 but I am going to uninstall updates one by one to see if I can find the source of the problem. Also, please let us know if you or anyone else finds a solution to this problem.

Share this post


Link to post
Share on other sites

Well I'm at my wit's end on this one. I uninstalled all of the updates and it still didn't work. So then I re-installed Windows, FSX, Acceleration, and FsPassengers X, nothing else and it still didn't work. Not sure what I did to have it working that one time. Next thing I can try is the new build and hope that somehow fixes the problem but I know I had it working once with this build.

Share this post


Link to post
Share on other sites

Grab the latest installer from teh developer. I had the same issue but was using the installer I got when I purchased over a year ago. Now it works fine. I'm running Build 7000.Is the RC out? I thought 7000 was the latest public release?

Share this post


Link to post
Share on other sites
Grab the latest installer from teh developer. I had the same issue but was using the installer I got when I purchased over a year ago. Now it works fine. I'm running Build 7000.Is the RC out? I thought 7000 was the latest public release?
Didn't work for me.

Share this post


Link to post
Share on other sites

Update: I'm on build 7077 and it still doesn't work. Build 7077 is one of the last builds before the RC of Windows 7 and I highly doubt this is a Microsoft problem at this point.

Share this post


Link to post
Share on other sites
Not very much information to go on here. What is the EXACT error you are getting?What build of Windows 7 are you using. 7000, 7022,7048 or 7057. I am using 7057 (RC1) and I have no such problems.You can't expect support for an OS that is still in beta. Microsoft won't even give you support for Windows 7, so you accept the responsibility to use it at YOUR own risk.
Can you tell us what addons you're using as well as what version of FSUIPC? It must be a conflict of another addon because like Mark said, remove the fspassengers.dll file and flight sim loads fine.The FSPassengers developer really should look into this.

Share this post


Link to post
Share on other sites
Can you tell us what addons you're using as well as what version of FSUIPC? It must be a conflict of another addon because like Mark said, remove the fspassengers.dll file and flight sim loads fine.The FSPassengers developer really should look into this.
I doubt he will until the OS is near RTM or at RTM status. Most vendors don't support Beta/RC OS's.

Share this post


Link to post
Share on other sites

Hmmm not a good choice if you ask me. The beta is out there so people can test it and work on patches for existing conflicting software. What other purpose does it serve? I can understand to an extent though. Still, this is the only program I'm having trouble running. Everything else works fine just as it did in Vista only better. That's a shame. I'm glad I downloaded the demo before I bought it.

Share this post


Link to post
Share on other sites

Did you install FSPassengers using the 'Run as Admin' option? If not that may be the issue as well. I just finished up another flight in FS9 with FSP and it worked just fine and I'm on Build 7000.

Share this post


Link to post
Share on other sites

Yes I tried that and I tried installing with vista compatibility mode as well but neither worked. I had it working once when I was on build 7000. I can't figure out what it could be.

Share this post


Link to post
Share on other sites

Ya revert back until the RC comes out :)I've been on Build 7000 for a while and while it was nice there are too many things that aren't ready yet for me to continue. My TripleHead2Go doesn't like Windows 7 much at all with the supplied Nvidia compatible drivers (early and buggy). Certain programs such as this are hit and miss.It will be a great OS once it is out, but right now there are significant issues. (If you use Windows Home Server you can't restore backups to a Windows 7 computer OOPS!).I'm planning on reverting back to Vista 64Bit this weekend and will upgrade whenver Windows 7 comes out.

Share this post


Link to post
Share on other sites
I am having the same problem. Anyone have a fix?
Chief, please list your complete specs including operating system and add-ons.

Share this post


Link to post
Share on other sites

I am using Build 7077 and FS Passengers works fine.The only thing I have noticed with it is the Mini report slows your frame rate down by 10 to 15 frames.Mark

Share this post


Link to post
Share on other sites

What other addons are you using? I'm on build 7077 as well and cant get it to work at all.

Share this post


Link to post
Share on other sites