Jump to content

Archived

This topic is now archived and is closed to further replies.

Hernan1

Restoring the AFCAD.bgl files

Recommended Posts

I have an embarrasing question regarding an error I made when trying to view an airport AFCAD.bgl file. Today I was working in adding the correct gate sizes for the Beijing airport (ZBAA) scenery made by FRF studios. For some reason when I was saving my changes it opened a different folder for another airport. As I tried to locate where that file was, I opened the Properties folder, and it directed me to its location. When I opened the file, I got the window that tells me that whatever I was using to view it, could not open the file. I obviously thought that only the AFCAD utility could "view" it, so I selected AFCAD tool to open that file with. Now, all of my AFCADs listed in the add-on scenery/scenery folders no longer have their .bgl extension and the "icon" in front of the AFCAD file has the AFCAD icon. I did not realize about my error, until I opened flight simulator to check that particular airport when I noticed that there are trees are all over the apron now. I went to my FRF-ZBAA scenery folder and noticed that all of the files with.bgl extensions no longer show the bgl extension. For example: AFX_ZBAA_FRF.bgl was normally there, now it simply shows: [AFCAD icon}AFX_ZBAA_FRF (no.bgl extension) How can I go back to the way it was before? I hope I was able to explain my problem properly without the need to post a screenshot as that is another problem I have. I suppose what I am asking is, how can restore a .bgl file?. I will appreciate your knowledgeable input, because mine sucks! Please help. :(

Share this post


Link to post
Share on other sites

Have you tried simply renaming the afcads which currently have no extension - adding the bgl suffix?Also I suggest using the "details" view rather than the "icon" view - so you are seeing the actual file name. Your problem potentially is more widespread if all of the bgls in your FS2004 installation are now "missing" the bgl extension.

Share this post


Link to post
Share on other sites

I think your problem may not be as bad as you think. Windows file explorer has an option to not show the filename extension for known file types. If you look in the explorer tools folder option view tab there is a checkbox for "hide extensions for known file types". It probably is checked. (Personally, I don't like having this checked. I like seeing the extensions.) I suspect you just misplaced an afcad file. Put it back in the right folder and you should be good.scott s..

Share this post


Link to post
Share on other sites

×
×
  • Create New...