Archived

This topic is now archived and is closed to further replies.

hamish7777

ATI 5850 Screen Tearing FSX Problem

Recommended Posts

I have just upgraded to an i5 with an ATI 5850 at the same time as moving to Windows 7 64bit. I have re installed my FS9 that I use most of the time but also tried to give FSX a go as I have a new rig. I have installed it pretty much the way Nick N suggested but I have a pretty major problem. Other than the fact that both FS9 and FSX seem to be more buggy in Win 7 (difficult to minimize to desktop and back again, FSX runs in windows basic mode etc etc) the main problem I am facing is screen tearing. This only happens in FSX and I am running a matrox triple head2go system running 3840 x 1024. Whenever I fly using my track ir the screen tears quite considerably even though my frames on average are 30ish. I have googled this problem and found that my card is not forcing the ' vsync on' and that you have to use a program d3d overider which comes with riva tuner. I downloaded this and started the application. The good news the screen does not tear anymore!! the bad news every few seconds if you are using Radar Contact or the weather is updating the screen goes black and then reloads which makes the sim unplayable. Does anyone have the same problem and is there a workaround?Any help most appreciated.......H.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

I have just upgraded to an i5 with an ATI 5850 at the same time as moving to Windows 7 64bit. I have re installed my FS9 that I use most of the time but also tried to give FSX a go as I have a new rig. I have installed it pretty much the way Nick N suggested but I have a pretty major problem. Other than the fact that both FS9 and FSX seem to be more buggy in Win 7 (difficult to minimize to desktop and back again, FSX runs in windows basic mode etc etc) the main problem I am facing is screen tearing. This only happens in FSX and I am running a matrox triple head2go system running 3840 x 1024. Whenever I fly using my track ir the screen tears quite considerably even though my frames on average are 30ish. I have googled this problem and found that my card is not forcing the ' vsync on' and that you have to use a program d3d overider which comes with riva tuner. I downloaded this and started the application. The good news the screen does not tear anymore!! the bad news every few seconds if you are using Radar Contact or the weather is updating the screen goes black and then reloads which makes the sim unplayable. Does anyone have the same problem and is there a workaround?Any help most appreciated.......H.
I don't have Radar Contact.I find FSX in W7 x64 to be perfect for me. I use REX v2 and it updates every so often and it is hardly noticed in the sim. However I am currently using an nVidia card, and the newest drivers are terrible (meaning slow). I'll have to go back to the release I was using.Why not un-install Radar Contact and see how FSX behaves?You could also try turning UAC off just in case it's perventing something from running.At that resolution you sure are pushing a lot of pixels. lol I would just try one monitor and see what happens.

Share this post


Link to post
Share on other sites

I'm currently struggling with my ATI 5870 card and FSX ([lack of] results explained in another thread) and I've experienced the issue you mention. This has nothing to do with UAC or Radar Contact. Doing stuff like displaying the ATC menu or the red "overspeed" text will also cause the problem (screen flashes, and sometimes go totally crazy). I've done some googling and found out that basically, forcing vsync the "official" way does not work under Vista or 7 for some ATI cards. Forcing vsync with e.g. CCC simply has no effect. That's why the d3d overrider (and ATI tray tools using the "vista workaround" mode) does this in an alternative way. It works in the sense that vsync is now really enforced. However for FSX it has the drawback of messing up the screen when displaying menus and such things, making it completely unplayable. Since I've been using nvidia cards for years I have very limited experience with ATI stuff. The sad thing is that this particular issue obviously has been discussed on various hardware forums for years and there still doesn't seem to be any known workaround for FSX. If someone knows a way to fix this without reverting to XP or nvidia, I'd love to hear about it...

Share this post


Link to post
Share on other sites

Just to underline that there's a lot of hardware differences out there and to use the marketing phrase "your experience may vary", I'm for the moment (knock on wood) not having any problems with my new 5870 on Catalyst 9.12 with FSX. In fact, I'm pegged at my max FPS limiter (24) for the first time in many years and decidedly pleased with the results. Using Windows 7 x64, all defaults. Only tweak I made was the texture_max_load = 4096 for my REX clouds. I also no longer have the sound crackling problem I had with the 9600GT (but not with an 8800 ultra - go figure).Note: With regards to the note above on the "windows is switching to basic mode" when running FSX on Aero enabled desktops (Vista or W7): It's not a bug. FSX was created before Aero came out, and requests a video mode that is not compatible with Aero when it initializes directX, hence, the warning. My son has a few old games that cause the message in Vista as well, so it's not FSX specific.Cheers,

Share this post


Link to post
Share on other sites

Well from checking around a few forums looks like one is screwed if you own an ATI card and want to play FSX. From what I gathered yes d3d overider is the only program that will force VSYNC on in FSX and it gets rid of all the horrible screen tearing but all you get is a black screen every few seconds especially if any text comes up on the screen like the 'brakes' caption etc....so makes it unplayable....So if you use Track IR and I have a 3 monitor setup with a Matrox Triple Head 2 GO please be warned you should stick with Nvidia at all costs... real shame I outlayed

Share this post


Link to post
Share on other sites
So if you use Track IR and I have a 3 monitor setup with a Matrox Triple Head 2 GO please be warned you should stick with Nvidia at all costs... real shame I outlayed

Share this post


Link to post
Share on other sites

That is an interesting question..... had not thought of that... I think it wont help as other users who do not have 3 screens but are using Track IR are still having the same issues...Have a look at this....http://www.rage3d.com/board/showthread.php?t=33953314I have fired an e mail to ATI Driver support and I will see if they reply... to be honest I am really surprised there is not a sticky on the forum saying. If you have an ATI Card running Windows 7/Vista you will not be able to have V Sync on therefore you will have screen tearing issues in FSX... stick with Nvidia...

Share this post


Link to post
Share on other sites
to be honest I am really surprised there is not a sticky on the forum saying. If you have an ATI Card running Windows 7/Vista you will not be able to have V Sync on therefore you will have screen tearing issues in FSX... stick with Nvidia...
Probably because it is untrue. I'm sure there are other ATi users that don't have this issue, therefore it is not a universal problem as you claim.

Share this post


Link to post
Share on other sites

That is what I thought at first but having done some research especially on ATI Radeon Forums there are lots of people who are complaining that under Win7/Vista in CCC forcing V Sync on does not work... apparently they have been reporting it to the Windows 7/Vista Driver feedback to ATi so it may get looked into.. If you read thishttp://www.rage3d.com/board/showthread.php?t=33953314This problem has been around for quite a while... do I honestly do not think its just me, if you find someone using FSX with Win7/Vista running an ATI card with Vsync on please let me know!!Hamish

Share this post


Link to post
Share on other sites

VSync never works properly in FSX, whether its ATi or Nvidia, there will still be screen tearing or graphical anomalies whether you force or not through Forceware, or Catalyst Control. To solve this you need to use the right tools. I'm tired of people blaming their ATi for their problems. The PROPER way to get Vsync in FSX is through the CFG, Nvidia through NHancer, or if your on ATi, download nHancer for ATi (ATITrayTools) and create a profile for FSX. Everyone that is having a problem with an ATi card should download this, or if you are an enthusiast this is a vital program. You can download ATi Tray Tools here:http://majorgeeks.com/ATI_Tray_Tools_d4569.htmlhttp://www.softpedia.com/get/Tweak/Video-T...ray-Tools.shtml(Note: If using Softpedia, when you go the download page make sure to download the BETA which has support for newer cards (HD 3xxx through 5xxx)Also check here for the vsync line for the FSX CFG:http://blogs.msdn.com/ptaylor/archive/2007...aks-in-sp1.aspxAlso check this out for some other tips: http://forums1.avsim.net/index.php?s=&...t&p=1694202Research, before blaming a part of your computer for the problem, because there are often ways to fix it, but you may not have found the proper solution yet. I used to have an Nvidia card, but when I switched to ATi and was learning how their cards worked, I never just came out and shot down the card when I had a problem. Sometimes you may get better performance, or better satisfaction with your new card than your old card, when you find out how everything works. Spreading false rumors will hurt any company and some people will even return their card, only to find later there was a way to solve their problem and deeply regret it. I don't really care though because the people that actually study or research on technology will know, and the people that don't will be missing out big time...

Share this post


Link to post
Share on other sites

Thank you for your time in replying.... seems like the first post that has any hope. I might have been misled by this forum threadhttp://www.rage3d.com/board/showthread.php?t=33953314From the research I did, I found the only way to get Vsync working in FSX was to use d3d overrider which is packaged with riva tuner however its useless with in the sim as you get a black screen every time the weather updates or when text is written on the screen, ie brakes/ atc window... I will read your post and follow your guidelines and if it looks I have been harsh on ATI and I can get V sync to work, I take it all back....Will report back.....

Share this post


Link to post
Share on other sites
Thank you for your time in replying.... seems like the first post that has any hope. I might have been misled by this forum threadhttp://www.rage3d.com/board/showthread.php?t=33953314From the research I did, I found the only way to get Vsync working in FSX was to use d3d overrider which is packaged with riva tuner however its useless with in the sim as you get a black screen every time the weather updates or when text is written on the screen, ie brakes/ atc window... I will read your post and follow your guidelines and if it looks I have been harsh on ATI and I can get V sync to work, I take it all back....Will report back.....
If I was a bit too harsh, I'm sorry. It's just so many people today will stomp on a good brand. I would just like it if people (not you) on the internet would post their problem without saying "ATI/Nvidia sucks". Good luck fixing your problem :(.

Share this post


Link to post
Share on other sites
Thank you for your time in replying.... seems like the first post that has any hope. I might have been misled by this forum threadhttp://www.rage3d.com/board/showthread.php?t=33953314
You have not been misled by that thread. There are however several attempts to mislead you in this current thread.A few clarifications:- Yes, there is a problem with some ATI cards and Vista/7. ATI has confirmed this but depend on MS to fix it- Vista override mode in ATT "works" - for pretty much everything but FSX. Vsync is forced but with the drawbacks you mention - The vsync lines in fsx.cfg are useless in FSX as of SP2 (http://forums1.avsim.net/lofiversion/index.php/t65693.html)- Basically, none of the statements from gman or techguymax are valid for the 58xx cardsYou could try to use an ATT profile and use Vista override mode for vsync, and then enable directx 10 preview mode in FSX and see if it helps. Although using directx 10 preview has its own downsides.

Share this post


Link to post
Share on other sites

Thank you... I have tried the workaround that g man offered but it does not work, you get the dreaded black screen every few seconds.....So as I stated before there should be a sticky saying do not use ATI cards with FSX if using Win 7/Vista, as Nick N said the best advice is to use Win XP 64bit...... there is a discussion on this at the Simforums website.....Thanks for all your help everyone.....Hamish...

Share this post


Link to post
Share on other sites
Thank you... I have tried the workaround that g man offered but it does not work, you get the dreaded black screen every few seconds.....So as I stated before there should be a sticky saying do not use ATI cards with FSX if using Win 7/Vista, as Nick N said the best advice is to use Win XP 64bit...... there is a discussion on this at the Simforums website.....Thanks for all your help everyone.....Hamish...
There is another method other than using the Vsync that overrides. I have had this problem too, and couldn't even fly with the method that is similar to D3DOverrider but I tried a different way to enable VSync in ATT. Right Click the ATT icon go to 3D > Settings. In the 'General' tab select "Always On" for "Wait for Vertical Sync". In 'Additional' I set Catalyst A.I. to Low or High (Don't know if this could make a differenece if it is set to off) then in the 'Open GL' Tab I have selected "Triple Buffering". I use this in-case some avionics or add-on uses Open-GL to render. I read something about this a few years ago but I cannot remember where it was. I doubt OpenGL can work inside a DirectX app, but I just set it incase. Doesn't hurt :smile. Try locking your framerate as well. You may want to set it to your refresh rate (i.e. Monitor with 60Hz refresh rate, locked @ 60, 70Hz, loked @ 70), but first start of with lower #s and see if it works.Good Luck!

Share this post


Link to post
Share on other sites

Just a small tip that will make things a little bit better... If you disable the brakes/stall/overspeed text warnings in fsx.cfg you can at least avoid some of the screen flashing. InfoBrakesEnable=False InfoParkingBrakesEnable=False InfoPauseEnable=False InfoSlewEnable=False InfoStallEnable=False InfoOverspeedEnable=False However stuff like the ATC menu and various addons will of course still give you the screen flashing. Personally I handle ATC and such stuff on a separate monitor so that's not an issue. Using these workarounds I get a bit less of the screen flashing but it's still too annoying to be acceptable though.

Thank you... So as I stated before there should be a sticky saying do not use ATI cards with FSX if using Win 7/Vista, as Nick N said the best advice is to use Win XP 64bit...... there is a discussion on this at the Simforums website.....
I agree on that one, I've tried the 5870 on XP and vsync worked as expected without problems in FSX. However Eyefinity does not work on XP and Eyefinity is kind of the reason I got the 5870 :(

Share this post


Link to post
Share on other sites

Thanks for those tips.... will try that now.....I have Radar Contact so that may be a possibility.....Maybe ATI will release a new driver that addresses these issues, lets hope!!Hamish

Share this post


Link to post
Share on other sites