Archived

This topic is now archived and is closed to further replies.

wombat778

Mute key

Recommended Posts

I bought FS2Crew for the MD80 yesterday and am having a blast with it. Really fantastic work!Anyhow, my only problem so far is that I can't seem to get the mute button to work. I have tried a number of different keystrokes from the dropdown and it never seems to do anything in the sim (e.g., the little M symbol never shows up). I made sure that no other key in FS was assigned to the keystroke I selected. I also looked in the FS2CrewInputMapper.CFG file and it looks like the keystroke is correctly entered there. Any idea what might be causing the problem?Thanks!

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

I bought FS2Crew for the MD80 yesterday and am having a blast with it. Really fantastic work!Anyhow, my only problem so far is that I can't seem to get the mute button to work. I have tried a number of different keystrokes from the dropdown and it never seems to do anything in the sim (e.g., the little M symbol never shows up). I made sure that no other key in FS was assigned to the keystroke I selected. I also looked in the FS2CrewInputMapper.CFG file and it looks like the keystroke is correctly entered there. Any idea what might be causing the problem?Thanks!
Glad to hear you like it!As for the mute button issue, I'm not sure.Did you try a joystick button?Pls advise.Best,

Share this post


Link to post
Share on other sites
Did you try a joystick button?Pls advise.
Thanks for the quick reply. I just tried a joystick button, but unfortunately it did not seem to work either.

Share this post


Link to post
Share on other sites
Thanks for the quick reply. I just tried a joystick button, but unfortunately it did not seem to work either.
Are you using any kind of exotic keyboard? Or it just a standard American style one?Try re-installing DirectX.

Share this post


Link to post
Share on other sites

Its not a very exotic keyboard...a Logitech G15 keyboard with US layout. I'll try re-installing DX later tonight.The only other thing I can think of is that maybe it is related to the fact that I don't have a dedicated USB headset, but instead am using the mic input of my normal soundcard. Anyhow, thanks very much for your help and troubleshooting.

Share this post


Link to post
Share on other sites
Its not a very exotic keyboard...a Logitech G15 keyboard with US layout. I'll try re-installing DX later tonight.The only other thing I can think of is that maybe it is related to the fact that I don't have a dedicated USB headset, but instead am using the mic input of my normal soundcard. Anyhow, thanks very much for your help and troubleshooting.
A USB headset is not a requirement.Do you have UAC disabled?Take a look at this file:FS2Crew2010\Versions\MadDog\FS2CrewInputMapper.CFGPaste its content into this thread.Cheers,

Share this post


Link to post
Share on other sites
A USB headset is not a requirement.Do you have UAC disabled?Take a look at this file:FS2Crew2010\Versions\MadDog\FS2CrewInputMapper.CFGPaste its content into this thread.
Thanks. Yes, I have UAC disabled (using Win7).Here is the contents of my FS2CrewInputMapper.CFG:
FS2_Main=BACKSPACE

Backspace is the last key I tried, which also does not work.

Share this post


Link to post
Share on other sites
Thanks. Yes, I have UAC disabled (using Win7).Here is the contents of my FS2CrewInputMapper.CFG:
FS2_Main=BACKSPACE

Backspace is the last key I tried, which also does not work.

I'm afraid I have no idea. There's no reason why the Mute Key shouldn't work for you.Please email me we'll do some additional tests.Best,

Share this post


Link to post
Share on other sites
Anyhow, my only problem so far is that I can't seem to get the mute button to work.
Did you notice that the mute function only works after you have switched the battery on? Before, pressing the mute button/key doesn't have any effect.I personaly thought there was a problem because I tried for long to see the "M" indicator on the FS2Crew panel before going further.... I reallised all was OK when I continued the start process.Cyril

Share this post


Link to post
Share on other sites
Did you notice that the mute function only works after you have switched the battery on? Before, pressing the mute button/key doesn't have any effect.I personaly thought there was a problem because I tried for long to see the "M" indicator on the FS2Crew panel before going further.... I reallised all was OK when I continued the start process.Cyril
That's correct.Does that solve the Original Poster's problem?Battery switch must be on first.

Share this post


Link to post
Share on other sites

LOL, I bet thats the problem. I will try that as soon as I get home. Every time I ran my tests, all I did was load up the AC from cold/dark and then hit the mute key to look for the "M". I never turned on the battery, and I don't think I ever tested it during flight (as I assumed it would not work). I will report back what happens. Thanks!!

Share this post


Link to post
Share on other sites

Yep, that was it. With the battery on it works great. Interestingly the Backspace key still does not work, but that is a minor problem (using Tab works). Thanks very much for your help!Anyhow, I will go ahead and make a quick idea for an improvement, though it is not a big deal. I would love an option to have it operate as a push-to-talk rather than a push-to-mute. There is often a lot of background noise in my house (aka, a screaming baby), so my choice would probably to have it muted all the time except when giving commands. One cool way that it maybe could be implemented would be as follows:1. When given a single tap quickly, the key would toggle mute on or off.2. When held down, the key would temporarily toggle to the other mode, and would return to the prior mode on release.In this way, FS2 would start unmuted, and holding the key down would mute it (as it works now). To change to a push-to-talk, all you would need to do is tap the key quickly to go into mute mode. Thereafter, holding the mute key would unmute the sound while the key is held.It seems logical to me, but maybe others would find it too complicated;)

Share this post


Link to post
Share on other sites
Yep, that was it. With the battery on it works great. Interestingly the Backspace key still does not work, but that is a minor problem (using Tab works). Thanks very much for your help!Anyhow, I will go ahead and make a quick idea for an improvement, though it is not a big deal. I would love an option to have it operate as a push-to-talk rather than a push-to-mute. There is often a lot of background noise in my house (aka, a screaming baby), so my choice would probably to have it muted all the time except when giving commands. One cool way that it maybe could be implemented would be as follows:1. When given a single tap quickly, the key would toggle mute on or off.2. When held down, the key would temporarily toggle to the other mode, and would return to the prior mode on release.In this way, FS2 would start unmuted, and holding the key down would mute it (as it works now). To change to a push-to-talk, all you would need to do is tap the key quickly to go into mute mode. Thereafter, holding the mute key would unmute the sound while the key is held.It seems logical to me, but maybe others would find it too complicated;)
Glad you got it figured out.You had me stumped there.I'll consider your request.Best,

Share this post


Link to post
Share on other sites
Yep, that was it. With the battery on it works great. Interestingly the Backspace key still does not work, but that is a minor problem (using Tab works). Thanks very much for your help!Anyhow, I will go ahead and make a quick idea for an improvement, though it is not a big deal. I would love an option to have it operate as a push-to-talk rather than a push-to-mute. There is often a lot of background noise in my house (aka, a screaming baby), so my choice would probably to have it muted all the time except when giving commands. One cool way that it maybe could be implemented would be as follows:1. When given a single tap quickly, the key would toggle mute on or off.2. When held down, the key would temporarily toggle to the other mode, and would return to the prior mode on release.In this way, FS2 would start unmuted, and holding the key down would mute it (as it works now). To change to a push-to-talk, all you would need to do is tap the key quickly to go into mute mode. Thereafter, holding the mute key would unmute the sound while the key is held.It seems logical to me, but maybe others would find it too complicated;)
I would like it too. I'ld prefer it in this way because if you consider that flying online the most of us already use a joystikc button for push-to-talk with ATC and it's complicated at the same time to hold another button to mute FS2C while speaking to ATC.

Share this post


Link to post
Share on other sites
I would like it too. I'ld prefer it in this way because if you consider that flying online the most of us already use a joystikc button for push-to-talk with ATC and it's complicated at the same time to hold another button to mute FS2C while speaking to ATC.
Hi,You don't need to use a separate key or joystick button for the mute button.Just use the same key or joystick button you're currently using as your ATC transmit key.So, as an example, if you're using Joystick button 3 to talk to ATC, assign the mute button to Joystick button 3.Same thing with the keyboard assignment.Best,

Share this post


Link to post
Share on other sites
Hi,You don't need to use a separate key or joystick button for the mute button.Just use the same key or joystick button you're currently using as your ATC transmit key.So, as an example, if you're using Joystick button 3 to talk to ATC, assign the mute button to Joystick button 3.Same thing with the keyboard assignment.Best,
:( Surprise, surprise......Thanks so mutch for the hint, I didn't know this would be possible...

Share this post


Link to post
Share on other sites
:( Surprise, surprise......Thanks so mutch for the hint, I didn't know this would be possible...
Considering what above, I think it's better to keep the present push-to-mute function, since with one key you can talk with online ATC and mute Fs2crew at the same time, which is perfect.Regards,Michele

Share this post


Link to post
Share on other sites

Very cool addon, thanks it has brought me back to FSX for the time being.I can't get the mute key to work. After saving my selection of the key I want to use for Mute, I checked the cfg file in C:\Documents and Settings\Jeff\Application Data\FS2Crew2010\Versions\MadDog and I don't have that file that would define the mute key.How do I get the config manager to save the key?Another question, when I am using the software, the Speech Recognition engine often thinks I am saying "Manual" all the time. Is this normal?JB

Share this post


Link to post
Share on other sites

JB,I'm not sure why you don't have the CFG file. Please email at admin *at* fs2crew.comThanks,

Share this post


Link to post
Share on other sites
JB,I'm not sure why you don't have the CFG file. Please email at admin *at* fs2crew.comThanks,
Ok Bryan, just sent you a mail..JB

Share this post


Link to post
Share on other sites
Ok Bryan, just sent you a mail..JB
We solved this.FYI, the cfg file is located in FS root folder- FS2Crew2010- Versions - ProductCheers,

Share this post


Link to post
Share on other sites

Hi,i was reading this post and thought that you might be able to help me.i have fsx deluxe edition and one day i came on to it and there was no engine sound from any plane, but i had menu music ATC and wind noises and stuff like that, but no plane noises. nothing is muted and nothing is turned down. i have realtek sound manager, also the sound files are full of sounds and has one .CFG file, even the default planes dont work. why is this.thank you in advance

Share this post


Link to post
Share on other sites
Hi,i was reading this post and thought that you might be able to help me.i have fsx deluxe edition and one day i came on to it and there was no engine sound from any plane, but i had menu music ATC and wind noises and stuff like that, but no plane noises. nothing is muted and nothing is turned down. i have realtek sound manager, also the sound files are full of sounds and has one .CFG file, even the default planes dont work. why is this.thank you in advance
Hi,Do you have FS2Crew? You might want to ask the general FSX forum that one :-)Cheers,

Share this post


Link to post
Share on other sites
Hi,Do you have FS2Crew? You might want to ask the general FSX forum that one :-)Cheers,
Oh ok, does this sight have the general fsx forum post??

Share this post


Link to post
Share on other sites