Archived

This topic is now archived and is closed to further replies.

terrypin

Getting into Autopilot mode?

Recommended Posts

I'm a novice with no serious flying intentions. But could someone help me get a plane into autopilot please? (Alternatively, in case I've missed it, please point me to it in the FSX help.)I assumed I couldn't do this in my usual Trike so I changed to a Cessna C172SP Skyhawk. I've loaded a flight plan. I've switched on the GPS instrument panel, and can see my simple flight plan there. I even managed to get the Cessna into the air.But what next? Where is the Autopilot switch that will take over? And will it keep me at whatever my altitude is when I switch it on?BTW, after experimenting with a few of its buttons, the GPS panel is now incomprehensible to me, as shown below. What do I do to reset it please?FSX-Cessna-GPS-1.jpg--Terry, East Grinstead, UK

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Information about the autopilot is here (use your own path to the Learning Center):Microsoft Flight Simulator X/FSWeb/LearningCenter/InTheCockpit/UsingAnAutopilot.htmInformation about the GPS is here:Microsoft Flight Simulator X/FSWeb/LearningCenter/Navigation/UsingTheGPS.htmQuick tip about the GPS (when you are still in this state): press the PROC button at the right bottom: I suppose you pressed it accidently: press it again to leave this mode.EDIT:Here is a quick pic to get you going:2r3b8zn.jpg

Share this post


Link to post
Share on other sites

Many thanks J van E, appreciate the fast reply. That's given me something to get started with.--Terry, East Grinstead, UK

Share this post


Link to post
Share on other sites

You're welcome. BTW About this question: 'And will it keep me at whatever my altitude is when I switch it on?' The answer is no: the default AP doesn't have an altitude hold function which would do what you said, even though the Learning centre does call this option an altitude hold...! :( . It's not the most realistic AP around... :( You HAVE to enter an altitude and pressing ALT will get and keep you there, so it will in the end hold the alt you entered, but that's not a real hold. For more realistic AP's you need addon's! Hm, I have the feeling I only made things sound more complicated now... :(

Share this post


Link to post
Share on other sites

Lost Among the Screens?Click and HOLD the "CLR" button for three seconds. It will return you to the default flightplan screen.

Share this post


Link to post
Share on other sites
Lost Among the Screens?Click and HOLD the "CLR" button for three seconds. It will return you to the default flightplan screen.
Thanks - that's a tip I badly needed!--Terry, East Grinstead, UK

Share this post


Link to post
Share on other sites
You're welcome. BTW About this question: 'And will it keep me at whatever my altitude is when I switch it on?' The answer is no: the default AP doesn't have an altitude hold function which would do what you said, even though the Learning centre does call this option an altitude hold...! :( . It's not the most realistic AP around... :( You HAVE to enter an altitude and pressing ALT will get and keep you there, so it will in the end hold the alt you entered, but that's not a real hold. For more realistic AP's you need addon's! Hm, I have the feeling I only made things sound more complicated now... :(
Thanks Jeroen. Once I've got into autopilot for the first time and at least got a plane turning, I'll tackle 'auto-altitude'. I am surprised that doesn't happen automatically though? If a real pilot flicks on autopilot, does he still have to maintain altitude manually?Meanwhile, I've been puzzled why the various 'Hold' shorcut keys I've tried never seem to work. For example, I gather that <Ctl + Z> is supposed to toggle altitude hold. And <Ctl + R> toggle airspeed hold. But if I'm flying and I use these neither seem to have any effect. I still have to maintain engine speed and altitude manually. Probably another elementary misunderstanding on my part.--Terry, East Grinstead, UK

Share this post


Link to post
Share on other sites
Meanwhile, I've been puzzled why the various 'Hold' shorcut keys I've tried never seem to work. For example, I gather that <Ctl + Z> is supposed to toggle altitude hold. And <Ctl + R> toggle airspeed hold. But if I'm flying and I use these neither seem to have any effect. I still have to maintain engine speed and altitude manually. Probably another elementary misunderstanding on my part.
Well, the reason <Ctrl+R> doesn't work is because the Cessna 172 don't have an auto-throttle, so the plane has no way to control the throttle position itself

Share this post


Link to post
Share on other sites
I am surprised that doesn't happen automatically though? If a real pilot flicks on autopilot, does he still have to maintain altitude manually?
No, the AP holds the altitude. What I was trying to say is that an autopilot often has a 'hold alt' button: when you press that it automatically holds the current alt. The default AP in FSX only has a altitude button that brings and (of course) keeps you at the set altitude (the alt you put in manually). It does not have a real 'hol'd button. However, DarkCharizma posted that ctrl-Z apparently does act as an actual hold button (holding the current altitude when you first press it).

Share this post


Link to post
Share on other sites

There is a 'proceedure' or sequence that must be used. When you use the 'Ctrl+Z' key it sets alt to whatever your alt is at NOW. But it does not 'hold' because by itself 'Ctrl+Z' does not 'activate' the auto pilot. So.....1. Press 'Z'. This activates auto pilot (like pressing 'AP' on panel).2. Press 'Ctrl+Z'. This SETS alt to your present alt. Since AP is active, NOW it will 'hold' that alt (comfirm by watching pitch trim wheel 'working'). But you can do this operation while in any view (ie: don't need to be in panel view).To un-do alt 'hold' press 'Ctrl+Z'. Then you can manually change alt (climb or desend) and then when leveled out you can again press 'Ctrl+Z' to hold your present alt. It's kinda convenient as you don't have to do the mouse roll of alt numbers and all that dumb fiddleing. Instant set of alt numbers-me yeah. But it sets to closest whole number, but a few clicks with mouse and you set alt to what you need (ie: alt+500). Makes simming life easier-I'm for that.CBNapamule

Share this post


Link to post
Share on other sites
There is a 'proceedure' or sequence that must be used. When you use the 'Ctrl+Z' key it sets alt to whatever your alt is at NOW. But it does not 'hold' because by itself 'Ctrl+Z' does not 'activate' the auto pilot. So.....1. Press 'Z'. This activates auto pilot (like pressing 'AP' on panel).2. Press 'Ctrl+Z'. This SETS alt to your present alt. Since AP is active, NOW it will 'hold' that alt (comfirm by watching pitch trim wheel 'working'). But you can do this operation while in any view (ie: don't need to be in panel view).To un-do alt 'hold' press 'Ctrl+Z'. Then you can manually change alt (climb or desend) and then when leveled out you can again press 'Ctrl+Z' to hold your present alt. It's kinda convenient as you don't have to do the mouse roll of alt numbers and all that dumb fiddleing. Instant set of alt numbers-me yeah. But it sets to closest whole number, but a few clicks with mouse and you set alt to what you need (ie: alt+500). Makes simming life easier-I'm for that.CBNapamule
Thanks a bunch guys, appreciate your patience. I feel frustratingly close - but still not quite there. I followed the procedure as follows. I got airborne from Gatwick in a Cessna Skyhawk SP Model 172. I have a flight plan (Gatwick to Cologne.) I'm in GPS mode. When I first looked at the GPS panel I could see my flight plan as a straight line from Gatwick, heading roughly SE, presumably ending in Cologne. My plane took off roughly west. I pressed Z to get into AP, followed shortly after by Ctl+Z. But the plane does not change direction. It continues west. And the altitude seems to gradually drop too.Am I missing some other glaringly obvious step please?--Terry, East Grinstead, UK

Share this post


Link to post
Share on other sites
Thanks a bunch guys, appreciate your patience. I feel frustratingly close - but still not quite there. I followed the procedure as follows. I got airborne from Gatwick in a Cessna Skyhawk SP Model 172. I have a flight plan (Gatwick to Cologne.) I'm in GPS mode. When I first looked at the GPS panel I could see my flight plan as a straight line from Gatwick, heading roughly SE, presumably ending in Cologne. My plane took off roughly west. I pressed Z to get into AP, followed shortly after by Ctl+Z. But the plane does not change direction. It continues west. And the altitude seems to gradually drop too.Am I missing some other glaringly obvious step please?--Terry, East Grinstead, UK
In order to get your aircraft to follow your route you need to make sure your NAV/GPS switch is switched to GPS. Turn your autopilot on then click on the nav button on the autopilot or press <CTL n> . Your aircraft should then turn onto course for your destination. That's a long trip in a C172 I hope that you have enough fuel to get there.

Share this post


Link to post
Share on other sites
Thanks a bunch guys, appreciate your patience. I feel frustratingly close - but still not quite there. I followed the procedure as follows. I got airborne from Gatwick in a Cessna Skyhawk SP Model 172. I have a flight plan (Gatwick to Cologne.) I'm in GPS mode. When I first looked at the GPS panel I could see my flight plan as a straight line from Gatwick, heading roughly SE, presumably ending in Cologne. My plane took off roughly west. I pressed Z to get into AP, followed shortly after by Ctl+Z. But the plane does not change direction. It continues west. And the altitude seems to gradually drop too.Am I missing some other glaringly obvious step please?
Yes. Step 4. :( 2r3b8zn.jpgCtrl-Z only controls the altitude. If I were you I'd forget about all keys you can press and simply do EACH step that's on the picture. That way you can't go wrong.EDIT:And btw I think it's better to try a few very (and I mean very) short flights where you can practice taking off, getting on course, landing etc. Going from Gatwick to Cologne in a C172... well, I wouldn't do it. Not until you really know all there is to now. But even then... ;)

Share this post


Link to post
Share on other sites
Yes. Step 4. :( Ctrl-Z only controls the altitude. If I were you I'd forget about all keys you can press and simply do EACH step that's on the picture. That way you can't go wrong.
Brilliant, you're a star Jeroen! As so often proves to be the case, it was my impatience holding me back.
EDIT:And btw I think it's better to try a few very (and I mean very) short flights where you can practice taking off, getting on course, landing etc. Going from Gatwick to Cologne in a C172... well, I wouldn't do it. Not until you really know all there is to now. But even then... ;)
Interesting! I'd drawn up a couple of flight plans in advance, one being a tour from Gatwick, around my home 10 miles away, some local waypoints matching a 5 mile walk, and back again to Gatwick. However my inaugural attempt was the Cologne trip, because I'd assumed that would be the simplest. I had no intention of completing it, merely establishing if I could get the plane to fly onto that straight line towards Cologne.Following your steps I have success! This time I included the vital step #4 I'd missed earlier, despite the fact that to me it seems to be sort of undoing step #1?So there really is no single hotkey that will switch on AP and start flying the flight plan at the current altitude? (What, lazy, moi?)Edit: After my first succesful AP run I'm back on the ground at Gatwick. Although this was only by changing to slew mode after several failed attempts to fly down. But I can't stop! I keep hitting F1, which is supposed to cut the engines, but moments later they seem to resume and I proceed forward. I tried putting the brakes on, by pressing the period key (how do you know if they're on or off BTW?), but that didn't stop me either.2nd edit: OK, minutes later I discovered Ctl+Sh+F1 ("Set mixture to idle cut-off", which I read as "Completely switch off engines", yes? Presumably I could do that instead of first using F1?) Anyway that did the job, and my Cessna is at least staitonary.--Terry, East Grinstead, UK

Share this post


Link to post
Share on other sites
Following your steps I have success! This time I included the vital step #4 I'd missed earlier, despite the fact that to me it seems to be sort of undoing step #1?
The NAV/GPS switch in step 1 is to set the autopilot to follow the course in the GPS instead of the NAV1 radio. The NAV button on the autopilot simply turns on the autopilots course following parts.
Edit: After my first succesful AP run I'm back on the ground at Gatwick. Although this was only by changing to slew mode after several failed attempts to fly down. But I can't stop! I keep hitting F1, which is supposed to cut the engines, but moments later they seem to resume and I proceed forward. I tried putting the brakes on, by pressing the period key (how do you know if they're on or off BTW?), but that didn't stop me either.2nd edit: OK, minutes later I discovered Ctl+Sh+F1 ("Set mixture to idle cut-off", which I read as "Completely switch off engines", yes? Presumably I could do that instead of first using F1?) Anyway that did the job, and my Cessna is at least staitonary.
Ctrl+Shift+F1 means no fuel, which obviously means the engines turn off. Now, in real life, a lot of people wouldn't be too happy if you stopped on the runway with your engines off

Share this post


Link to post
Share on other sites
The NAV/GPS switch in step 1 is to set the autopilot to follow the course in the GPS instead of the NAV1 radio. The NAV button on the autopilot simply turns on the autopilots course following parts.Ctrl+Shift+F1 means no fuel, which obviously means the engines turn off. Now, in real life, a lot of people wouldn't be too happy if you stopped on the runway with your engines off

Share this post


Link to post
Share on other sites
So there really is no single hotkey that will switch on AP and start flying the flight plan at the current altitude? (What, lazy, moi?)
LOL No, there isn't such a hotkey. :(
Thanks, I'm calling it a day but will report back tomorrow. I do have a joystick, although I don't believe it controls throttle.
What joystick do you have?

Share this post


Link to post
Share on other sites
LOL No, there isn't such a hotkey. :( What joystick do you have?
It's a Speedlinkhttp://www.speed-link.com/?p=2&cat=314...0204&paus=1On studying FSX Options > Settings > Controls I found this:I think I set it that way ages ago, to make it more consistent with its use in slew mode (rotation). BTW, I don't know what 'dial' refers to. There's no other rotating control on this joystick. Anyway I've now changed it so that it does alter throttle, at least for now.The remaining problem is braking. If I land and use F1 to cut the throttle (but don't want to use Ctl+Sh+F1 to remove power completely) how do I get my aircraft to stop? Pressing . to "Apply/Release" brakes briefly shows the word 'Brakes' in red, bottom left. But then plane doesn't stop moving along the ground. Also, I still don't know how to tell whether the brakes are On or Off!--Terry, East Grinstead, UK

Share this post


Link to post
Share on other sites
The remaining problem is braking. If I land and use F1 to cut the throttle (but don't want to use Ctl+Sh+F1 to remove power completely) how do I get my aircraft to stop? Pressing . to "Apply/Release" brakes briefly shows the word 'Brakes' in red, bottom left. But then plane doesn't stop moving along the ground. Also, I still don't know how to tell whether the brakes are On or Off!
The brake (.) works as a real brake: just clicking it once will only briefly apply brakes. It's not a toggle: you don't turn the brakes on or off: you apply them! Like in a car you will have to keep applying the brakes, so press that key (.) and keep it pressed until you have slowed down enough (you will see that red word all the time). It's not common practice to come to a complete stand on the runway: you should clear the runway when speed is low enough and when there is an exit.) When you are stopped and want to put on the parking brake, press ctrl-. (that's control-dot): that one IS a toggle: you will see a red message that the parking brake is 'on'.

Share this post


Link to post
Share on other sites
The brake (.) works as a real brake: just clicking it once will only briefly apply brakes. It's not a toggle: you don't turn the brakes on or off: you apply them! Like in a car you will have to keep applying the brakes, so press that key (.) and keep it pressed until you have slowed down enough (you will see that red word all the time). It's not common practice to come to a complete stand on the runway: you should clear the runway when speed is low enough and when there is an exit.) When you are stopped and want to put on the parking brake, press ctrl-. (that's control-dot): that one IS a toggle: you will see a red message that the parking brake is 'on'.
Thanks Jeroen, the penny drops! That makes sense at last.Re your advice about runways: don't forget that I'm using FSX in a most unusual fashion! Mainly for sight-seeing and planning walks/tours, or reviewing actual ones. A complement to using Memory-Map and Google Earth and other map and GPS tools. Mainly in slew mode, although I confess I'm getting more enthusiastic each day about slow flying. So I don't spend much time on runways, but quite a lot puttering around the Sussex, Surrey or Kent countryside (scenery from Horizon).It was a revelation to find that FSX simulates gravity so well. Great fun! Until now, before you put me straight about the brakes, I've been stopping either by cutting all fuel (Ctl+Sh+F1) or by pointing my Trike to a suitable hill! Snag with that is that, unless I've chosen very carefully, I sart rolling backwards again.BTW, is there some subtle trick to using F1? I find it slows the engine but it picks up again. Should I have to keep F1 pressed?--Terry, East Grinstead, UK

Share this post


Link to post
Share on other sites

F1 - cut throttle to zero (press once)F2 - decrease throttle (press and hold to repeat)F3 - increase throttle (press and hold to repeat)F4 - full throttle immediately (press once)

Share this post


Link to post
Share on other sites
F1 - cut throttle to zero (press once)
Thanks, but my point was that this doesn't appear to work. As I said, it reduces throttle (obviously not to zero though, or it would shut off!) and then increases again after 3 or 4 seconds. It's consistent here (with the Trike).--Terry, East Grinstead, UK

Share this post


Link to post
Share on other sites

So you are using F1. But your stick has a throttle 'wheel'. Did you EVER try using that wheel as throttle? If you calibrate stick, do you move that wheel 'full travel' (0 to 100 %) while at that part of calibration? You should. See pic below. If you don't want to use it (now that you 'found' it) then you MUST set it to '0' (zero) and wedge it in place (or duct tape it) where wheel does not move or FSX(and maybe FSUIPC) will 'read' any input (accidental or not) and you will have sporadic, and irratic, throttle control even if using F1 thru F4 keys. Move it around yourself (or let kids play with it) and then go try to use F1 thru F4 to comfirm. The IMPORTANT thing: Set to Zero in calibration. Wedge or tape it down. Go back to calibration and make sure it says 'Zero' in the wedged or taped down 'position' when looking in calibration for throttle 'wheel'.CBNapamule

Share this post


Link to post
Share on other sites
So you are using F1. But your stick has a throttle 'wheel'. Did you EVER try using that wheel as throttle? If you calibrate stick, do you move that wheel 'full travel' (0 to 100 %) while at that part of calibration? You should. See pic below. If you don't want to use it (now that you 'found' it) then you MUST set it to '0' (zero) and wedge it in place (or duct tape it) where wheel does not move or FSX(and maybe FSUIPC) will 'read' any input (accidental or not) and you will have sporadic, and irratic, throttle control even if using F1 thru F4 keys. Move it around yourself (or let kids play with it) and then go try to use F1 thru F4 to comfirm. The IMPORTANT thing: Set to Zero in calibration. Wedge or tape it down. Go back to calibration and make sure it says 'Zero' in the wedged or taped down 'position' when looking in calibration for throttle 'wheel'.CBNapamule
As I said in post #18 up-thread, the wheel was set to the Rudder. "I think I set it that way ages ago, to make it more consistent with its use in slew mode (rotation)." I did then briefly experiment with it as a throttle control instead, but quickly returned it to rudder. I only use it for Slew mode anyway. So obviously I don't want to 'duct tape' it! (BTW, I still don't know what 'dial' refers to in that earlier screenshot?)Anyone with any thoughts about my queries re F1 please? With a Trike stationary on the ground, RPM reads 3927. If I briefly press F1 it drops to about 1900 but immediately climbs again to around 3925, all of that taking about 5 seconds. If I hold F1 pressed for about 30 seconds, RPM gets down eventually to about 700. But after releasing F1, in about 5 seconds it climbs quickly back up to 3925.So F1 on my setup here doesn't work as you described or as FSX documentation (and my book 'Tips, Tricks and Trips') says. F2, F3 and F4 also behave in a similar 'temporary' way. For example, briefly pressing F1 gives a 10 second increase to about 6500, which then drops rapidly back to about 3925. So there seems no way to change engine speed permanently?--Terry, East Grinstead, UK

Share this post


Link to post
Share on other sites
Anyone with any thoughts about my queries re F1 please? With a Trike stationary on the ground, RPM reads 3927. If I briefly press F1 it drops to about 1900 but immediately climbs again to around 3925, all of that taking about 5 seconds. If I hold F1 pressed for about 30 seconds, RPM gets down eventually to about 700. But after releasing F1, in about 5 seconds it climbs quickly back up to 3925.So F1 on my setup here doesn't work as you described or as FSX documentation (and my book 'Tips, Tricks and Trips') says. F2, F3 and F4 also behave in a similar 'temporary' way. For example, briefly pressing F1 gives a 10 second increase to about 6500, which then drops rapidly back to about 3925. So there seems no way to change engine speed permanently?--Terry, East Grinstead, UK
Did you already try all this with the joystick disconnected? See what happens then!

Share this post


Link to post
Share on other sites