Jump to content

Archived

This topic is now archived and is closed to further replies.

Sesquashtoo

I think that I found the answer to the FSX-FREEZE UP..

Recommended Posts

....go to OPTIONS, and then choose SOUND. When in the Sound Screen, you will most likely find that both SOUND SOURCE masks/boxes show DEFAULT DEVICE. Pick the one DOWN from the DEFAULT DEVICE which should read the actual sound card you have installed. After you have that choice highlighted, then pick OK, and you are done. You should no longer have the dreaded FSX FREEZE whereby your animation has stopped but yet you hear the sound output from FSX. The only way to end this...is to use the TASK MANAGER to end FSX.You should no longer have this. I had this problem...but when I swapped out the DEFAULT DEVICE for my actual Creative X-Titanium (which was the next choice down), I had no further freeze up in flights, whether full-windowed, or windowed, whether in the cockpit, or using any of the SPOT Views.I believe that it truly is a SOUND CARD/DRIVER ISSUE which was put forward by others, but had not zoned in, or stumbled upon on how to correct this FSX hang-up.I think that by only having the DEFAULT DEVICE...it is in some way not allowing the actual sound card DRIVER to be controlling sound directly, and then causing that freeze and glitch.Whatever, and who knows for sure.... but when I swapped out from the Default Device setting...I ended this P.I.T.A.!If you have also chosen a less quality sound setting, you no longer need to...bring it back up to the high quality, but again....set your actual card as the sound source.Please post on this thread if my suggestion also cured your random FSX freezes at altitude, or whatever scenario was causing FSX to freeze up.Cheers!POST EDIT: I have been in a FL280 flight out of Boston's Logan en-route to Phoenix's Sky Harbor, for over two hours with no FREEZE showing its face! Usually, it came on about 10-15 minutes after I fired up FSX. The funny thing is...like the others...this 'symptom' just came on one day, where I never had it as a chronic issue. I know that I did upgrade my Creative Sound Driver Suite...but thought nothing of it at the the time. Hmmmm...but back to the flight on pause.Post Edit 2: I declare the FSX Flying Freeze officially tamed and dead! I have been flying over four hours non-stop, two hours in North American airspace, and two hours in European (from Berlin to a test field in Greece), with no stutter or freeze up of any kind. It is/was a sound driver issue with having the DEFAULT DEVICE highlighted in the two SOUND MASKS. Mitch

Share this post


Link to post
Share on other sites
Guest firehawk44

Hi Mitch,I haven't had one of these types of FSX freezes for a long time but took your suggestion to change the default device to my actual sound card (SB X-FI). I loaded my PMDG 747-8i for a short trip from SFO to SEA, and clicked the Fly Now button. Upon loading at SFO, I heard a 'click' then an immediate CTD and Microsoft had the info that there was a problem and Microsoft was looking for a solution. I immediately opened the Event Viewer and it told me that the crash was caused by the AEMODULE.dll which belongs to Flight One's Audio Environment software. So I'm returning to the default sound as my source. BTW, your solution sounds good to me and I have heard of this "solution" before but, logically (okay, I'm not Spock), if your solution was valid, wouldn't everyone who has the default sound set as the sound source eventually have a crash as you described? I mean it IS the default setting and we have thousand of people playing this game daily and I would think there would be several complaints every day that FSX crashed with the sound left running. So I don't think it's a solid solution (although it seems to be working for you so far). I have seen this problem before and its usually a fault of the sound card driver installation or the sound card is not properly seated or installed. Another reason (and it's definitely not your case) was memory starvation. This was an issue that occurred in FS9 and FS2K2 too. So hopefully your solution will fix the problem for many but I really think the actual reasons are as I outlined above.Best regards,Jim

Share this post


Link to post
Share on other sites
Guest Nils79

awesome tweak. people should try everything

Share this post


Link to post
Share on other sites
Hi Mitch,I haven't had one of these types of FSX freezes for a long time but took your suggestion to change the default device to my actual sound card (SB X-FI). I loaded my PMDG 747-8i for a short trip from SFO to SEA, and clicked the Fly Now button. Upon loading at SFO, I heard a 'click' then an immediate CTD and Microsoft had the info that there was a problem and Microsoft was looking for a solution. I immediately opened the Event Viewer and it told me that the crash was caused by the AEMODULE.dll which belongs to Flight One's Audio Environment software. So I'm returning to the default sound as my source. BTW, your solution sounds good to me and I have heard of this "solution" before but, logically (okay, I'm not Spock), if your solution was valid, wouldn't everyone who has the default sound set as the sound source eventually have a crash as you described? I mean it IS the default setting and we have thousand of people playing this game daily and I would think there would be several complaints every day that FSX crashed with the sound left running. So I don't think it's a solid solution (although it seems to be working for you so far). I have seen this problem before and its usually a fault of the sound card driver installation or the sound card is not properly seated or installed. Another reason (and it's definitely not your case) was memory starvation. This was an issue that occurred in FS9 and FS2K2 too. So hopefully your solution will fix the problem for many but I really think the actual reasons are as I outlined above.Best regards,Jim
---------------------------------------------------------------------------------Hi Jim,Well....all I can say, is that before I placed the actual sound card as the 'driver' for sound, I was getting nailed with this 'acquired' thing usually after about ten minutes in the air. Where it came from, I really have no idea as it was not always there. But...after having chosen rather than the DEFAULT DEVICE...I have no more lock-ups. FSX is a Witch's Brew at best. For myself, I now have a very stable FSX. If it helps another, then it's a good deal!Regards,Mitch
awesome tweak. people should try everything
Hello Nils,I don't know if the term 'tweak' applies here. It's just placing your actual sound card in the mask, versus having a 'default sound source' there. Jim tried it, and it didn't work for him. For myself, it did.Try it, if you are also experiencing those freezes! If it does the trick, you scored.Cheers!Mitch

Share this post


Link to post
Share on other sites

I noticed the setting would stay for a while and then revert back to defualt device after a few flights


Windows 10 Pro; P3DV4, ASP4, REXSF, AIGAIM, ProATCx, GSX 

I9-9900k @ 5.0; Asus Maximus XI Hero; Asus Strix GTX 1080ti; 32GB G.Skill Ripjaw DDR4 3600; 2X Samsung 1TB 970EVO; NZXT Kraken X63; Seasonic Prime PX-1000, Single 32" 4k Monitor 



 

Share this post


Link to post
Share on other sites
Guest Nils79

The only difference should be the identifier of the device (either the system wide default or a GUID from a generated list of available devices).@MitchHi Mitch,sorry, i was just joking because there are so many ultimate "tweaks" ;)As i wrote above, from my understanding, there shouldn't be any difference as long as it is the same device.

Share this post


Link to post
Share on other sites
Guest firehawk44
I noticed the setting would stay for a while and then revert back to defualt device after a few flights
I noticed that too when I went back in to change it back to the default because of my CTD and it had already reverted back to the default. Glad it happened to you too as I thought it was just my system that had automatically placed it back to the default because of my crash.Best regards,Jim

Share this post


Link to post
Share on other sites

Well...two hours into a flight at FL320 from Athens, Greece, to Heathrow, London, England.No more freezes!Here is the final tally:TBM set to 40Sound Masks (which stay the way I set them) set to one level below DEFAULT SOUND DEVICEBufferPools=0The FSX random freeze up with sound still playing in the background has been vanquished.Back to the flight. FSX is set for DAY as the scenery is fabulous between Athens-------->Heathrow, with flight plan mapped out by FSX's planner.Mitch

Share this post


Link to post
Share on other sites

  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Donation Goals

    AVSIM's 2020 Fundraising Goal

    Donate to our annual general fundraising goal. This donation keeps our doors open and providing you service 24 x 7 x 365. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. We reset this goal every new year for the following year's goal.


    18%
    $4,640.00 of $25,000.00 Donate Now
×
×
  • Create New...