Sign in to follow this  
FlyinIron406

New Official NVIDIA drivers!

Recommended Posts

Should fix the GeForce FX problems in 2004 for people who have those cards...www.nvidia.comRyan

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

I don't believe this - nevermind folks - it is NOT fixed according to the readme file. FS9 problems are still listed as an open issue that has not been resolved in the new driver...Ryan

Share this post


Link to post
Share on other sites

Regardless of this issue having been fixed or not, I've noticed a tremendous improvement in image quality with these drivers. FPS stay the same for me (locked at 24, lowest is ~15 @ KORD in Airport 2002 w/RFP 747-200 in external view mode). Textures (especially on buildings) seem so much sharper. I highly recommend these drivers if you want improved image quality without a loss in fps.-Max Cowgill

Share this post


Link to post
Share on other sites

Correct. Nvidia has yet to fix the display/driver issue in FS2004. I finally got a response back from Nvidia. I knew the 45.23 was not the fix because I am using 45.24 and it does not fix issues either.However, I am enjoying FS2004!Cheers!Cloud9

Share this post


Link to post
Share on other sites

Are they better quality than the recent July 29 Microsoft driver update for Windows XP? Or should I wait until they have Anti-Aliasing fixed? GeForce4 420MX. 64MegWindows XP HomeCompaq Athlon 2400+XP 640 Meg.

Share this post


Link to post
Share on other sites

I downloaded and installed the new drivers but now the registration number on the default aircraft is one big black box, the trees have black boxes around them and so have the lights:-roll . Is there any way to get rid of these? In the mean time I have reverted back to 40.72 drivers for my GeForce4 Ti4200 AGP8XRichard Wheatley

Share this post


Link to post
Share on other sites

Curious the black box issue and the mention of textures looking sharper. I suspect the drivers have enabled anisotropic filtering by default. If that is true, check FS2004 and make sure Trilinear filtering is selected...-John

Share this post


Link to post
Share on other sites

John, aniso is not enabled, I use rivatuner and have disabled it. I was running 8x AF for awhile but it didn't make much of a difference on blurries for me so I turned it off.-Max Cowgill

Share this post


Link to post
Share on other sites

Richard, I often had this happen to me with my old GF4 Ti 4200 when I tried out different drivers. The funny thing is, I'd switch from one driver to another and get the same effect you describe, then to another driver or the previous driver and the problem would disappear, then some time down the road I'd switch to the driver that was causing the problem and the problem wouldn't come back. Try switching to your previous driver or another driver and then back to the new ones (if you like). See if that works for you.I suppose this fix could be unique to my system though.-Max Cowgill

Share this post


Link to post
Share on other sites

Just download to the 30.82's and leave it at that, the most stable drivers EVER!......LMAO...Tom

Share this post


Link to post
Share on other sites

Grettings from the Darkside,Folks should not expect any changes in Better AA, Texture colors/quality nor any D3D performance boost as compared to the last official 44.03 drivers, as these drivers as do most all driver updates mainly fix compatability issues with various applications.Ripped from the 45.23 release notes under "C H A P T E R 2 : R e l e a s e 4 0 D r i v e r I s s u e s O p e n I s s u e s i n V e r s i o n 4 5 . 2 3":"

Share this post


Link to post
Share on other sites

I'm doing fine with the new drivers. I set the AA as the readme suggested (Application controlled and enabled AA in FS), and I'm getting surprisingly ok frame rates (averaging 15-20 fps in the skies). I have it locked to 25 and I'm sure if I turn off AA, I'll probably get up to 25.

Share this post


Link to post
Share on other sites

so, do these work to get rid of the "no 2d panel" problem! currently i am using the 45.20 off 3dguru or whatever. my last nvidia ones were 44.03

Share this post


Link to post
Share on other sites

If you're using AntiAliasing, then you should have no problems in Windowed mode. Otherwise, you'll have to turn off AntiAliasing (or use the APPLICATION mode).

Share this post


Link to post
Share on other sites

lately, the ones i have been running, the 45.20's, I run at AA4xs or something like that fine in 2004. that is in full screen

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this