Sign in to follow this  
1mikel151

Please help. Stutters...last gasp for FS9

Recommended Posts

Hi All,I have had the same issues with stuttering as Steve Lewis has had. The sim performance is outstanding in all other parts of a flight except my stutters occur at close approach and landing at 100-200 agl. The pauses and stutter are severe. Below are my specs:Athlon AMD 1 Ghz512 Meg RamNvidia ti4200 8X agp running at 4x agp (mobo constraint)64 meg videoCh yoke and Ch pedalsWin 98SEI have downloaded the frame friendly clouds (from Chris) and textures, fixed hard drive errors, defragged my hard drive, cleaned my registry, unistalled and re-installed FS9. I have Changed my agp aperture settings, confirmed that I have no irq conflicts, changed my pci latency settings using PowerStrip, removed my Aureal sound card completely, tried turning ALL things down in FS9 and all to no avail except...This is the first kicker...I get great performance at the settings I use, roughly 25-35 fps taking off from small airports with scenery detail and autogen set to sparse and one layer of cirrus clouds and traffic turned off. The sim is really smooth at all times except for the all important approach and landing.And now the second kicker...The stutters on approach and landing go away completely if I just turn autogen to full off. The framerate impact for the sparse setting in autogen is negligible and the sim runs great at takeoff and general flying. However during approach and landing the stutters and pauses come at exactly the same place everytime.I have been following Steve's odessey with the same issue and have been in touch w/ him via email. I have had no success in resolving the issue except to turn auto gen completely off. If autogen is turned off and I increase regular scenery I get a slight decrease in fps but no stutter. As soon as i turn autogen on to the lowest setting the stutters come right back.I have to admit I do enjoy some eye candy. Why would autogen cause stuttering at 800 ft agl and then 100 ft agl on approach and landing only? I have tried several small airports and the stutters are at the same time everytime. It seems to be an issue with displying autogen objects from a certain angle or perhaps new objects are loaded at this time?My last gasp may be to upgrade to XP. :~) But FS2k2 always runs great on this machine/OS combo, no pauses and great fps all around.Any more advice would be greatly appreciated.I am glad Steve got this resolved and hope others do too.Best regards,Tom

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Tom, Not so fast. I resolved the stutters and pauses on take off but as I approach my destination, the stutters start up again. Now, I have my Autogen on the default not Sparce. I seem to get the stutters/pauses on approach even with no autogen running :-hmmm. It's not nearly as bad as it was before but I was flying into Newark last night and the sim stopped for about 2 minutes then proceeded normally. The sim seemed to be redrawing either the arrival airport scenery or the clouds. Either way, it doesn't make any sense for the sim to just stop at the most inopportune time in your flight. You don't know if it's going to stop for a second or a minute. Doesn't make any sense. Went to the Cleveland air show today at Burke Lakefront (Blue Angels were awesome as usual....) I came home to fire up FS2004 and set up the Lear 45 at Burke. I just did a take off and one turn VFR. I was getting 29.5 fps (locked at 30). I had the sim download the weather and there were several clouds about. I took off on runway 6R and as I turned west over Lake Erie everything was very smooth. BUT, as I turned on base at about 15 miles out, the slide show began. The sim seemed to be having a very difficult time rendering the clouds. No pauses but severe stuttering until I was at 2,000 ft and about 5 miles out. This should not be happening. I have the default 3D cloud set up (60 mile vis, 40 mile cloud draw, and 50% 3D clouds)... There must be some conflict with Win98 and the GeF 4000 series video cards. Shouldn't have to have a Radeon 9700 to run this sim. If you haven't set yourself up at Burke you should do so. It's right in downtown Cleveland and the Browns stadium is off to the west end. The skyscrapers are all pretty much there, too. Looks very realistic. I flew this morning in FS2002 and other than the clouds it was a wholly different experience.Steve

Share this post


Link to post
Share on other sites

hey, capt. don't fret I get the same with xp. I'm about ready to through the sim in the trash. go back to fs8

Share this post


Link to post
Share on other sites

Hi, There is no pause in fs2004, If you have them it is not normal. My card, Gforce4 TI 4200 8X 128 MB 8X. Windows XP PRO 2.53 GHZ, 512 Ram, ASUS P4P800 8X. I have seen these issue on some users and others none.If you computer is not able to handle the weather, FSUIPC have a limit clouds layer and others tweaking, anyways in fs2002 you are limited to 2 layers in 3d clouds, and limited on flat clouds sheet the higher altitude abovew the aircraft and below the aircraft,ThanksChris Willis[link:fsw.simflight.com/FSWMenuFsSim.html]Clouds And Addons For MsFs

Share this post


Link to post
Share on other sites

I have the same issue and I have investigated exactly when this happens. With the help of this information, others have figured out exactly what causes this problem.Autogen objects are created as you get close to a ground tile, but the data is not released until you get very far from the tile (over three minutes away at 250kts GS). This means that a lot of useless autogen data (data for currently not visible objects) is accumulated. FS2002 did not behave this way, autogen data was released properly as soon as the autogen objects dissapeared.Note that this has absolutely nothing to do with the actual visibility of the objects. The objects do dissapear when you get furhter from them, but they are not "released" by the sim.The problem is most apparent when flying an approach. What happens is that as you fly toward the airport, data accumulates. As long as you keep flying in the same direction, this is not a problem and the framerate will be good. Apparently the accumulated Autogen is not processed when you're not facing it. However, during an approach you often turn and come back the same way. An example: Approach to KSEA RWY 34 (any one of them), comming in from the north.1. As you come in from the north, you have to fly over downtown Seattle. So far, framerate will be good.2.When executing the approach to 34, you will fly past the airport, then circle and land facing downtown Seattle. As you turn toward Seattle, FPS will tank.3. Even though the autogen objects for downtown Seattle are not actually VISIBLE, the data has still accumulated and the autogen is using up CPU cycles4. At this point, go into display options and turn Autogen OFF and click OK. Then, go into display options again and turn it back to the setting you were using5. This clears the accumulated data and returns the FPS to normal.

Share this post


Link to post
Share on other sites

I have crashed at an airport during a slide show landing and after the flight reset, the fps were normal?MB

Share this post


Link to post
Share on other sites

Chris, I have FSUIPC 3.05 Payware and it doesn't make a difference. Anyway, I was using FS9's weather engine and not ActiveSky 1.9 or FSMeteoe 6.0 (I have both). And you don't have to fly right over a dense city and turn back for the slide show. I've been using Radar Contact and you get a 30 degree approach at about 23 miles out and as soon as you turn that 30 degrees onto final the slide show begins. I haven't tried a flight yet with ActiveSky or FSMeteoe since I've re-installed FS9. I'll do that this morning and see what happens. I've also turned off my Autogen completely (looks pretty barren without any trees, I must say).... So, my next flight will be without Autogen, also.Steve

Share this post


Link to post
Share on other sites

It seems you have tried everything so I doubt this will work, but have you tried running enditall? You should be able to find enditall2 on the web quite easily. This will kill background processes. I have seen stutters on other games which have been cured by this. I don't hold out too much hope in your case, but it is well worth a try and will quite likely give you some fps improvement anyway.

Share this post


Link to post
Share on other sites

If you haven't tried this,setting these properties in my FS9.CFG file solved the issues for me:[DISPLAY.Device.NVIDIA Whatever you've got]TextureAGP=0PanelAsTexture=0TriLinear=1RenderToTexture=0(Also, Windows 98 is a virus...)HTH,

Share this post


Link to post
Share on other sites

I also improved the smoothness of FS9 by inserting some of the Display settings into FS9.cfg.But surprisingly, the biggest improvement came yesterday when I was trying to work out my problems with studders by playing with the autogen settings (like so many others here). I found that when I turned off my AI Traffic and restarted the sim from the OS desktop, the sim was silky smooth, even with my autogen set to Dense (I kicked it up to Very Dense and higher, with marginal studders). I never noticed this difference before because I was not restarting my sim after making an adjustment. I assumed that when I adjusted a display setting and saw the sim reload terrain and textures, that I was going to see the true results of my change.After shutting down the sim and restarting, I then turned on AI Traffic with a setting of only 20% and immediately I was getting studders. Moving the slider up to 70% and 100% yielded the same amount of studders, so the quantity of AI was not the issue on my system. I then turned off AI and I was still getting the studders. I closed the sim and restarted with AI off and again, smooth frame rates.So there are 2 items here to consider if you have an O/S prior to WinXP/2000. Win9x & WinME are not the best at memory management. I would recommend that you restart the sim after you make a tweak to AI, Autogen, or whatever. Secondly, start by turning off both AI and Autogen and see if you get studders. This would be your baseline of reference. Then try one and they try the other (after restarting!). Try this with the clear weather theme so your cloud settings don't affect your tests.Also check your DirectX input tab and turn off any Force Feedback that may be enabled.I hope you find a solution. :)BruceDell 8100 with PowerLeap 2.6 P4512mb PC800 RDRAMGeForce3 Ti500 64mbSoundBlaster LiveDirectX 9bWinME

Share this post


Link to post
Share on other sites

ok, none of that is my problem I have a system alomost exactly like chris willis new drivers etc. and this is just unflyable. no conflicts tried almost every tweak mentioned so far. the stutters are driving me crazy.

Share this post


Link to post
Share on other sites

Seems like having a 1 gig CPU and 4X AA is really pushing it, I am surprized you can get off the tarmac. We have the same CPU speed, but you have a faster card, but I have more memory and XP. Most everything maxed, NO AA, clouds default, no real weather and I get 20+ with an occasional stutter, but otherwise, no problems.Regards, Michaelhttp://mysite.verizon.net/res052cd/mybannercva1.jpgCalVirAir International VAwww.calvirair.comCougar Mountain Helicopters & Aviationwww.cgrmtnhelos.com

Share this post


Link to post
Share on other sites

Hi Michael,I think you misread my spec. I am running 4x agp not 4xAA. I run with AA off because it does not make a big enough visual difference for the frame rate impact it has.Thank you all very much for your input I will keep trying suggestions.I uninstalled FS9 defragged and cleaned up my reg and have seen a decrease in the studders it is now quite flyable with no ai traffic and sparse setting for autogen, global max texture set to high, terrain detail set to 50%, terrain texture set to high, weather change rate to none, and effects set to low. If I raise effects to the next level up the studders appear. This is not a big deal for me as I fly mostly in the cockpit any way. I am still trying out suggestions from other in this forum. I don't expect to be able to run with sliders all turned up but the thing was it ran great at the settings that I was very happy with but landing induced severe stutters.Thank you all for the time you took to reply in this forum. I hope others get this issue resolved sufficiently to make it enjoyable to fly.Thanks and best regards,Tom

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this