Archived

This topic is now archived and is closed to further replies.

Guest yienmaster

RealAir Scout in Windows 7 - Problem?

Recommended Posts

I just got a new PC and am now running FSX on Windows 7. My RealAir Scout 2007 was working perfectly on XP, but on Windows 7 the "Panel Config" utility no longer has any effect. I am stuck with the default setup which is missing vacuum gauges and autopilot.Is this a problem with Windows 7 not allowing the panel config program to write to the .cfg file? I've noticed I have to take extra steps to edit .cfg files in Windows 7, with all of its extra security measures in place.Is there a way to manually edit the panel.cfg to display the gauges?I just figured there must be other FSX junkies who've switched to Windows 7 recently and maybe had similar problems.Thanks a lot!

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

There is one thing you can try that fixed the same problem for me. Download and run the Flight1 FSX/FS9 Registry Repair Tool from this page. Even though there seemed nothing wrong with my registry settings running the tool solved the issue. There's a good chance the registry repair tool will make your panel configurator work again as well.

Share this post


Link to post
Share on other sites

No dice.I'm gonna try disabling all the Windows 7 security stuff, and then I'm out of ideas.Does anyone know how to edit the panel.cfg to show or hide instruments manually?

Share this post


Link to post
Share on other sites

Disabling User Authentication Control still didn't make the panel config program start working. I guess I'm stuck with no autopilot in my favorite plane. Great.

Share this post


Link to post
Share on other sites

When you installed the package, did the installer find your FSX folder correctly? I'd suggest uninstalling and reinstalling the Scout and check this. If it doesn't find your FSX path, abort the installation and run the registry repair tool. After that, try again.

Share this post


Link to post
Share on other sites

Very good idea. I'll give it a shot after work tonight.I did find a solution to the read-only thing windows 7 has been doing in the form of a "take ownership" setting for a folder, but that still didn't solve the problem (although it takes some of the headache out of tweaking config files that windows thinks are important).I've just got to make a note of my custom eyepoint for the Scout, and hopefully a reinstall following the registry repair will find my FSX directory correctly and finally get that panel config working.Thanks for the ideas so far. I'll keep you posted.

Share this post


Link to post
Share on other sites

Try it in this order; uninstall the Scout, run the registry repair tool, reinstall the Scout. That worked for me once. (Strangely enough one day it stopped working again, but even then running the reg repair tool worked, without uninstalling the Scout). I hope you'll solve the issue, good luck!

Share this post


Link to post
Share on other sites

Well, I give up. I tried it in that exact order, but the panel config is still completely useless. I can't imagine what's going wrong, it should be so simple, but I'll just chalk it up to another windows 7 quirk. I'm starting to get over the sexy new look of 7 (over XP) and starting to notice all the new problems it is presenting me. Mostly by assuming I'm an idiot and I want the OS to control everything for me. At least FSX runs like a dream compared to on my old PC.Thanks for your help. If anyone else has any ideas, or knows how to manually edit .cfg files to show or hide gauges, please let me know.

Share this post


Link to post
Share on other sites

Too bad it didn't work. Have you checked panel alterations in the sim? Or did you only look if the panel.cfg was changed? If the latter is the case, this file doesn't change, it's the Panel Config.xml file in the Config folder (inside the panel folder) that counts. When I had problems I tried to manually edit the Panel Config.xml file to alter the panel, but even that wasn't picked up within the sim. It's a complete read/write problem. Not only Windows 7 by the way; I first encountered this annoying issue when I ran Vista. You could try a complete reinstallation of FSX, but that's a hassle. Have you tried contacting Realair? I exchanged a few e-mails with Rob Young about this. They may have investigated further.

Share this post


Link to post
Share on other sites
Well, I give up. I tried it in that exact order, but the panel config is still completely useless. I can't imagine what's going wrong, it should be so simple, but I'll just chalk it up to another windows 7 quirk. I'm starting to get over the sexy new look of 7 (over XP) and starting to notice all the new problems it is presenting me. Mostly by assuming I'm an idiot and I want the OS to control everything for me. At least FSX runs like a dream compared to on my old PC.Thanks for your help. If anyone else has any ideas, or knows how to manually edit .cfg files to show or hide gauges, please let me know.
Hi yienmaster,Sorry to hear of your frustrations. We do have many customers with Win 7 but without your config issues. I see the thread has already covered most possibilities. If you have "repaired" FSX and totally disabled Windows User Account Control, then the other thing is to RIGHT CLICK on the config app and "run as administrator". You can also try running it in emulation mode (assuming your Win 7 has that option), and run as though your system was XP.Other than that I am stumped as to a solution. Have you tried re-installing the Scout package AFTER the other steps you took?Kind Regards,Rob - Realair

Share this post


Link to post
Share on other sites
Hi yienmaster,Sorry to hear of your frustrations. We do have many customers with Win 7 but without your config issues. I see the thread has already covered most possibilities. If you have "repaired" FSX and totally disabled Windows User Account Control, then the other thing is to RIGHT CLICK on the config app and "run as administrator". You can also try running it in emulation mode (assuming your Win 7 has that option), and run as though your system was XP.Other than that I am stumped as to a solution. Have you tried re-installing the Scout package AFTER the other steps you took?Kind Regards,Rob - Realair
I've experienced the same problem recently. Repairing the registry worked for me.Thanks!

Share this post


Link to post
Share on other sites
Well, I give up. I tried it in that exact order, but the panel config is still completely useless. I can't imagine what's going wrong, it should be so simple, but I'll just chalk it up to another windows 7 quirk. I'm starting to get over the sexy new look of 7 (over XP) and starting to notice all the new problems it is presenting me. Mostly by assuming I'm an idiot and I want the OS to control everything for me. At least FSX runs like a dream compared to on my old PC.Thanks for your help. If anyone else has any ideas, or knows how to manually edit .cfg files to show or hide gauges, please let me know.
Here are my settings:[VCockpit01]size_mm=512,512pixel_size=1024,1024texture=$RASScout_CFGbackground_color=7,7,7gauge01=RASScout07_Radios!NavCom1, 0, 0, 512, 62gauge02=RASScout07_Radios!NavCom2, 0, 62, 512, 62gauge03=RASScout07_Radios!ADF, 4, 127, 334, 49gauge04=RASScout07_Radios!Xpndr, 5, 181, 341, 56gauge05=RASScout07_Radios!Autopilot, 5, 242, 307, 57gauge06=RASScout07_Radios!DME, 4, 302, 266, 43gauge07=Config!RealView, 300, 301, 1, 1gauge08=RASScout07!Engine_Readouts, 0, 348, 177, 110gauge09=RASScout07!Engine_LEDs, 0, 457, 273, 55gauge10=Config!Panel Config, 300, 302, 1, 1gauge11=Config!Engine Cut, 300, 303, 1, 1gauge12=RASScout07!AP Trim Boost, 300, 304, 1, 1

Share this post


Link to post
Share on other sites