Sign in to follow this  
Guest SoarPics

Catalyst v3.9 Available

Recommended Posts

Another release and another problem sorted according to the release notes;Setting the game Flight Simulator 2004 to display at 1024x768 or 1280x1024 followed by starting a new flight no longer results in the menu being flipped just before the new flight is about to begin they also resolve any problems people may have been having with cards overheatingavailable here http://www2.ati.com/drivers/wxp-w2k-cataly...28m-011774c.exe

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

So......has any brave soul here tried them? Has the screen flashing demon finally been exorcised?Tim13

Share this post


Link to post
Share on other sites

Yaay! Yes, I can confirm that (at least on my rig) the flashing is a thing of the past. The transitions between the various views (spot, VC, etc.) are also much improved. In fact, they're instantaneous. I'm very pleased.

Share this post


Link to post
Share on other sites

I too can confirm that the flashing menu problem is finally a thing of the past. Switching between views is much quicker. I didn't realize just how much the menu flashing was detracting from the game until it was gone. Now I realize just how annoying it really was! lol.Tim13

Share this post


Link to post
Share on other sites

Awesome - I knew they'd fix it. Time to think about that new system... ;)Ryan

Share this post


Link to post
Share on other sites

Hi, thanks for the great news. Does the new driver also reduce bluriness??japangg

Share this post


Link to post
Share on other sites

Another interesting thing I noted: with the 3.8's, the graphics fan would tend to slow down and then speed up, like they were trying to keep the temp at a certain value with the fan. With the 3.9's that is gone and the fan speed seems to be constant, and at a lower RPM (at least quieter).In 2D cockpit, where I do most of my flying, using the hat switch to see other views seems to be slower but I have not had a chance to give this a more complete test yet.Larry S.P.S. Flying with real world weather with updates is the "cat's meow" as long as its a DSL connection to the internet. No pauses or other problems and frames remain good. I've gotten to turning off the counter unless I'm testing new drivers or A/C. On my old dialup, it was pretty stuttery.

Share this post


Link to post
Share on other sites

Thanks for the info! now installed and works like a charm with FS2004 with no more black screen flicker between mode changes and popup window displays. It also is faster to switch views in my opinion ('s' key) as well as with the joy-hat! There is even a slight increase in performance at AAx2 and AFx4 Quality (not tested the other modes) which looks like less hesitations sometimes (fluid)! But this may well be an impression only!Hope this helps!

Share this post


Link to post
Share on other sites

These new Cat 3.9's cured the flashing menus for me too! Like others have mentioned, I also noticed that the menus now load up much faster as well as cycling views with the 's' key is much quicker now too.Radeon 9600 Pro 256MB DDRRob

Share this post


Link to post
Share on other sites

This appears to be a great set of drivers. The flashing problem is cured of course (never so much a problem for me because I run in windowed mode), and performance is good. In my FRAPS benchmark, I gained 2fps over the previous set of drivers (and the Omega's). Avergage fps on my standard benchmark (approach and landing at KSEA runway 34L) was 29fps (versus 27fps previously) and was peaking at 33fps (versus 30fps previously).Looks like a keeper.

Share this post


Link to post
Share on other sites

Jimmy, what are your sliders set at? I have a similar system, but with a 9800 Pro, and I'm getting 12fps or sometimes lower anywhere near KSEA. My sliders are pretty well maxed except a few that are down 1 notch. If your sliders are similar, what tweaks are you using!!!!? billg

Share this post


Link to post
Share on other sites

Installed last night and FS 2004 now crashing. I've only tried this a few times but it's repeatable. 3.8 drivers worked fine. Taking off from SEA Rwy 34 in the BE350,climb to 3000 with autopilot on, when level (about half way to downtown), cycling views with the "s" key crashes my computer to a hard reset when changing to the chase plane view. Using AIW 9800 Pro on Athlon 2K+ with 1 GB RAM. Also, barberpole building texture effect still there.

Share this post


Link to post
Share on other sites

Skyking I had similar problems when using 3.8's. I am half way through my flight and go to spot plane. Then I get screeching out my speakers and flight sim freezes. Have to cold boot. If that is what you are experiencing let me know. This has happened since I installed my new sound card so I am not sure if it is a video prob you are having.

Share this post


Link to post
Share on other sites

Make sure your chipset drivers and sound card drivers are properly installed and updated. Also browse the Creative site, if that's the SC your running for a patch that may possibly help both of your situations.The poor VC gets blamed for everything :(Bobby

Share this post


Link to post
Share on other sites

Thx FPSFREAK. I AM using the SB audigy 2. Not aware of patch for this but I believe I have the latest and greatest drivers.As for these new ATI drivers, nice improvement. Usuallu when I switch to spot plane it took a second or two to load the paint job on my plane but it is instant now.

Share this post


Link to post
Share on other sites

I must have had a bad driver install. Reinstalled 3.9 and it works fine. Flashing is gone but still some strange effects on buildings in downtown Seattle, although it doesn't appear to be as bad as with 3.8. I've got the AA and AF maxed in the 3D setup for the card.I'm using a Hercules Fortissimo 7.1 sound card because I couldn't get my nVidia built-in sound to work with the AIW TV ap.

Share this post


Link to post
Share on other sites

It's fixed my smearing text problem....90% of the time. If I use one of the larger Posky aircraft it seems to suck the juice out of my sytem and the smearing comes back, as do a bunch of blurries in spot view. But all in all, I'm pretty pleased. Just have to resign myself to not using Posky. :-(

Share this post


Link to post
Share on other sites

Any word on whether it matters with 3.9's if VPU recover is active or not from a stability standpoint?I had fairly nasty stability problems with 3.8 that weren't so easy to resolve, so I'm holding off with installing 3.9's until I hear more opinions.Thanks,Joe

Share this post


Link to post
Share on other sites

I consider VPU Recover to be a work in progress... thus I leave it off.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this